在线检测未来函数

通达信组合寻底指标公式

来源:Internet,编辑:股旁网,2014-12-20

N:=5;
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(A1,10,0,4,0),COLOR770077;
STICKLINE(A1,10,0,3,0),COLOR990099;
STICKLINE(A1,10,0,2,0),COLORBB00BB;
STICKLINE(A1,10,0,1,0),COLORDD00DD;
STICKLINE(A1,10,0,0.3,0),COLORFF00FF;
DRAWTEXT(A1,11,'财富临门'),COLORRED;
财富临门:A1,NODRAW;
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
J0:=(HIGH+LOW)/2;QJ:=EMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
VAR44:=SMA(RV,3,1);
VAR55:=SMA(VAR44,3,1);
KK:=EMA(SMA(RG,3,1),2),COLORFFFFFF;
DD:=SMA(KK,3,1),COLOR00FFFF;
DRAWTEXT(CROSS(VAR44,VAR55) AND CROSS(KK,DD),10,'共振'),COLOR00FFFF;
共振点:=(CROSS(VAR44,VAR55) AND CROSS(KK,DD));
STICKLINE(共振点>0,0,40,2,0),COLOR008888;
STICKLINE(共振点>0,0,40,1.5,0),COLOR00AAAA;
STICKLINE(共振点>0,0,40,0.8,0),COLOR00DDDD;
STICKLINE(共振点>0,0,40,0.3,0),COLOR00FFFF;
VAR1P2:=(CLOSE-LLV(LOW,55.144))/(HHV(HIGH,55.144)-LLV(LOW,55))*80;
VAR2P2:=SMA(VAR1P2,7,1);
VAR3P2:=SMA(VAR2P2,5,1);
起飞:IF(CROSS(VAR2P2,VAR3P2) AND VAR2P2<20,40,0),STICK,COLOR00FF7F,LINETHICK2;
DRAWTEXT(CROSS(VAR2P2,VAR3P2) AND VAR2P2<20,35,'起飞'),COLORFFFF00;
DRAWTEXT(CROSS(VAR2P2,VAR3P2) AND VAR2P2<22,20,'★'),COLORRED;
主流资金:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORMAGENTA,LINETHICK2;
XG3:CROSS(主流资金,10);
DRAWICON(XG3=1,24,14);
{A88:=(C+H+O+L)/4;
套马索:=XMA(A88,32)*0.9;
套马杆:=MA(CLOSE,20);
栓马桩:CROSS(套马索,套马杆);
STICKLINE(FILTER(栓马桩,5),0,35,3,0),COLORFF00FF;
DRAWICON(FILTER(栓马桩,5),40,9);
DRAWICON(FILTER(栓马桩,5),35,9) ;
DRAWICON(FILTER(栓马桩,5),20,9) ;
DRAWICON(FILTER(栓马桩,5),15,9) ;
DRAWICON(FILTER(栓马桩,5),10,9) ;
STICKLINE(FILTER(栓马桩,5),0,15,15,0),COLORCYAN;
DRAWTEXT(FILTER(栓马桩,5),35,' 快马'),COLORYELLOW;}
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
XG:CCI<-100 AND CCI>REF(CCI,1)AND(REF(C,1)-C)/REF(C,1)*100>3;
DRAWICON(XG=1,10,26);
小底:FILTER((CROSS((EMA(CLOSE,2)-EMA(CLOSE,10)),EMA((EMA(CLOSE,2)-EMA(CLOSE,10)),2)) AND EMA((EMA(CLOSE,2)-EMA(CLOSE,10)),2)<0 AND CROSS(C,MA(C,20))),90);
DRAWICON(小底=1,8,27);
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),21,1)/SMA(ABS(CLOSE-AA),21,1)*1000;
HHH:=BBB-LLV(BBB,27);
CCC:=LLV(BBB,27)-BBB;
QQ:=(MA(HHH,2)*3+HHH*13)/16,COLORFF00FF,LINETHICK1;
SS:=(MA(CCC,2)*3+CCC*13)/16,COLORFF00FF,LINETHICK1;
GG:=MA(HHH,5),LINETHICK1,COLORGREEN;
MM:=MA(CCC,5),LINETHICK1,COLORGREEN;
WW:=IF(QQ<GG,SS,MM),LINETHICK1,COLOR0000FF;
EE:=IF(SS<MM,GG,QQ),COLORFFFFCC,LINETHICK1;
买:=IF(EE-WW<5.6,200,0);
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH),COLORRED;
买AA:=黄金 AND RSVV<VARB2-2;
短牛:买AA>0,COLORRED,LINETHICK2;
DRAWICON(短牛=1,1,1);
RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*10000;
RSV2:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*10000;
短线:=SMA(SMA(RSV1,3,1),3,1)+3*STD(CLOSE,21),COLOR00FF00;
中线:=SMA(RSV2,5,1)+2*STD(CLOSE,37),COLORRED;
RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*10000;
长线:=SMA(RSV3,5,1),COLORYELLOW;
黄金坑:短线<2000 AND 中线<2000 AND 长线<2000;
DRAWICON(黄金坑=1,12,25);
V1:=EMA(CLOSE,5)-EMA(CLOSE,340);
V2:=EMA(V1,144);
V3:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
卖出:=-1*IF((CROSS(98.5,V3) AND V1>V2) AND COUNT(V3>97,3)=2,20,0)+90;
买入:=IF(CROSS(V3,5) AND V1<V2,20,0)+20,COLORYELLOW;
{2}
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),13,1)*4;
VAR3:=EMA(VAR2,13);
VAR4:=LLV(LOW,34);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:=STICKLINE(VAR5>REF(VAR5,1),0,VAR5,7,0 );
主力进场和:=SUM(主力进场,20);
{3}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D2:=SMA(K,3,1);
JJ:=9*(3*D2-2*K);
J:=((3 * K) - (2 * D2));
MAIRU:= CROSS(K,D2) AND K<20;
MAICHU:= CROSS(D2,K) AND D2>80;
快线:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
慢线:=SMA(快线,3,1);
空:=SMA(慢线,3,1);
BB:=IF(BARSLAST(CROSS(慢线,快线))>=3 AND CROSS(快线,慢线) AND 慢线<30,20,0);
买点:=IF(BB AND 买入>25 AND 主力进场和>5,35,0)+10,COLORYELLOW;
DRAWICON(买点=45,2,1);
VAR2B:=(C-MA(C,6))/MA(C,6)*100;
VAR3B:=(C-MA(C,12))/MA(C,12)*100;
VAR4B:=(C-MA(C,24))/MA(C,24)*100;
VAR5B:=(VAR2B+2*VAR3B+3*VAR4B)/6;
线:=MA(VAR5B,3);
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((C- LC),0),5,1) / SMA(ABS((C-LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((H- LOW),ABS((H-REF(C,1)))),ABS((L- REF(C,1)))),10);
HD:=(H-REF(H,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD>0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD>0) AND (LD > HD)),LD,0),10);
PDI:=((DMP*100)/TR1);
MDI:=((DMM*100)/TR1);
ADX:=MA(((ABS((MDI-PDI))/(MDI+PDI)) * 100),5);
AV:=(RSI5 + ADX);
WR10:=((100 *(HHV(H,10)-C)) / (HHV(H,10) - LLV(L,10)));
NEW:=(RSI5 - WR10);
回调:=(AV + NEW);
GG2:=CROSS(回调,0);
KTB:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1);
DTB:=SMA(KTB,3,1);
JTB:=3*KTB-2*DTB;
出击:=CROSS(CLOSE,REF(EMA(DMA((((HIGH+LOW)+(CLOSE*2))/4.15),0.9),3),1))AND JTB<55;
狙击:=CROSS(J,0) AND 线<=-7 AND GG2 AND 出击;
DRAWICON(狙击=1,9,28);
AAA:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
趋势:=IF(AAA>65,65,AAA),COLORYELLOW;
底部:=-21,COLORGREEN;
技术高位:=21,COLORWHITE;
顶区:=36,COLORGREEN;
技术低位:=-10,COLORWHITE;
牛熊分界:=0,COLORRED;
选股1:=CROSS(趋势,技术低位);
选股2:=CROSS(趋势,牛熊分界);
DRAWICON(选股1=1,11,24);
DRAWICON(选股2=1,13,13);
SM01:=MA((2*C+H+L)/4,5);
SM02:=SM01*(200-102)/100;
SM03:=(1-7/100)*DMA(C,ABS((2*C+H+L)/4-MA(C,20))/MA(C,20));
SM04:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
SM05:=3*SMA(SM04,3,1)-2*SMA(SMA(SM04,3,1),3,1);
SM06:=((H+L+C)/3-MA((H+L+C)/3,14))/(0.015*AVEDEV((H+L+C)/3,14));
SM07:=SM02<SM03&&SM05>REF(SM05,1)&&REF(SM05,1)<REF(SM05,2)&&SM06<-100&&SM06>REF(SM06,1);
STICKLINE(SM07,0,0.5,2,0),COLORYELLOW;
神秘买点:SM07,COLORRED,LINETHICK3;
LC20:=REF(CLOSE,1);
RSI20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100;
底:CROSS(RSI20,11)*1;
DRAWICON(底=1,4,7);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
加仓:IF(FILTER(YXF=1,5),1,0),STICK,COLORRED;
DRAWICON(加仓=1,6,23);
选股3:=COUNT(C/REF(C,1)<0.96,6)>=1 AND LAST(C<O,2,1) AND (REF(L,1)/REF(C,4)<0.85 OR
L/REF(C,3)<0.85) AND C>O;
DRAWICON(选股3=1,7,34);
MA5:=MA(C,5);MA10:=MA(C,10);MA20:=MA(C,20);MA60:=MA(C,60);
CBFB:=MA(C,2);
JL:=IF(C>CBFB,V,0);
CL:=IF(C<CBFB,V,0);
JLH:=SUM(JL,4);
CLH:=SUM(CL,4);
LHB:=CLH/JLH;
TJ1:=IF(HHV(LHB,5)>4 AND CROSS(2,LHB) AND C>=O,1,0);
DRAWICON(TJ1=1,15,9);
VAR1P:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VAR2P:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR3P:=(SMA(VAR2P,3,1)-18)*1.55;
VAR4P:=SMA(VAR3P,3,1);
VAR5P:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;
VAR6P:=SMA(VAR5P,10,1);
VAR7P:=(EMA(SMA(VAR6P,8,1),34)-25)*2.6;
VAR8P:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VAR9P:=POW(MA(LOW,5),2)+MA(LOW,5);
VARAP:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARBP:=((VAR8P-LLV(VAR9P,64))/(HHV(VARAP,64)-LLV(VAR9P,64))*150+65-10)/2;
VARCP:=SMA(VARBP,3,1)*1.5-46;
VARDP:=SMA(VARCP,3,1);
VAREP:=3*VARCP-2*VARDP;
VARFP:=(VAR1P+VAR2P+VAR5P)/3;
VAR10P:=((VAR3P+VAR3P+VAR6P+VARCP)/4-15)*1.67;
VAR11P:=((VAR4P+VAR4P+VAR7P+VARDP)/4-15)*1.67;
VAR12P:=((VAR1P+VAR5P*2+VARFP+VAR10P+VAR11P+VARBP+VARCP+VARDP+VAREP)/10-15)*1.67;
VAR13P:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*(-1)+0.9;
VAR14P:=(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*(-1)+0.92;
VAR15P:=(HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15))*(-1)+0.93;
VAR16P:=(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))*(-1)+0.94;
VAR17P:=(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89))*(-1)+0.95;
VAR18P:=(HHV(HIGH,120)-CLOSE)/(HHV(HIGH,120)-LLV(LOW,120))*(-1)+0.91;
VAR19P:=(HHV(HIGH,180)-CLOSE)/(HHV(HIGH,180)-LLV(LOW,180))*(-1)+0.96;
VAR1AP:=((VAR13P*8+VAR14P*8+VAR15P*8+VAR16P+VAR17P+VAR18P+VAR19P)/28-0.1)*185;
VAR1B:=SMA(VAR1AP,3,1);
VAR1C:=(SMA(VAR1B,8,1)-8)*1.18;
VARA1:=(CLOSE-LLV(LOW,60.13547854))/(HHV(HIGH,60.13547854)-LLV(LOW,60))*80;
VARB1:=SMA(VARA1,7,1);
VARC1:=SMA(VARB1,5,1);
英雄:=IF(CROSS(VARBP,VARCP) AND VARBP<20,100,0);
VAR2N:=LLV(LOW,3)<=LLV(LOW,60);
VAR3N:=C>O AND (C/O>1.03 OR C>1.03*REF(C,1));
绝地反击:IF(VAR2N AND VAR3N,30,0)COLOR00FF00;
VAR1A:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2A:=SMA(ABS(LOW-VAR1A),13,1)/SMA(MAX(LOW-VAR1A,0),10,1);
VAR3A:=EMA(VAR2A,10);
VAR4A:=LLV(LOW,33);
VAR5A:=EMA(IF(LOW<=VAR4A,VAR3A,0),3);
主力进场2:=(VAR5A>REF(VAR5A,1));
DRAWICON(主力进场2,30,1);
QVAR1A:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;
QVAR1B:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
QVAR1C:=SMA(QVAR1B,13,8);
QVAR1D:=SMA(QVAR1A,21,8);
机会来临:=SMA(QVAR1C,13,8);
AAS:=FILTER((COUNT((机会来临-QVAR1D<(-65)),3)=3),34);
DRAWICON(AAS,29,29);
DRAWICON( CROSS(CCI,-200),28,16);
DRAWICON( CROSS(CCI,-100),28,1);
DRAWTEXT(ISLASTBAR,28,'--CCI合并');
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10C:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10C);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=(CROSS(最佳买入,0));
DRAWICON(最佳买入选股,26,1);
RSVA:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 50);
KA:=SMA(RSVA,3,1);
DA:=SMA(KA,3,1);
JA:=3*KA-2*DA;
XB:=LLV(JA,2)=LLV(JA,8);
最佳买入时机:= (CROSS(JA,3));
DRAWICON(最佳买入时机,26,25);
DRAWTEXT(ISLASTBAR,26,'--最佳买入');
{短线套利}
MA18:=MA(C,21);
加码价:=((C-REF(MA18,1))/18+MA18)*1.004;
短线套利:=(CROSS(C,加码价) AND 加码价>REF(加码价,1));
DRAWICON(短线套利,20,1);
{短炒公式}
VARO:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
DRAWICON(VARO<-9 AND VARO> REF (VARO,1),20,26);
{DRAWICON(短底,20,26);}
DRAWTEXT(ISLASTBAR,20,'--短线套利');
{收银台}
QVAR2:=IF((HIGH+LOW<=REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),
ABS(LOW-REF(LOW,1))));
QVAR3:=IF((HIGH+LOW>=REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),
ABS(LOW-REF(LOW,1))));
QVAR4:=(SUM(QVAR2,13))/(SUM(QVAR2,13)+SUM(QVAR3,13));
QVAR5:=(SUM(QVAR3,13))/(SUM(QVAR3,13)+SUM(QVAR2,13));
QVAR9:=100-(3)*(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))+(2)*(SMA(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
QVARA:=100-(3)*(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))+(2)*(SMA(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
QVARB:=(QVAR9<REF(QVARA,1)) AND (VOL>REF(VOL,1)) AND (CLOSE>REF(CLOSE,1));
{QVAR1A:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;
QVAR1B:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
QVAR1C:=SMA(QVAR1B,13,8);
QVAR1D:=SMA(QVAR1A,21,8);}
生意上门:=SMA(QVAR1C,13,8);
收银台:=(生意上门-QVAR1D<-65);
DRAWICON(收银台,22,31);
AAS1:=FILTER((COUNT((生意上门-QVAR1D<(-65)),3)=3),34);
收银:=AAS1;
DRAWICON(收银,22,30);
AASS:=REF(BARSLAST(NOT(L<REF(L,1)))>=3,1) AND CROSS(C,REF(C,1));
自己动手:EXIST(AASS,5)*5;
VAR1K:4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*40,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*40,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2K:=8,COLORGREEN,LINETHICK0;
杀猪宰羊: IF(CROSS(VAR1K,VAR2),40,0),STICK,COLOR0000CC,LINETHICK2;
斗地主: IF(VAR1K<=8,25,0),STICK,COLORWHITE,LINETHICK2;
DRAWTEXT(CROSS(VAR1K,VAR2K),40,'谨慎买入'),COLOR00FFFF;
M2:=EMA(C,2);
M18:=EMA(C,18);
买点3:=IF(CROSS(M18,M2),5,10* 10000),COLORFF00FF,LINETHICK2;
RSVV3:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB22:=(RSVV3/2+22)*1;
Q:=EMA(VOL,13);
Y:=EMA(AMOUNT,13);
S:=((Y /Q) / 100);
X:=(((CLOSE -S) / S) * 100);
F:=((X < (0)) AND ZXNH);
XQ:=F AND RSVV<VARB22-2;
无未来XG:(买点3 AND XQ);
DRAWICON(无未来XG,33,18);
VARW2:=((CLOSE-MA(CLOSE,6))/(MA(CLOSE,6)))*(100);
VARW3:=((CLOSE-MA(CLOSE,12))/(MA(CLOSE,12)))*(100);
VARW4:=((CLOSE-MA(CLOSE,24))/(MA(CLOSE,24)))*(100);
VARW5:=(VARW2+(2)*(VARW3)+(3)*(VARW4))/(6);
VARW6:=MA(VARW5,3);
底部3:=IF((VARW6<-6),20,0),COLORFF9933;
DRAWICON(底部3=20,35,34);
主力:=EMA( (CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2)*5,LINETHICK2,COLOR0000FF;
散户:=EMA( (CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5,LINETHICK2,COLOR00FF00;
TJ2:=CROSS(主力,散户) AND 主力<-10;
TJ:=FILTER(COUNT(TJ1 OR TJ2,2)=2,5);
主力布控:=TJ OR TJ1 OR TJ2;
DRAWICON(主力布控=1,37,5);
预警1:(REF(CLOSE,2)/REF(OPEN,2)<= 0.98) AND (REF(OPEN,1) <= REF(CLOSE,2)) AND
(ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03) AND
CLOSE/OPEN>0.88 AND CLOSE>=REF(OPEN,2);
DRAWICON(预警1=1,38,27);
极品底:=IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),LINETHICK2,COLORFF00FF;
DRAWICON(极品底=23,23,17);
J8:=3*K-2*D2;
注意:= IF(CROSS(J8,3),95,0),COLORYELLOW,LINETHICK2;
DRAWICON(注意=95,18,16);
HH:=MAX(HIGH,REF(CLOSE,1));
LL:=MIN(LOW,REF(CLOSE,1));
AAAA:=SUM(CLOSE-LL,7)/SUM(HH-LL,7);
BBA:=SUM(CLOSE-LL,14)/SUM(HH-LL,14);
CC:=SUM(CLOSE-LL,28)/SUM(HH-LL,28);
TLIKTLI:=(AAAA/7+BBA/14+CC/28)*7*14*28/(7*14+14*28+7*28)*1000;
MTLIKTLI:=EMA(TLIKTLI,6);
ZZZ:=(HIGH + LOW + CLOSE)/3;
TLIK:=(ZZZ-MA(ZZZ,16))*100/(1.5*AVEDEV(ZZZ,16));
VVV:=IF((DATE>17374085120),0,1);
AVPRICE:=((CLOSE+OPEN+LOW+HIGH)/(4))*(VVV);
XXVOL:=(VOL)*(AVPRICE);
AAB:=(SUM(XXVOL,25)+0.001)/(SUM(VOL,25)+0.001);
GN:=(((500)*(AVPRICE-AAB))/(MAX(AVPRICE,AAB)))*(VVV);
ZS:=EMA(TLIK,3),COLOR0000FF;
IK:=EMA(TLIK,10),COLOR00FFFF;
ZZZZZ:=EMA(TLIK,20),COLORFF00FF,LINETHICK1;
青龙:=EMA(MTLIKTLI,1)/3.5815926,COLORDB70DB,LINETHICK1,DOTLINE;
青龙2:=EMA(MTLIKTLI,1)/4.5815926,COLOR009900,DOTLINE;
白虎:=EMA(GN,14),COLORFFFFFF,LINETHICK2;
地鼠:=EMA(MTLIKTLI,1)/-3.5815926,COLORDB70DB,LINETHICK1,DOTLINE;
地鼠2:=EMA(MTLIKTLI,1)/-4.5815926,COLOR009900,DOTLINE;
买入A:=(CROSS(ZS,地鼠))*100;
买入2A:=(CROSS(ZS,地鼠2))*100;
DRAWICON(买入A=100,20,13);
DRAWICON(买入2A=100,20,1);
VAR1S:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2S:=8,COLORGREEN,LINETHICK0;
V3S:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
操盘线:=SMA(V3S,2,1);
V5:=SMA(操盘线,2,1);
抄底9:IF(操盘线>REF(操盘线,1) AND REF(操盘线,1)<REF(操盘线,2) AND 操盘线<23 ,25,0) AND CROSS(VAR1S,VAR2S);
DRAWICON(抄底9=1,8,28);
黄金线:=EMA(C,18),COLORMAGENTA;
金矿:=COUNT(CLOSE<黄金线,5)=4 AND CLOSE/黄金线>1.004 AND
CROSS(CLOSE,黄金线) AND 黄金线>=REF(黄金线,1),LINETHICK,COLORRED;
有金矿:=IF(金矿,1.5,0),COLORLIRED,LINETHICK2;
DRAWICON(有金矿=1.5,2,13);
REF((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667,1) AND C>O AND C>REF(H,1);
SY:=H>C*1.02 AND C>O AND V>REF(V,1)*1.4;
CV:=CLOSE;
FF:=(MA(CV,3)+MA(CV,6)+MA(CV,12)+MA(CV,24))/4;
UPR:=FF+6*STD(BBIBOLL,11);
DWN:=FF-6*STD(BBIBOLL,11);
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HDZ :=HIGH-REF(HIGH,1);
LDZ :=REF(LOW,1)-LOW;
DMPZ:=EXPMEMA(IF(HDZ>0&&HD>LDZ,HDZ,0),14);
DMMZ:=EXPMEMA(IF(LDZ>0&&LD>HD,LDZ,0),14);
PDIZ:=DMPZ*100/MTR;
MDIZ:=DMMZ*100/MTR;
ADXZ:=EXPMEMA(ABS(MDIZ-PDIZ)/(MDI+PDIZ)*100,6);
ADXR:=EXPMEMA(ADXZ,6);
KKK:=C>REF(C,1) AND FF<REF(FF,1) AND PDI<REF(PDI,1) AND UPR>REF(UPR,1) AND ADX>REF(ADX,1) AND VOL<REF(VOL,1);
DRAWICON(KKK=1,40,13);
{三线共振}
HXLXA:=MA(CLOSE,5);
HXLXB:=MA(CLOSE,10);
HXLXC:=(HXLXA-CLOSE)/CLOSE>13/100;
HXLXD:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100/0.7;
HXLXE:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100*2;
HXLXF:=(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100/0.3/1.3/1.5;
HXLXH:=IF(HXLXE<-9,32,40);
HXLXI:=IF(HXLXF<-12,22,30);
HXLXG:=IF(HXLXD<-12,12,20);
共振:HXLXH<40 AND HXLXI<30 AND HXLXG<20;
DRAWICON(共振=1,40,1);
买Z:=IF("KDJ.J"<-10,10,0);
条件:=CROSS(9.9,买Z);
VAR1Z:=(2*CLOSE+HIGH+LOW)/4;
VAR2Z:=LLV(LOW,5);
VAR3Z:=HHV(HIGH,5);
VAR4Z:=EMA((VAR1Z-VAR2Z)/(VAR3Z-VAR2Z)*100,5);
MA1:=MA(VAR4Z,2);
稳底:VAR4>MA1 AND REF(VAR4,1)<15;
DRAWICON(稳底=1,40,38);
QZ:=(3*CLOSE+LOW+OPEN+HIGH)/6;
QQZ:=(20*QZ+19*REF(QZ,1)+18*REF(QZ,2)+17*REF(QZ,3)+16*REF(QZ,4)+15*REF(QZ,5)+14*REF(QZ,6) +13*REF(QZ,7)+12*REF(QZ,8)+11*REF(QZ,9)+10*REF(QZ,10)+9*REF(QZ,11)+8*REF(QZ,12) +7*REF(QZ,13)+6*REF(QZ,14)+5*REF(QZ,15)+4*REF(QZ,16)+3*REF(QZ,17)+2*REF(QZ,18)+ REF(QZ,20))/211;
DDZ:=CROSS(QQZ,EMA(EMA(EMA(QQZ,2),2),2));
CCZ:=EMA(EMA(CLOSE,12)-EMA(CLOSE,26),9);
QQ1:=HHV(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CC),4)<0
AND 2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CCZ)>REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CCZ),1)
AND REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CCZ),1)<REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CCZ),2)
AND REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CCZ),2) <REF(2*(EMA(CLOSE,12)-EMA(CLOSE,26)-CCZ),3);
QQ2:=EMA(EMA(EMA(EMA(CLOSE,2),2),2),2);
DD1:=CROSS(QQ2,EMA(REF(QQ2,1),2)) AND C>O AND V>=MA(V,21) AND V> REF(V,1);
DD2:=DD1+QQ1+DD>=2 AND EMA(CLOSE,12)-EMA(CLOSE,26)>CC AND H/C<1.01 AND REF(MA(C,5),1)<MA(C,5) AND REF(MA(C,5),2)>REF(MA(C,5),1);
MACD:=(EMA(CLOSE,12)-EMA(CLOSE,26)-EMA(EMA(CLOSE,12)-EMA(CLOSE,26),9))*2;
CC1:=CROSS(K,D2) AND MACD>0;
赚钱法宝:=DD2 AND REF(H/C<1.02,1) AND CC1,COLORRED;
DRAWICON(赚钱法宝=1,40,29);

通达信组合寻底指标公式

 

相关文章