在线检测未来函数

通达信看准趋势指标公式

来源:Internet,编辑:股旁网,2014-12-22

MB1:=EMA(C,5),COLORRED,LINETHICK2;
MB2:EMA(MB1,2),COLORYELLOW;
MB3:EMA(MB2,2),COLORYELLOW;
MB4:EMA(MB3,2),COLORYELLOW;
MB5:EMA(MB4,2),COLORYELLOW;
MB6:EMA(MB5,2),COLORYELLOW;
MB7:EMA(MB6,2),COLORYELLOW;
MB8:EMA(MB7,2),COLORYELLOW;
MB9:EMA(MB8,2),COLORYELLOW;
MB10:EMA(MB9,2),COLORYELLOW;
MB11:EMA(MB10,2),COLORYELLOW;
MB12:EMA(MB11,2),COLORYELLOW;
MB13:EMA(MB12,2),COLORYELLOW;
MB14:EMA(MB13,2),COLORYELLOW;
A1:IF(MB1<REF(MB1,1),MB2,DRAWNULL),COLORBLUE,LINETHICK1;
A2:IF(MB2<REF(MB2,1),MB2,DRAWNULL),COLORBLUE,LINETHICK1;
A3:IF(MB3<REF(MB3,1),MB3,DRAWNULL),COLORBLUE,LINETHICK1;
A4:IF(MB4<REF(MB4,1),MB4,DRAWNULL),COLORBLUE,LINETHICK1;
A5:IF(MB5<REF(MB5,1),MB5,DRAWNULL),COLORBLUE,LINETHICK1;
A6:IF(MB6<REF(MB6,1),MB6,DRAWNULL),COLORBLUE,LINETHICK1;
A7:IF(MB7<REF(MB7,1),MB7,DRAWNULL),COLORBLUE,LINETHICK1;
A8:IF(MB8<REF(MB8,1),MB8,DRAWNULL),COLORBLUE,LINETHICK1;
A9:IF(MB9<REF(MB9,1),MB9,DRAWNULL),COLORBLUE,LINETHICK1;
A10:IF(MB10<REF(MB10,1),MB10,DRAWNULL),COLORBLUE,LINETHICK1;
A11:IF(MB11<REF(MB11,1),MB11,DRAWNULL),COLORBLUE,LINETHICK1;
A12:IF(MB12<REF(MB12,1),MB12,DRAWNULL),COLORBLUE,LINETHICK1;
A13:IF(MB13<REF(MB13,1),MB13,DRAWNULL),COLORBLUE,LINETHICK1;
A14:IF(MB14<REF(MB14,1),MB14,DRAWNULL),COLORBLUE,LINETHICK1;
VAR2:MB1,COLORMAGENTA,LINETHICK2;
VAR3:IF(VAR2<REF(VAR2,1),VAR2,DRAWNULL),COLORBLUE,LINETHICK2;
操作线:=EMA(C,7),COLOR00FF00;
A:=(REF(操作线,1));
STICKLINE((操作线>A),A,操作线,5,0),COLOR0000FF,NODRAW;
STICKLINE((操作线<=A),A,操作线,5,0),COLOR00FF00,NODRAW;
{MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);
MA60:MA(C,60);
MA120:MA(C,120);
MA250:MA(C,250)};
DRAWKLINE(H,O,L,C),NODRAW;
K0:=MA(CLOSE,3);
D0:=MA(K0,3);
DRAWLINE(D0>=HHV(D0,21),D0,D0<=LLV(D0,21),D0,0),COLOR00BBFF,LINETHICK1;
DGL:=DRAWLINE(D0>=HHV(D0,21),D0,D0<=LLV(D0,21),D0,1);
DGL0:=DRAWLINE(D0<=LLV(D0,21),D0,D0>=HHV(D0,21),D0,1);
DRAWICON (CROSS(K0,D0) AND CROSS(K0,DGL),D0*0.995,11);
DRAWLINE(D0<=LLV(D0,21),D0,D0>=HHV(D0,21),D0,0),COLORLICYAN,LINETHICK1;
DRAWICON (CROSS(D0,K0) AND CROSS(DGL0,K0),D0*1.008,12);

通达信看准趋势指标公式

 

相关文章