在线检测未来函数

飞狐布林入内主图指标公式

来源:Internet,编辑:股旁网,2014-12-24

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
做多:=IF(K>D AND MACD>0 AND V>1,2,0),COLORRED;
做空:=IF(K<D AND MACD<0 AND V>1,-2,0),COLOR00FF00;
强洗:=IF(MACD>0 AND K<D AND V>1,1,0),COLOR0099FF;
弱升:=IF(MACD<0 AND K>D AND V>1,-1,0),COLORFFFF00;
STICKLINE(做多,L,H,0.5,0),COLORRED;
STICKLINE(做多 AND C>=O,C,O,9.5,1),COLORRED;
STICKLINE(做多 AND C<O,C,O,9.5,0),COLORRED;
STICKLINE(做空,L,H,0.5,0),COLORGREEN;
STICKLINE(做空 AND C>=O,C,O,9.5,1),COLORGREEN;
STICKLINE(做空 AND C<O,C,O,9.5,0),COLORGREEN;
STICKLINE(强洗,L,H,0.5,0),COLORFF00FF;
STICKLINE(强洗 AND C>=O,C,O,9.5,1),COLORFF00FF;
STICKLINE(强洗 AND C<O,C,O,9.5,0),COLORFF00FF;
STICKLINE(弱升,L,H,0.5,0),COLOR2299FF;
STICKLINE(弱升 AND C>=O,C,O,9.5,1),COLOR2299FF;
STICKLINE(弱升 AND C<O,C,O,9.5,0),COLOR2299FF;
VAR1:=EMA(C,3);
VAR2:=EMA(C,5);
VAR3:=EMA(C,10);
VAR4:=EMA(C,20);
VAR5:=EMA(C,30);
VAR6:=(VAR2+VAR3+VAR4+VAR5)/4;
VAR7:=(VAR6-REF(VAR6,15))/REF(VAR6,15)*100;
VAR8:=(VAR6-REF(VAR6,15))/REF(VAR6, 15)*100;
VAR9:=EMA(VAR7,8);
STICKLINE(VAR7<1*REF(VAR7,1),H,L,0.5,0),COLORBLUE;
STICKLINE(VAR7<1*REF(VAR7,1),O,C,6.5, 0),COLORBLUE;
中轴线:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
压力线: 中轴线+3*STD(中轴线,10);
支撑线: 中轴线-3*STD(中轴线,10);
破压力画一半线: 中轴线+1.5*STD(中轴线,10);
破支撑画一半线: 中轴线-1.5*STD(中轴线,10);
现价:C,POINTDOT,COLORRED;

飞狐布林入内主图指标公式

 

相关文章