在线检测未来函数

通达信股票走势趋势指标公式

来源:Internet,编辑:股旁网,2014-12-29

N:=10;
量:=(CLOSE - LLV(LOW,32)) / (HHV(HIGH,32) - LLV(LOW,32)) * 1.2 * CLOSE;
量1:=EMA(量,3);
量2:=EMA(量,5);
量3:=EMA(量,7);
Y:=MA(量1,6);
Y1:=MA(Y,2);
Y2:=MA(Y,4);
Y3:=MA(Y,6);
强弱分界:(Y1+Y2+Y+Y3)/4,COLORGREEN,LINETHICK2;
IF(强弱分界<量3,强弱分界,DRAWNULL),COLORRED,LINETHICK2;
STICKLINE(量1 >= 量2,量3,量1,2,0),COLOR000055;
STICKLINE(量1 >= 量2,量3,量1,1.8,0),COLOR0000BB;
STICKLINE(量1 >= 量2,量3,量1,1.4,0),COLOR0000CC;
STICKLINE(量1 >= 量2,量3,量1,1,0),COLOR0000DD;
STICKLINE(量1 >= 量2,量3,量1,0.5,0),COLOR0000FF;
STICKLINE(量1 <= 量2,量3,量1,2,0),COLOR000055;
STICKLINE(量1 <= 量2,量3,量1,1.8,0),COLORFF3300;
STICKLINE(量1 <= 量2,量3,量1,1.4,0),COLORFF5500;
STICKLINE(量1 <= 量2,量3,量1,1,0),COLORFF7700;
STICKLINE(量1 <= 量2,量3,量1,0.5,0),COLORFF9900;
T1:=量2 >= 量3 AND 量1 < REF(量1,1);
T2:=量2 < 量3 AND 量1 > REF(量1,1);
STICKLINE(T1,量1,量3,2,0),COLORFFBB11;
STICKLINE(T1,量1,量3,1.8,0),COLORFFCC22;
STICKLINE(T1,量1,量3,1.4,0),COLORFFDD33;
STICKLINE(T1,量1,量3,1,0),COLORFFEE44;
STICKLINE(T1,量1,量3,0.5,0),COLORFFFF55;
STICKLINE(T2,量1,量3,2,0),COLOR338FDD;
STICKLINE(T2,量1,量3,1.8,0),COLORFF00FF;
STICKLINE(T2,量1,量3,1.4,0),COLOR00DDFF;
STICKLINE(T2,量1,量3,1,0),COLOR00AAFF;
STICKLINE(T2,量1,量3,0.5,0),COLOR00BBFF;
大涨:=CLOSE/REF(CLOSE,1)>=1.09 OR ((H-L)/REF(C,1)>0.1 AND C=H),LINETHICK0,COLOR00FFFF;
STICKLINE(大涨,量1,量3,2,0),COLOR00FFFF;
大跌:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)<-0.098 OR ((H-L)/REF(C,1)>0.1 AND C=L),LINETHICK0,COLOR00FF00;
STICKLINE(大跌,量1,量3,2,0),COLOR00FF00;
HH:=HHV(量1,N);
LL:=LLV(量1,N);
LC:=REF(C,1);
CCI:=((C-MA(C,14))/(0.015*AVEDEV(C,14)))/4+50,COLORFFCCCC;
RSI:=SMA(MAX(C-LC,0),6,1)/SMA(ABS(C-LC),6,1)*150-30,COLORCC9900;
低0:=IF(LLV(CCI,10)<0 AND LLV(RSI,10)<0 AND C=LLV(C,10) AND L=LLV(L,10),40,0);
低:=IF(FILTER(低0=40,5),50,0);
DRAWICON(低=50,量1-0.05,9);
A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A1,5),LINETHICK2,COLOR6600FF;
A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2)),LINETHICK2,COLORYELLOW;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(FILTER(REF(黑马线,1)>90 AND A2<0,7),量1+0.5,'跑'),COLOR00FF00;
DRAWTEXT(CROSS(A1,黑马线) AND 黑马线<A5,量3-1.5,'21D');
P1:=20,32,28;
P2:=32,35,32;
P3:=35,38,35;
VARA2:=LLV(LOW,10);
VARA3:=HHV(HIGH,25);
警戒线1:= P1/10;
减仓线1:= P2/10 ;
卖出线1:= P3/10;
动力线1:= EMA((CLOSE-VARA2)/(VARA3-VARA2)*4,4);
警惕:IF(CROSS(动力线1,警戒线1),量2+3,DRAWNULL),POINTDOT,LINETHICK5,COLORF00FF0;
逢高减磅:IF(CROSS(动力线1,减仓线1),量2+2,DRAWNULL), POINTDOT,LINETHICK5,COLORF0F000;
NG1:=20;
VARG2:=((3 * SMA((((CLOSE - LLV(LOW,NG1)) / (HHV(HIGH,NG1) - LLV(LOW,NG1))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,NG1)) / (HHV(HIGH,NG1) - LLV(LOW,NG1))) * 100),5,1),3,1)));
秘密买点:IF((VARG2 <= 3),量2+5,强弱分界),COLORWHITE;
绝密买点:IF((VARG2 <= 0),量2+4,强弱分界),COLORRED;
STICKLINE(VARG2<0 ,量2,量2+4,0.5,0),COLORRED;
FFF:=REF((H-MAX(C,O))/ABS(C-O)>2 AND C>O,1) AND ((MIN(C,O)-L)/ABS(C-O)>2 AND C>O);
抄点:STICKLINE(FFF,0,10,3,0),COLORLICYAN;

通达信股票走势趋势指标公式

 

相关文章