在线检测未来函数

通达信操盘图指标公式

来源:Internet,编辑:股旁网,2015-01-01

A8A:=(C+O+L+H)/4;
B8B:=REF(CLOSE,A8A);
处女线:=SMA(MAX(CLOSE-B8B,0),2,1)/SMA(ABS(CLOSE-B8B),2,1)*100;
DZ1:=处女线>REF(处女线,1) AND 处女线>89;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
CCI修正1:=EMA(EMA(EMA(CCI,2),2),2);
CCI修正2:=EMA(EMA(EMA(CCI,3),2),2);
DZ2:=CCI修正1>100;
T:=CLOSE*1.0+LOW*0.0+HIGH*0.0;
SL:=(T/REF(T,1)-1)*1000;
快:=XMA(XMA(XMA(SL,3),3),3);
慢:=XMA(XMA(XMA(SL,5),5),5);
X:=快-慢;
增速1:=X;
WWW:=REF(增速1,1)<0;
DZ4:=增速1>3 AND WWW;
DZ:=DZ1 AND DZ2 AND DZ4;
STICKLINE(DZ,0,10,3,0),COLORWHITE;
DRAWTEXT(DZ,12,'强势'),COLORWHITE;
ZLCM:=EMA(WINNER(CLOSE)*70,3);
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
ZZLJJ:=EMA(ZZLKP,55);
XGL:=(ZZLJJ>REF(ZZLJJ,1) AND REF(ZZLJJ,1)<REF(ZZLJJ,2))*25;
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,1,0),COLORRED;
VAR21:=REF(LOW,1);
VAR31:=SMA(ABS(LOW-VAR21),3,1)/SMA(MAX(LOW-VAR21,0),3,1)*100;
VAR41:=EMA(IF(CLOSE*1.3,VAR31*10,VAR31/10),3);
VAR51:=LLV(LOW,30);
VAR61:=HHV(VAR41,30);
VAR71:=IF(MA(CLOSE,58),1,0);
VAR81:=EMA(IF(LOW<=VAR51,(VAR41+VAR61*2)/2,0),3)/618*VAR71;
VAR91:=IF(VAR81>100,100,VAR81);
吸筹:IF(VAR91>-120,VAR91,0),COLORMAGENTA,NODRAW;
STICKLINE(VAR91>-120,0,VAR91,1,1),COLORMAGENTA;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100,COLORYELLOW,LINETHICK1;
红买:FILTER(CROSS(RSI,11),7),COLORRED;
STICKLINE(红买,0,5,6,0),COLORRED;
绿卖:=FILTER(CROSS(88,RSI),7),COLOR00FF00;
STICKLINE(绿卖,100,88,6,0),COLOR00FF00;
ZLC:= EMA((WINNER(CLOSE) * 70),3);
SHC:= EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.9))) * 80),3);
主力控盘: ((ZLC / (ZLC+ SHC)) * 100),COLORRED,LINETHICK1;
VAR2001:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3001:=SMA(SMA(VAR2001,3,1),3,1)/28.57;
VAR4001:=EMA(VAR3001,5);
操盘1:=3*VAR3001-2*VAR4001;
A11:=CROSS(操盘1,VAR3001) AND VAR3001<2.1 AND C>O;
STICKLINE(A11,20,0,4,1),COLOR0000FF;
DRAWTEXT(A11,23,'满仓'),COLORRED;
VAR2:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3:=(((CLOSE - LLV(LOW,18)) / (HHV(HIGH,18) - LLV(LOW,18))) * 100);
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,3,1);
黄线在上持股:((3 * VAR4) - (2 * VAR5)), LINETHICK1 , COLORYELLOW;
VAR6:=(黄线在上持股 > (1 * REF(黄线在上持股,1)));
VAR7:=LLVBARS(LOW,50);
VAR8:=SUM(VOL,VAR7);
VAR9:=HHVBARS(HIGH,50);
VAR10:=SUM(VOL,VAR9);
VAR11:=(((CLOSE - REF(OPEN,VAR9)) / REF(OPEN,VAR9)) * 100);
VAR12:=((VAR10 / CAPITAL) * 100);
VAR13:=(((CLOSE - REF(OPEN,VAR7)) / REF(OPEN,VAR7)) * 100);
VAR14:=((VAR8 / CAPITAL) * 100);
VAR15:=(MA(WINNER(CLOSE),3) * 100);
VAR16:=EMA(VAR4,3);
回档不破洗盘:EMA(VAR4,3),COLORFFFFFF,LINETHICK1;
红线下穿减仓:EMA(回档不破洗盘,3),COLORFFCC66;
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(A1,10,0,4,0),COLOR770077;
STICKLINE(A1,10,0,3,0),COLOR990099;
STICKLINE(A1,10,0,2,0),COLORBB00BB;
STICKLINE(A1,10,0,1,0),COLORDD00DD;
STICKLINE(A1,10,0,0.3,0),COLORFF00FF;
DRAWTEXT(A1,14,'全仓'),COLORRED;
DRAWTEXT(REF("KDJ.J",1)<0 AND "KDJ.J">0,17,'短'),COLORRED ;
STICKLINE(REF("KDJ.J",1)<0 AND "KDJ.J">0,13,0,1,0),COLORRED;

通达信操盘图指标公式

 

相关文章