在线检测未来函数

飞狐抄底趋势指标公式

来源:Internet,编辑:股旁网,2015-01-04

N:=2;
DRAWGBK(1,COLORRGB(0,0,0),COLORRGB(0,0,0),1);
VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2:=2*ABS(VAR1);
VAR3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));
VAR7:=(VAR5-MA(VAR5,70))/(0.015*AVEDEV(VAR5,70));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARB:=100-ABS(VARA);
VARC:=3*SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARD:=3*SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=VAR11-CLOSE;
VAR13:=REF(CLOSE,1);
VAR14:=(SMA(MAX(CLOSE-VAR13,0),7,1))/(SMA(ABS(CLOSE-VAR13),7,1))*100;
VAR15:=(SMA(MAX(CLOSE-VAR13,0),13,1))/(SMA(ABS(CLOSE-VAR13),13,1))*100;
VAR16:=BARSCOUNT(CLOSE);
VAR17:=(SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),6,1))*100;
VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1A:=(SMA(VAR19,4,1)-50)*2;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR11:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100;
VAR22:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR33:=IF(ABS(VAR1)<2,0.9,1);
VAR44:=VAR33*(VAR22-VAR11);
VAR20:=IF(VAR17<=25 AND VAR18<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR12>=-0.25 AND VAR14<25 AND VAR15<30 AND VAR16>50,70,0);
★发射:VAR20,LINETHICK0,colorFF;
预警系统:(IF(VAR7>=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9)))+60,LINETHICK0;
AA:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1);
AA1:=MA(VOL,8)/MA(VOL,45)>=2.5;
AA2:=MA(HIGH,13);
AA3:=MA(CLOSE,13);
AA4:=MA(AMOUNT/VOL,13)/100;
AA5:=MA(LOW,13);
AA6:=MA(AMOUNT/VOL,30)/100;
AA7:=MA(AMOUNT/VOL/100,13)*0.85;
AA8:=FILTER(AA2>REF(AA2,1)*1.015 AND AA5>REF(AA5,1)*1.015 AND AA3>REF(AA3,1)*1.015 AND AA4>REF(AA4,1)*1.015,5);
高位买:(CLOSE>0 AND FINANCE(33)>0 AND (AA OR AA8))*20,LINETHICK0,colorFF00FF;
盘:=CAPITAL/1000000;
益:=FINANCE(33);
资:=FINANCE(34);
换手:=VOL/CAPITAL;
长阳:=WINNER(CLOSE)-WINNER(OPEN)>=0.15 AND 换手<=0.04;
缩量长阳:=IF(长阳,(WINNER(CLOSE)-WINNER(OPEN))*100,0);
VVAR1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
VVAR2:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
个股:=EMA(SUM(VVAR1,20),5);
大盘:=EMA(SUM(VVAR2,20),5);
领涨:=个股-大盘>=0;
VVAR3:=(CLOSE-LLV(LOW,125))/(HHV(HIGH,125)-LLV(LOW,125))*100;
VVAR4:=SMA(VVAR3,72,1);
VVAR5:=SMA(VVAR4,34,1);
中线趋势:=3*VVAR4-2*VVAR5;
中线趋势升:=中线趋势-REF(中线趋势,1)>=0;
均五升:=MA(CLOSE,5)-REF(MA(CLOSE,5),1)>=0;
均十升:=MA(CLOSE,10)-REF(MA(CLOSE,10),1)>=0;
领涨大盘:IF(均五升 AND 均十升 AND 中线趋势升 AND 领涨,4,0),colorFF99FF;
VVAR6:=(2*CLOSE+HIGH+LOW)/4;
VVAR7:=LLV(LOW,N);
VVAR8:=HHV(HIGH,N);
攀登:=(EMA((VVAR6-VVAR7)/(VVAR8-VVAR7)*100,13)-15)*1.6;
金山:=EMA(0.618*REF(攀登,1)+0.382*攀登,3);
强弱界:0,colorFFFF00;
运动员:=IF(攀登>=金山 AND 均五升 AND 均十升 AND 中线趋势升 AND 金山<35,1,0);
起步:IF(CROSS(攀登,金山) AND 金山<30,10,0);
起攀:IF(运动员=1 AND (COUNT(运动员=1,5))=1,8,0),LINETHICK1,colorFF9999;
超短买:缩量长阳,LINETHICK0,color60FFFF;
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
抄底:IF(起攀=8 AND (COUNT(乖离<-12,10))>=1,10,0),LINETHICK0,colorFF;
天:=IF(VARB<90,VARB,100);
地:=IF(VAR1>0,VAR1,0);
基地:=IF(VAR1<0,VAR2,0);
STICKLINE(基地>=REF(基地,1),0,基地,7,0),color414141;
STICKLINE(基地<REF(基地,1),0,基地,7,0),colorE2E4E5;
STICKLINE(基地,0,-基地*0.3,7,0),color232323;
STICKLINE(基地<REF(基地,1),-基地*0.3,0,7,0),color808080;
STICKLINE(★发射>0,15,★发射*1.1,1,0),POINTDOT,colorFFFFFF;
STICKLINE(★发射>0,15,0,3,0),LINETHICK6,colorFF;
STICKLINE(★发射>0 AND ★发射<400,40,★发射,1,1),LINETHICK3,colorFFA4A6;
STICKLINE(★发射>0 AND ★发射<400,40,★发射,1,0),LINETHICK1,colorFF;
STICKLINE(★发射>0,15,★发射*0.7,5,0),LINETHICK5,colorFFA4A6;
STICKLINE(★发射>0,15,★发射*0.4,5,0),LINETHICK7,colorFFA4A6;
STICKLINE(★发射>0,15,★发射*0.1,5,0),LINETHICK7,color99CC;
STICKLINE(地>0,0,地,10,0),color66FF00;
STICKLINE(地>0,0,地*0.9,10,0),color66EE00;
STICKLINE(地>0,0,地*0.85,10,0),color66DD00;
STICKLINE(地>0,0,地*0.8,10,0),color66CC00;
STICKLINE(地>0,0,地*0.75,10,0),color66BB00;
STICKLINE(地>0,0,地*0.7,10,0),color66AA00;
STICKLINE(地>0,0,地*0.65,10,0),color669900;
STICKLINE(地>0,0,地*0.6,10,0),color668800;
STICKLINE(地>0,0,地*0.55,10,0),color667700;
STICKLINE(地>0,0,地*0.5,10,0),color666600;
STICKLINE(地>0,0,地*0.45,10,0),color665500;
STICKLINE(地>0,0,地*0.4,10,0),color664400;
STICKLINE(地>0,0,地*0.35,10,0),color663300;
STICKLINE(地>0,0,地*0.3,10,0),color662200;
STICKLINE(地>0,0,地*0.25,10,0),color661100;
STICKLINE(地>0,0,地*0.2,10,0),color660000;
STICKLINE(地>0,0,-地*0.3,10,0),color417800;
STICKLINE(VAR3>=REF(VAR4,1),VAR3,VAR4,8,0),colorFF;
STICKLINE(VAR3<REF(VAR4,1),VAR3,VAR4,8,0),colorFFFF;
T1:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
T2:=CLOSE<MA(CLOSE,20) AND MA(CLOSE,20)<REF(MA(CLOSE,20),1);
T3:=地>50 AND 预警系统>60 AND 天=100;
T4:=地>48 AND 预警系统>60 AND 天<100;
T5:=基地>38 AND 预警系统<55;
T6:=★发射>50 AND 天<90;
T7:=VAR3<REF(VAR4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
T8:=VAR3>=REF(VAR4,1) AND CLOSE<REF(CLOSE,1) AND 预警系统=60 AND ★发射=0 AND 基地>REF(基地,1) AND VARC<REF(VARD,1);
OSC:=CLOSE/REF(CLOSE,10)*100;
LC:=REF(CLOSE,1);
VR:=(SUM(IF(CLOSE>LC,VOL,0),10))/(SUM(IF(CLOSE<=LC,VOL,0),10))*100;
AR:=(SUM(HIGH-OPEN,10))/(SUM(OPEN-LOW,10))*100;
PSY:=(COUNT(CLOSE>REF(CLOSE,1),10))/10*100;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2,90,'电子股评,仅供参考');
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND "MACD.MACD">0,75,'强势!'),colorFFFF;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND REF("MACD.MACD",1)<0 AND "MACD.MACD">0 OR CLOSE>0 AND BARSTATUS=2 AND REF("MACD.MACD",1)>0 AND "MACD.MACD"<0,0,'强弱转换,择情而动!');
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND "MACD.MACD"<0,75,'弱势!'),colorFFFF;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND OSC>100,60,'目前多方占优!'),colorFF00;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND OSC<100,60,'目前空方占优!'),colorFFFFFF;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND VR<40,45,'股价低位,有可能见底反弹!'),colorFF00FF;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND BETWEEN(VR,40,70),45,'股价低位,可建仓!'),colorFF00FF;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND BETWEEN(VR,70,150),45,'盘整阶段,可持有!');
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND BETWEEN(VR,151,351),45,'应该获利了结!'),colorFF;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND VR>350,45,'持股比较危险,股价有下调要求,应选择获利了结时机!'),colorFF;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND BETWEEN(AR,69,151),30,'人气平稳,波动幅度较小!');
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND AR>151,30,'人气比较活跃,随时有可能回档下调!'),colorFF;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND AR<70,30,'人气不足,有反弹的要求!'),colorFF00FF;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND BETWEEN(PSY,24,71),15,'市场买卖趋向正常!'),colorFF00;
DRAWTEXT(CLOSE>0 AND BARSTATUS=2 AND PSY>75 OR CLOSE>0 AND BARSTATUS=2 AND PSY<25,15,'市场买卖趋向异常,行情有可能反转!'),colorFF;
STICKLINE(均五升 AND 均十升 AND 中线趋势升,0+0.5,-0.5,3,1),LINETHICK4,colorFFFF00;
STICKLINE(攀登>=金山 AND 均五升 AND 均十升 AND 中线趋势升,金山-3,金山-7,4,0),color64A0E6;
STICKLINE(攀登>金山 AND 攀登>=REF(攀登,1),攀登+5,金山-1,3.5,0),LINETHICK2,colorFF;
STICKLINE(攀登>金山 AND 攀登<REF(攀登,1),攀登,攀登,3.5,0),LINETHICK2,colorFFFFFF;
STICKLINE(攀登>=金山,金山,金山,3.5,0),LINETHICK2,colorFFFF;
STICKLINE(攀登<金山,金山+0.5,金山-0.5,3.5,0),LINETHICK2,colorFFFF00;
STICKLINE(领涨大盘=4,攀登+6,金山-1,4,0),colorFF99FF;
STICKLINE(必抄底=10,10,0,10,1),colorFF;
STICKLINE(缩量长阳,15,0,2,0),LINETHICK2,colorFFFF;
STICKLINE(高位买>0,11,高位买*1.1,1,0),POINTDOT,colorFFFFFF;
STICKLINE(高位买>0,5,0,3,0),LINETHICK5,colorFF;
STICKLINE(高位买>0 AND 高位买<400,10,高位买,1,1),LINETHICK3,colorFFA4A6;
STICKLINE(高位买>0 AND 高位买<400,5,高位买,1,0),LINETHICK1,colorFF;
STICKLINE(高位买>0,5,高位买*0.7,2,0),LINETHICK5,colorFFA4A6;
STICKLINE(高位买>0,5,高位买*0.4,3,0),LINETHICK7,colorFFA4A6;
STICKLINE(高位买>0,5,高位买*0.1,2,0),LINETHICK7,color99CC;
STICKLINE(VARB<90,100,VARB,1,0),colorFFFFFF;
STICKLINE(VARB<90,95,90,1,0),colorB5B5B5;
STICKLINE(VARB<90,100,95,1,0),color898989;
DRAWTEXT(均五升 AND 均十升 AND 中线趋势升 AND 领涨,4,'ˉ'),ALIGN1,colorFF99FF;
DRAWTEXT(预警系统=75,75,'↓'),ALIGN1,colorFF;
DRAWTEXT(预警系统=50,75,'↑'),ALIGN1,colorFFFF;
DRAWTEXT(T1 AND COUNT(T1,30)=1,100,'待长或高抛低吸!★'),ALIGN2,colorFFFF;
DRAWTEXT(T2 AND COUNT(T2,30)=1,90,'小心无量阴跌!☆'),ALIGN2,colorFFFF;
DRAWTEXT(T3 AND COUNT(T3,30)=1,70,'过急,需要调整!∨'),ALIGN2,colorFFFF;
DRAWTEXT(T4 AND COUNT(T4,30)=1,80,'顶部,注意风险!∨'),ALIGN2,colorFFFF;
DRAWTEXT(T5 AND COUNT(T5,30)=1,50,'不必杀跌,应有小反弹!∧'),ALIGN2,colorFFFF;
DRAWTEXT(T6 AND COUNT(T6,30)=1,30,'坚决抢反弹!▲'),ALIGN2,colorFFFF;
DRAWTEXT(T7 AND COUNT(T7,30)=1,40,'有资金进场迹象,关注!△'),ALIGN2,colorFFFF;
DRAWTEXT(T8 AND COUNT(T8,30)=1,20,'后市注意方向◇'),ALIGN2,colorFFFF;
DRAWTEXT(CLOSE>0 AND 高位买 AND BARSTATUS=2,60,'高位买进,注意风险!▲'),ALIGN2,colorFFFF;
DRAWTEXT(起攀=8,金山,'起攀'),colorFFFFFF;
DRAWTEXT(CLOSE>0 AND 缩量长阳>0 AND BARSTATUS=2,0,'超短买,次日逢低买进◆'),ALIGN2,colorFFFF;
DRAWTEXT(CLOSE>0 AND 缩量长阳>0,0,'◆'),ALIGN0,colorFFFF;
DRAWTEXT(必抄底=10,30,'★←必抄底'),colorFF;

飞狐抄底趋势指标公式

 

相关文章