在线检测未来函数

通达信主力进出2指标公式

来源:Internet,编辑:股旁网,2015-01-04

{用法:1、火焰山出信号;2、周金叉先笑脸出现;3、棕色色块年变绿色色块;4、机构筹码指大于50;}

VAR0:=(2*CLOSE+HIGH+LOW)/4;
VAR311:=(HHV(HIGH,18)-CLOSE)/(HHV(HIGH,18)-LLV(LOW,18))*100;
VAR322:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
B0:=EMA((VAR0-LLV(LOW,26))/(HHV(HIGH,34)-LLV(LOW,26))*100,16);
AA:=SMA(SMA(VAR322,2,1)+3,2,1),COLORRED,LINETHICK3;
浮筹:=EMA(B0,4),LINETHICK3,DOTLINE,COLORYELLOW;
BB:=SMA(VAR311,3,1),COLORGREEN,LINETHICK3;
{背景}
STICKLINE(AA>BB,6,90,5,0)COLOR00FF00;
STICKLINE(BB>AA,6,90,5,0)COLOR422D00;
周K:=MA("KDJ.K#WEEK"(9,3,3) ,5),LINETHICK2,COLORWHITE;
周D:=MA("KDJ.D#WEEK"(9,3,3) ,5),LINETHICK2,COLOR33FF99;
周J:=MA("KDJ.J#WEEK"(9,3,3) ,5),LINETHICK2,COLORMAGENTA;
周金▲:DRAWTEXT(CROSS("KDJ.K#WEEK"(9,3,3),"KDJ.D#WEEK"(9,3,3)) ,0,'周▲'),COLORRED;
周死▼:DRAWTEXT(CROSS("KDJ.D#WEEK"(9,3,3),"KDJ.K#WEEK"(9,3,3)) ,92,'周▼'),COLORGREEN;
金叉:IF(CROSS(周K,周D),90,0)LINETHICK3,COLORRED;
DRAWTEXT(周金叉,80,'周叉'),;
DRAWICON(CROSS(周K,周D),90,5);
DRAWBAND(周K,RGB(100,0,0),周J,RGB(0,100,0));
M:=60; N:=30;
N1:=5;N2:=10;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,30);
VAR6:=HHV(VAR4,30);
VAR7:=IF(MA(CLOSE,58),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,50,VAR8);
吸筹了:=STICKLINE(VAR9>-120,0,VAR9,2,5),{COLORMAGENTA}COLORGRAY;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
散户线: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M))COLORGRAY,LINETHICK4;
VAR1:=1;
VAR55:=LLV(LOW,8);
VAR66:=HHV(HIGH,8);
VAR77:=(VAR66-VAR55)/10;
VAR88:=SMA((CLOSE-VAR55)/VAR77,20,1);
VARA:=3*VAR88-2*SMA(VAR88,15,1);
股民筹码集中:=(10-VARA)*VAR1*6,COLORGREEN,LINETHICK1;
机构筹码集中度:EMA(WINNER(C)*80,3),LINETHICK5,COLORRED;
主力筹码:= 10*WINNER(CLOSE*0.9)*8,LINETHICK2 COLORFF00FF;
VAR11:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR11-REF(VAR11,1))/REF(VAR11,1)*4000;
STICKLINE(控盘<0,控盘,0,1,0),COLORWHITE;
A10:=CROSS(控盘,0);
无庄控盘:=IF(控盘<0,控盘,0),COLORWHITE,NODRAW;
开始控盘:=IF(A10,55,0),LINETHICK4,COLORYELLOW;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORRED;
有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
VAR222:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR222>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORFF00FF;
高度控盘:IF(VAR222>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLOR00FF00;
主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;
90;
VAR23:=REF(LOW,1);
VAR33:=SMA(ABS(LOW-VAR23),3,1)/SMA(MAX(LOW-VAR23,0),3,1)*100;
VAR44:=EMA(IF(CLOSE*1.3,VAR33*10,VAR33/10),3);
VAR556:=LLV(LOW,13);
VAR667:=HHV(VAR44,13);
VAR777:=IF(MA(CLOSE,34),1,0);
VAR888:=EMA(IF(LOW<=VAR556,(VAR44+VAR667*2)/2,0),3)/618*VAR777;
VAR999:=IF(VAR888>100,100,VAR888);
吸筹:VAR999,LINETHICK2,COLORRED;
今量:=吸筹;
STICKLINE(吸筹>0,0 ,今量*1.2,8,0 ),COLOR00EEFF;
STICKLINE(吸筹>0,0 ,今量*0.8,8,0 ),COLOR00BBFF;
STICKLINE(吸筹>0,0 ,今量*0.6,8,0 ),COLOR0099FF;
STICKLINE(吸筹>0,0 ,今量*0.4,8,0 ),COLOR0066FF;
STICKLINE(吸筹>0,0 ,今量*0.2,8,0 ),COLOR0000FF;

通达信主力进出2指标公式

 

相关文章