在线检测未来函数

通达信获利云梯主图指标公式

来源:Internet,编辑:股旁网,2015-01-05

N:=5;
A1:=COST(1);
A90:=COST(90);
A99:=COST(99);
A50:COST(50);
DRAWBAND(MA(C,6),90,A50,0);
DRAWBAND(MA(C,5),RGB(36,35,139),COST(99),RGB(36,35,139));
DRAWBAND(C,180,MA(C,5),RGB(36,35,139));
A5:=COST(5);
A10:=COST(10);
A20:=COST(20);
A30:=COST(30);
A40:=COST(40);
A60:=COST(60);
A70:=COST(70);
A80:=COST(80);
B99:IF(CURRBARSCOUNT<=10,CONST(REF(A99,N)),DRAWNULL);
B90:IF(CURRBARSCOUNT<=10,CONST(REF(A90,N)),DRAWNULL);
B80:IF(CURRBARSCOUNT<=15,CONST(REF(A80,N)),DRAWNULL);
B70:IF(CURRBARSCOUNT<=20,CONST(REF(A70,N)),DRAWNULL);
B60:IF(CURRBARSCOUNT<=25,CONST(REF(A60,N)),DRAWNULL);
B50:IF(CURRBARSCOUNT<=30,CONST(REF(A50,N)),DRAWNULL);
B40:IF(CURRBARSCOUNT<=35,CONST(REF(A40,N)),DRAWNULL);
B30:IF(CURRBARSCOUNT<=40,CONST(REF(A30,N)),DRAWNULL);
B20:IF(CURRBARSCOUNT<=45,CONST(REF(A20,N)),DRAWNULL);
B10:IF(CURRBARSCOUNT<=50,CONST(REF(A10,N)),DRAWNULL);
B5:IF(CURRBARSCOUNT<=55,CONST(REF(A5,N)),DRAWNULL);
B1:IF(CURRBARSCOUNT<=55,CONST(REF(A1,N)),DRAWNULL);
STICKLINE(1,B1,B5,0,-1),COLORWHITE;
STICKLINE(1,B5,B10,0,-1),COLORYELLOW;
STICKLINE(1,B10,B20,0,-1),COLORBROWN;
STICKLINE(1,B20,B30,0,-1),COLORLIRED;
STICKLINE(1,B30,B40,0,-1),COLORMAGENTA;
STICKLINE(1,B40,B50,0,-1),COLORLIMAGENTA;
STICKLINE(1,B50,B60,0,-1),COLORWHITE;
STICKLINE(1,B60,B70,0,-1),COLORYELLOW;
STICKLINE(1,B70,B80,0,-1),COLORBROWN;
STICKLINE(1,B80,B90,0,-1),COLORLIRED;
STICKLINE(1,B90,B99,0,-1),COLORMAGENTA;
DRAWKLINE(H,O,L,C);

通达信获利云梯主图指标公式

 

相关文章