在线检测未来函数

飞狐战神买卖主图指标公式

来源:Internet,编辑:股旁网,2015-01-07

M1:=3;
M2:=5;
M3:=21;
M4:=60;
N1:=5;
N2:=3;
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
VAR1:=EMA((C-(LLV(L,25)))/((HHV(H,25))-(LLV(L,25)))*100,5);
VAR2:=VAR1,COLORRED,LINETHICK2;
VAR3:=MA((V-REF(V,1))/REF(V,1),5);
VAR4:=(C-MA(C,24))/MA(C,24)*100;
VAR5:=VAR4*(1+VAR3);
VAR6:=REF(VOL,1);
VAR7:=SMA(MAX(VOL-VAR6,0),6,1)/SMA(ABS(VOL-VAR6),6,1)*100;
VAR8:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR9:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR10:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR11:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR12:=VAR5>REF(VAR5,1);
VAR13:=VAR5<REF(VAR5,1);
VAR14:=VAR2<REF(VAR2,1);
VAR15:=VAR2>REF(VAR2,1);
VAR16:=VAR8 OR VAR10;
VAR17:=VAR9 OR VAR11;
VAR18:=VAR13 AND VAR14;
VAR19:=VAR16 OR VAR18;
VAR20:=VAR12 AND VAR15;
VAR21:=VAR17 OR VAR20;
VAR22:=LAST(VAR19,N1,1) AND VAR20;
VAR23:=LAST(VAR21,N2,1) AND VAR18;
DRAWTEXT(VAR22,L,'★买'),COLOR00FFFF;
DRAWTEXT(VAR23,H,'★卖'),COLORWHITE;

飞狐战神买卖主图指标公式

 

相关文章