在线检测未来函数

通达信狂龙出击指标公式

来源:Internet,编辑:股旁网,2015-01-07

DIFF:(EMA(CLOSE,10)-EMA(CLOSE,20))*0.7,LINETHICK1,COLORRED;
DEAF:EMA(DIFF,8),LINETHICK1,COLORGREEN;MACD1:=(DIFF-DEAF),COLORSTICK;
DRAWBAND(DIFF,RGB(250,10,10),DEAF,RGB(0,0,0));
SHORT:=5;
LONG:=26;
MID:=2;
DIF:(EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)),LINETHICK1,COLOR0000FF;
DEA:EMA(DIF,MID);
DRAWBAND(DIF,RGB(500,180,280),DEA,RGB(380,280,180));
MACD:=(DIF-DEA)*2,COLORSTICK;
向下:=IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(DIF,DEA) AND DIF>REF(DIF,1) AND DEA<0,DIF,0);
趋势线:=MACD1,LINETHICK2,COLORCYAN;
判断:=(SMA(((C+L)/2-LLV(L,21))/(HHV((H+C)/2,21)-LLV(L,21))*100,2,1)-8);
STICKLINE(FILTER(CROSS(判断,趋势线)=1 OR 判断>REF(判断,1),10) AND 判断<25 ,0,0.02,4,0),COLORRED;
STICKLINE(FILTER(判断<REF(判断,1)AND 判断>65,5),0,0.02,4,0),COLORGREEN;
MA5:=EMA(C,3);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0),COLOR00FF00;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
STICKLINE(TJ2,0,0.02,5,0),COLOR008888;
STICKLINE(TJ2,0,0.02,2,0),COLOR00AAAA;
STICKLINE(TJ2,0,0.02,1,0),COLOR00CCCC;
STICKLINE(TJ2,0,0.03,0.2,0),COLOR00FFFF;
DRAWTEXT(TJ2,-0.01,'大牛'),COLOR00FFFF;
0;

通达信狂龙出击指标公式

 

相关文章