在线检测未来函数

飞狐MACD88指标公式

来源:Internet,编辑:股旁网,2015-01-13

DIFF9:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),COLORRED;
DEA9:=EMA(DIFF9,9),COLORRED,LINETHICK2;
MACD:2*(DIFF9-DEA9), COLORSTICK,LINETHICK2;
A1:=BARSLAST(REF(CROSS(DIFF9,DEA9),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF9>REF(DIFF9,A1+1) AND CROSS(DIFF9,DEA9);
STICKLINE(背离,0,DEA9,2,0),COLOR00FF00;
DRAWTEXT(背离,DEA9,' 背离');
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.5,0),COLORFF99AA;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,0.5,0),COLORBLUE;
STICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,0.5,0),COLORGRAY;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0.5,0),COLORMAGENTA;
DIFF :(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),COLORRED;
DEA : EMA(DIFF9,9),COLORRED,LINETHICK2;

飞狐MACD88指标公式

 

相关文章