在线检测未来函数

大智慧秘密买点Z指标公式

来源:Internet,编辑:股旁网,2015-01-13

N:=14;
K:=N/2;
MAK:MA(CLOSE,K),COLORWHITE,LINETHICK2;
MAN:MA(CLOSE,N),COLORYELLOW,LINETHICK2;
DTPL:=MA(C,N)>MA(C,N*1.5) AND MA(C,N*1.5)>MA(C,N*3) AND MA(C,3)>MA(C,N*6);
选择均线:N,POINTDOT,COLORYELLOW;
强弱天数:K,POINTDOT,COLORFF00FF;
连续走强:=COUNT(C>MA(C,N),K)=K;
ZQSJ:=BARSLAST(连续走强);
{STICKLINE(连续走强 ,0 ,K*0.3 ,5 ,1 ),colorYELLOW;}
下穿:=CROSS(MA(C,N),C);
GL:=MA(C,N/2)/MA(C,N*2)>=1.05;
买跌:(下穿 AND ZQSJ<=3 AND DTPL AND GL)*N,COLOR00FF00,LINETHICK2;
连续走弱:=COUNT(C<MA(C,N),K)=K;
ZRSJ:=BARSLAST(连续走弱);
{STICKLINE(连续走弱 ,0 ,K*-0.3 ,5 ,1 ),color00FF00;}
上穿:=CROSS(C,MA(C,N));
买涨:(上穿 AND ZRSJ<=3)*K,COLORFF00FF,LINETHICK2;
{以下设置显示方式:}
DRAWTEXT(买涨>0 ,L*0.99 , '●'),colorYELLOW,LINETHICK1;
STICKLINE(买涨>0,h,l,0,1),colorYELLOW,linethick2;
STICKLINE(买涨>0,o,c,4,1),colorYELLOW,linethick2;
DRAWTEXT(买跌>0 ,L*0.99 , '◆'),COLOR00FF00,LINETHICK1;
STICKLINE(买跌>0 ,h,l,0,1),COLOR00FF00,linethick2;
STICKLINE(买跌>0 ,o,c,4,1),COLOR00FF00,linethick2;
DRAWTEXT(连续走强>0 ,MAN-0.01 , '○'),colorYELLOW,LINETHICK1;
DRAWTEXT(连续走弱>0 ,MAK-0.01 , '○'),color00FF00,LINETHICK1;

大智慧秘密买点Z指标公式

 

相关文章