在线检测未来函数

通达信ADX指标公式

来源:Internet,编辑:股旁网,2015-01-15

N:=14;
TR1:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/TR1,COLORRED,DOTLINE;
MDI:DMM*100/TR1,COLORGREEN,DOTLINE;
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORYELLOW,LINETHICK2;
20;
40;

通达信ADX指标公式

 

相关文章