在线检测未来函数

大智慧春夏秋冬主图指标公式

来源:Internet,编辑:股旁网,2015-01-19

M9:=MA(CLOSE,9);
Y:=((HIGH + LOW) / 2);
AO:=(MA(Y,5) - MA(Y,34));
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
VAR22:=(((((3 * CLOSE) + LOW) + OPEN) + HIGH) / 6);
VAR33:=(((((((((((((((((((((20 * VAR22) + (19 * REF(VAR22,1))) + (18 * REF(VAR22,2))) + (17 * REF(VAR22,3))) + (16 * REF(VAR22,4))) + (15 * REF(VAR22,5))) + (14 * REF(VAR22,6))) + (13 * REF(VAR22,7))) + (12 * REF(VAR22,8))) + (11 * REF(VAR22,9))) + (10 * REF(VAR22,10))) + (9 * REF(VAR22,11))) + (8 * REF(VAR22,12))) + (7 * REF(VAR22,13))) + (6 * REF(VAR22,14))) + (5 * REF(VAR22,15))) + (4 * REF(VAR22,16))) + (3 * REF(VAR22,17))) + (2 * REF(VAR22,18))) + REF(VAR22,20)) / 210);
VAR44:=MA(VAR33,13);
VAR555:=EMA(MA(CLOSE,33),34);
VAR66:=((((MA(CLOSE,33) + MA(CLOSE,6)) + MA(CLOSE,12)) + MA(CLOSE,24)) / 4);
VAR7:=MA(VAR66,5);
VAR8:=MA(VAR66,10);
关注:STICKLINE(((COUNT(((VAR33 > (1.005 * VAR44)) AND (VAR33 <= REF(VAR33,1))),2) = 2) OR (COUNT((IF((VAR33 < VAR555),(VAR33 <= (1.015 * VAR44)),(VAR33 <= (1.005 * VAR44))) AND (VAR33 >= REF(VAR33,1))),2) = 2)),VAR33,VAR44,10,0),color008000;
买入:DRAWTEXT((REF(CROSS(VAR33,VAR44),2) AND (VAR33 > (1.005 * VAR44))),VAR44,'★'),color0000FF;
争夺:DRAWTEXT((CROSS(VAR66,VAR7) AND (VAR7 < VAR8)),(VAR33 * 0.99),'▲'),color0000FF;
DRAWTEXT((CROSS(VAR7,VAR66) AND (VAR7 > VAR8)),(VAR33 * 1.01),'?'),color0000FF;
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF((TDU3 < TUD3),REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));
JDU0:=(((REF(CLOSE,1) <= REF(UDGLINE,1)) AND (CLOSE > UDGLINE)) AND (TDU0 < TUD0));
JUD0:=(((REF(CLOSE,1) >= REF(UDGLINE,1)) AND (CLOSE < UDGLINE)) AND (TUD0 < TDU0));
JDU1:=(JDU0 AND (COUNT(JDU0,TDU0) = 1));
JUD1:=(JUD0 AND (COUNT(JUD0,TUD0) = 1));
JDU2:=(JDU1 AND (REF(BARSLAST(JUD1),1) < REF(BARSLAST(JDU1),1)));
DRAWTEXT(JDU2,(M9 * 0.95),'▲●▲'),color000001;
VAR122:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) * 100);
VAR14:=((OPEN > CLOSE) AND ((HIGH - IF((CLOSE > OPEN),CLOSE,OPEN)) > (IF((OPEN < CLOSE),OPEN,CLOSE) - LOW)));
VARA:=(((REF(VAR122,1) > ABS((0 - 13))) AND (CLOSE < OPEN)) AND ((((REF(CLOSE,1) - CLOSE) / REF(CLOSE,1)) * 1000) > 20));
VARB:=FILTER((((REF(VAR122,1) > ABS((0 - 13))) AND VAR14) OR VARA),3);
DRAWTEXT(((VARB * VAR122) > 0),(1 * REF(CLOSE,1)),'?★?'),color000001;
VARE:=FILTER(((((REF((((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) * 100),1) < (0 - 13)) AND (CLOSE > OPEN)) AND ((OPEN - LOW) > (HIGH - CLOSE))) OR (((REF((((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) * 100),1) < (0 - 13)) AND (CLOSE > OPEN)) AND ((((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 1000) > 20))),3);
DRAWTEXT((VARE > 0),LOW,'←---★?'),color0000FF;
H0:=REF(CLOSE,1);
VAR51:=EMA((((((((2 * CLOSE) + HIGH) + LOW) / 4) - LLV(LOW,34)) / (HHV(HIGH,34) - LLV(LOW,34))) * 100),6);
VAR52:=EMA(((0.667 * REF(VAR51,1)) + (0.333 * VAR51)),4);
DRAWTEXT(IF((((((COUNT((CLOSE < REF(CLOSE,1)),8) / 8) > 0.3) AND COUNT((VAR51 > VAR52),3)) AND (REF(LOW,1) = LLV(LOW,120))) AND (CLOSE > OPEN)),1,0),LOW,'-->★●'),color0000FF;
VAR55:=EMA(EMA(EMA(CLOSE,8),13),62);
VAR56:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR57:=(MA(CLOSE,20) + (2 * STD(CLOSE,20)));
DRAWICON(CROSS(VAR56,VAR57),(HIGH * 1.035),11);
DRAWTEXT(CROSS(VAR56,VAR57),(HIGH * 1.04),'------->★'),color00FFFF;
VAR58:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),7,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),7,1)) * 100);
LC:=FILTER(CROSS(79,VAR58),4);
DRAWICON(LC,(HIGH * 1.035),11);
DRAWTEXT(LC,(HIGH * 1.04),'------>★'),color00FFFF;
RSI:=EMA((((((((2 * CLOSE) + HIGH) + LOW) / 4) - VAR55) / (VAR56 - VAR55)) * 100),7);
VAR1:=EMA(((0.667 * REF(RSI,1)) + (0.333 * RSI)),5);
DRAWTEXT(IF((((((COUNT((CLOSE < REF(CLOSE,1)),8) / 8) > 0.6) AND (VOL >= (1.5 * MA(VOL,5)))) AND COUNT((RSI >= VAR1),3)) AND (REF(LOW,1) = LLV(LOW,120))),1,0),LOW,'★●');
DRAWTEXT(IF((((((((((COUNT((CLOSE < REF(CLOSE,1)),13) / 13) > 0.6) AND COUNT((RSI > VAR1),6)) AND (REF(LOW,5) = LLV(LOW,120))) AND REF((CLOSE >= OPEN),4)) AND REF((CLOSE > OPEN),3)) AND REF((CLOSE > OPEN),2)) AND REF((OPEN > CLOSE),1)) AND (OPEN > REF(CLOSE,1))),1,0),LOW,'●●'),colorFF0000;
B2:=(MA(CLOSE,80) - (MA(CLOSE,10) / 3));
DRAWTEXT(IF(((((CLOSE < B2) AND ((VOL / 240) > (MA(VOL,5) / 240))) AND (CLOSE > (REF(CLOSE,1) * 1.08))) AND (CLOSE < (MA(CLOSE,13) * 1.3))),1,0),LOW,'●★'),color0000FF;
DRAWICON(CROSS(MA(CLOSE,5),MA(CLOSE,30)),(LOW - (LOW * 0.01)),8);
DRAWTEXT((CROSS(MA(CLOSE,5),MA(CLOSE,30)) AND (CLOSE > MA(CLOSE,250))),(LOW - (LOW * 0.02)),'←---★ '),color0000FF;
DRAWTEXT(((CROSS(MA(CLOSE,5),MA(CLOSE,30)) AND (CLOSE >= MA(CLOSE,60))) AND (CLOSE <= MA(CLOSE,250))),(LOW - (LOW * 0.02)),'←---★★'),color0000FF;
DRAWTEXT((CROSS(MA(CLOSE,5),MA(CLOSE,30)) AND (CLOSE < MA(CLOSE,60))),(LOW - (LOW * 0.02)),'←---★★★ '),color0000FF;
MA21:=REF(CLOSE,1);
ZX:=((SMA(MAX((CLOSE - MA21),0),6,1) / SMA(ABS((CLOSE - MA21)),6,1)) * 100);
DRAWTEXT(CROSS(84,ZX),HIGH,'-----→ ★ '),colorFF00FF;
大雪:MA((((HIGH + LOW) + CLOSE) / 3),8);
无痕:MA((((HIGH + LOW) + CLOSE) / 3),21);
VAR111:=EMA(((OPEN + CLOSE) / 2),26);
VAR222:=MA(COST(30),3);
天下有雪:MA(COST(50),3);
VAR3:=MA(COST(80),3);
VAR4:=(((HIGH + LOW) + CLOSE) / 3);
VAR5:=EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),233);
VAR6:=(VAR5 + ((VAR5 * 6) / 100));
严冬:STICKLINE((VAR4 > 0.1),HIGH,LOW,0.5,0),colorFFFFFF;
早春:STICKLINE(((((VAR4 < 天下有雪) AND (VAR4 > 无痕)) OR ((VAR4 < VAR5) AND (VAR4 > 无痕))) OR ((VAR4 > 无痕) AND (VAR111 > 无痕))),HIGH,LOW,0.5,0),color00FF00;
初夏:STICKLINE((((((VAR4 > 天下有雪) AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))) OR ((((VAR4 > VAR222) AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1)))),HIGH,LOW,0.5,0),color0000FF;
深秋:STICKLINE(((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 无痕)) AND (VAR111 > REF(VAR111,1))),HIGH,LOW,0.5,0),color00FFFF;
STICKLINE(((VAR4 > 0.1) AND (CLOSE < OPEN)),OPEN,CLOSE,9,0),colorFFFFFF;
STICKLINE(((VAR4 > 0.1) AND (CLOSE >= OPEN)),OPEN,CLOSE,9,1),colorFFFFFF;
STICKLINE((((((VAR4 < 天下有雪) AND (VAR4 > 无痕)) AND (CLOSE < OPEN)) OR (((VAR4 < VAR5) AND (VAR4 > 无痕)) AND (CLOSE < OPEN))) OR (((VAR4 > 无痕) AND (VAR111 > 无痕)) AND (CLOSE < OPEN))),OPEN,CLOSE,9,0),color00FF00;
STICKLINE((((((VAR4 < 天下有雪) AND (VAR4 > 无痕)) AND (CLOSE > OPEN)) OR (((VAR4 < VAR5) AND (VAR4 > 无痕)) AND (CLOSE > OPEN))) OR (((VAR4 > 无痕) AND (VAR111 > 无痕)) AND (CLOSE >= OPEN))),OPEN,CLOSE,9,1),color00FF00;
STICKLINE(((((((VAR4 > 天下有雪) AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))) AND (CLOSE < OPEN)) OR (((((VAR4 > VAR222) AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))) AND (CLOSE < OPEN))),OPEN,CLOSE,9,0),color0000FF;
STICKLINE(((((((VAR4 > 天下有雪) AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))) AND (CLOSE > OPEN)) OR (((((VAR4 > VAR222) AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))) AND (CLOSE >= OPEN))),OPEN,CLOSE,9,1),color0000FF;
STICKLINE((((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 无痕)) AND (VAR111 > REF(VAR111,1))) AND (CLOSE < OPEN)),OPEN,CLOSE,9,0),color0000FF;
STICKLINE((((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 无痕)) AND (VAR111 > REF(VAR111,1))) AND (CLOSE >= OPEN)),OPEN,CLOSE,9,1),color00FFFF;
STICKLINE(1,CLOSE,OPEN,0.5,0),colorFFFFFF;
VAR101:=EMA(CLOSE,3);
vVAR2:=EMA(CLOSE,8);
V2:=EMA(CLOSE,21);
STICKLINE(((VAR101 < vVAR2) AND (VAR101 > V2)),HIGH,LOW,0,1),colorFF5D10;
STICKLINE(((VAR101 < vVAR2) AND (VAR101 > V2)),CLOSE,OPEN,5,0),colorFF5D10;
STICKLINE(((VAR101 > vVAR2) AND (VAR101 < V2)),HIGH,LOW,0,1),colorFF00FF;
STICKLINE(((VAR101 > vVAR2) AND (VAR101 < V2)),CLOSE,OPEN,5,0),colorFF43FF;
KS:=MA(CLOSE,20);
V3:=REF(KS,((20 / 2) + 1));
V4:=((EMA(CLOSE,3) - EMA(CLOSE,6)) - ((EMA(CLOSE,6) - EMA(CLOSE,12)) * (0 - 100)));
VAR12:=EMA(V4,3);
VAR15:=CROSS(V4,VAR12);
VAR16:=CROSS(VAR12,V4);
风险:STICKLINE(VAR16,OPEN,CLOSE,5,0),color222222;
收益:STICKLINE(VAR15,OPEN,CLOSE,5,0),color0000FF;
止损:STICKLINE(VAR15,OPEN,(CLOSE - ((CLOSE - OPEN) * 0.33)),5,0),colorC367B2;
止盈:STICKLINE(VAR15,OPEN,(CLOSE - ((CLOSE - OPEN) * 0.66)),5,0),colorAE996E;
V5:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * (0 - 100));
STICKLINE((V5 >= 8),OPEN,CLOSE,9,1),LINETHICK2,colorFFFFFF;
STICKLINE(1,CLOSE,OPEN,0.5,0),colorFFFFFF;V6:=(((((SMA(AMOUNT,19,3) / 60000) * CLOSE) / MA(REF(CLOSE,1),5)) * 60000) / 5700000);
VAR11:=IF(((V6 > REF(V6,1)) AND (REF(V6,1) >= REF(V6,2))),1,IF(((V6 < REF(V6,1)) AND (REF(V6,1) <= REF(V6,2))),(0 - 1),IF(((V6 > REF(V6,2)) AND (REF(V6,2) > REF(V6,1))),2,IF(((V6 < REF(V6,2)) AND (REF(V6,2) < REF(V6,1))),(0 - 2),0))));
VAR2:=if(ref(V6,1) > ref(V6,2) and ref(V6,1)>ref(V6,3),1,if(ref(V6,1)<ref(V6,2) and ref(V6,1)<ref(V6,3),-1,if(ref(V6,2)>ref(V6,3) and ref(V6,2)>ref(V6,4),2,if(ref(V6,2)<ref(V6,3) and ref(V6,2)<ref(V6,4),-2,if(ref(V6,3)>ref(V6,4) and ref(V6,3)>ref(V6,5),3,if(ref(V6,3)<ref(V6,4) and ref(V6,3)<ref(V6,5),-3,0))))));
带量上涨:STICKLINE((VAR11 = 2),OPEN,CLOSE,5,0),color0000FF;
蓄勢:STICKLINE((((VAR11 = 1) OR (VAR11 = 2)) AND (VAR2 < 0)),OPEN,((CLOSE + OPEN) / 2),5,0),colorFF00FF;
多翻空变盘:STICKLINE((((VAR11 = (0 - 1)) OR (VAR11 = (0 - 2))) AND (VAR2 > 0)),OPEN,((CLOSE + OPEN) / 2),5,0),colorF86A71;
STICKLINE(1,CLOSE,OPEN,0.5,0),colorFFFFFF;

大智慧春夏秋冬主图指标公式

 

相关文章