在线检测未来函数

通达信黄金麦克主图指标公式

来源:Internet,编辑:股旁网,2015-01-19

使用说明:发一个黄金分割+麦克组合指标,突破黄金分割线和麦克指标线可能会有一个起爆。

N:=10;
HLC:REF(MA((HIGH+LOW+CLOSE)/3,N),1);
HV:EMA(HHV(HIGH,N),3);
WEKS:EMA(HLC*2-HV,3);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED;
一0.809:REFDATE(H1,DATE),DOTLINE,COLORFFFF00;
二0.618:REFDATE(H2,DATE),DOTLINE,COLORMAGENTA;
三0.500:REFDATE(H3,DATE),DOTLINE,COLORWHITE;
四0.382:REFDATE(H4,DATE),DOTLINE,COLORGREEN;
五0.191:REFDATE(H5,DATE),DOTLINE,COLORYELLOW;
低:REFDATE(低1,DATE),DOTLINE,COLORRED;
HJF1:=O<MA(C,5) AND C>MA(C,5) AND O<MA(C,10) AND C>MA(C,10) AND O<MA(C,20) AND C>MA(C,20) AND O<MA(C,120) AND C>MA(C,120);
HJF11:=O<MA(C,5) AND C>MA(C,5) AND O<MA(C,10) AND C>MA(C,10) AND O<MA(C,20) AND C>MA(C,20) AND O<MA(C,60)AND C>MA(C,60);
HJF2:=(O<低 AND C>低 AND 低/O<1.06) OR (O<五0.191 AND C>五0.191 AND 五0.191/O<1.06) OR (O<四0.382 AND C>四0.382 AND 四0.382/O<1.06);
HJF3:=C/REF(C,1)>1.04;
HFXG:=(HJF1 OR HJF11) AND HJF2 AND HJF3;

通达信黄金麦克主图指标公式

 

相关文章