在线检测未来函数

飞狐中短底买点指标公式

来源:Internet,编辑:股旁网,2015-01-20

DRAWGBK(c, COLORRGB(2,1111,4444), COLORRGB(2,3333,6666),2);
价相对位:=(C-LLV(L,10))/(HHV(H,10)-LLV(L,10))*100;
K10:=EMA(价相对位,7);
D10:=EMA(K10,10);
J10:=3*K10-2*D10;
J10m:=EMA(J10,5);
FILLRGN(C,J10m,-J10m),COLOR005500;
短底:REF((COUNT((J10m<=REF(J10m,1)),5)=5),1) AND (J10m>REF(J10m,1)),ColorFFFF00;
STICKLINE(短底,-20,20,15,1),ColorFFFF00;
价相对位27:=(C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100;
J27:=5*SMA(价相对位27,5,1)-3*SMA(SMA(价相对位27,5,1),3,1)-SMA(SMA(SMA(价相对位27,5,1),3,1),2,1);
J27a:=3*SMA(价相对位27,5,1)-2*SMA(SMA(价相对位27,5,1),3,1);
探中底:IF((J27a<=5),58,0),ColorFF00FF;
中底:CROSS(J27,5),coloryellow;
DRAWTEXT(中底,0,'◥◤'),Color00FFFF;
DRAWTEXT(中底,15,'◢◣'),Color00FFFF;
A:=(REF(C,4)>REF(C,2) or REF(C,4)<=REF(C,2) AND REF(C,5)>=REF(C,3));
B:=(REF(C,3)>REF(C,1) or REF(C,3)<=REF(C,1) AND REF(C,4)>=REF(C,2));
VARA1:=C>=REF(C,1) AND REF(C,1)>=REF(C,2) AND REF(C,1)<=REF(C,3)
AND REF(C,2)<=REF(C,3) AND A or C>=REF(C,1) AND (REF(C,1)<=REF(C,2))
AND C>=REF(C,2) AND B;
价相对位5:=EMA(((C-LLV(L,5))/(HHV(H,5)-LLV(L,5)))*100,4);
J5:=EMA(0.667*(REF(价相对位5,1))+0.333*价相对位5,2);
VARA6:=J5<24 AND (O<MA(C,20));
中底2:VARA6 AND VARA1,Color2894FF;
STICKLINE(中底2,-40,40,8,1),Color2894FF;
半月涨跌值均线:MA((C-REF(C,13))*31,5),LINETHICK1,COLOR7711EE;
//疯牛绝佳买点--真神了
VarF1:=MA(HHV(H,485),17);
VarF2:=MA(HHV(H,222),17);
VarF3:=MA(HHV(H,96),17);
VarF4:=MA(LLV(L,485),17);
VarF5:=MA(LLV(L,222),17);
VarF6:=MA(LLV(L,96),17);
VarF7:=MA((VarF4*0.96+VarF5*0.96+VarF6*0.96+VarF1*0.558+VarF2*0.558+VarF3*0.558)/6,17);
VarF8:=MA((VarF4*1.25+VarF5*1.23+VarF6*1.2+VarF1*0.55+VarF2*0.55+VarF3*0.65)/6,17);
VarF9:=MA((VarF4*1.3+VarF5*1.3+VarF6*1.3+VarF1*0.68+VarF2*0.68+VarF3*0.68)/6,17);
VarFA:=MA((VarF7*3+VarF8*2+VarF9)/6*1.738,17);
VarFE:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VarFF:=MA(IF(C*1.35<=VarFA,VarFE*10,VarFE/10),3);
VarF11:=HHV(VarFF,30);
绝佳买点:MA(IF(L<=LLV(L,30),(VarFF+VarF11*2)/2,0),3)/200;
DRAWTEXT(CROSS(绝佳买点,2.4) ,-8,'绝技'),colorwhite;
DRAWTEXT(CROSS(绝佳买点,4.2) ,-20,'牛'),color00FF00 ;
DRAWTEXT(CROSS(绝佳买点,1.2) ,-32,'疯牛!'),coloryellow;
DRAWTEXT(CROSS(绝佳买点,2.4) ,-45,'疯牛1'),colorFF99FF ;
DRAWTEXT(CROSS(绝佳买点,3.6) ,38,'疯牛2'),colorFF00FF;
DRAWTEXT(CROSS(绝佳买点,4.5) ,58,'倾家荡产买'),color9966FF;
DRAWTEXT(CROSS(绝佳买点,7.0) ,78,'疯牛3'),colorred;
正换手:=IF(C<REF(C,1),0,VOL/CAPITAL);
骤雨初晴:ABS(EMA(正换手,13.3)-18)/WINNER(C)*IF((C-MA(C,6))/MA(C,6)<-0.04,1,0)>2,coloryellow,LINETHICK0;
DRAWICON(骤雨初晴, 1.8,12);
81,LINEDASH,COLORFFFFDD;

飞狐中短底买点指标公式

 

相关文章