在线检测未来函数

通达信趋势平衡点主图指标公式

来源:Internet,编辑:股旁网,2015-01-26

APX:=(H+L+C)/3;
TR0:=MAX(H-L,MAX(ABS(H-REF(C,1)),ABS(L-REF(C,1))));
MF0:=C-REF(C,2);
MF1:=REF(MF0,1);
MF2:=REF(MF0,2);
DIRECT1:=BARSLAST(MF0>MF1 AND MF0>MF2);
DIRECT2:=BARSLAST(MF0<MF1 AND MF0<MF2);
DIRECT0:=IF(DIRECT1<DIRECT2,100,-100);
TBP:REF(REF(C,1)+IF(DIRECT0>50,MIN(MF0,MF1),MAX(MF0,MF1)),1);
多头获利:REF(IF(DIRECT0>50,APX*2-L,DRAWNULL),1),NODRAW;
多头停损:REF(IF(DIRECT0>50,APX-TR0,DRAWNULL),1),NODRAW;
空头回补:REF(IF(DIRECT0<-50,APX*2-H,DRAWNULL),1),NODRAW;
空头停损:REF(IF(DIRECT0<-50,APX+TR0,DRAWNULL),1),NODRAW;

通达信趋势平衡点主图指标公式

 

相关文章