在线检测未来函数

通达信双重MACD指标公式

来源:Internet,编辑:股旁网,2015-01-26

STICKLINE(C>0,0,0,10,0),COLORGRAY;
M6:=(EMA(c,5)+EMA(c,6))/2;
M12:=EMA(c,12);
M26:=EMA(c,26);
M56:=ema(C,56);
M121:=ema(C,121);
xdif:((M6-M121)/2+(M12-M56+M26-M121)/2+M6-M26)/3,COLORWHITE;
XDEA:ema(XDIF,3),COLORCYAN;
XMACD:=2*(xdif-XDEA),LINETHICK,COLORWHITE;
DIF:(M56-M121+(M26-M121)/2+(M12-M121)/3+(M6-M121)/4)/4,COLORMAGENTA;
DEA:ema(DIF,9),COLORGREEN;
MACD:2*(DIF-DEA),LINETHICK,COLOR00CCCC;
BMACD:(MACD+XMACD/2)/2,LINETHICK,COLORRED;
STICKLINE(BMACD>=0,0,BMACD,2,1),COLORRED;
STICKLINE(BMACD<0,0,BMACD,2,1),COLOR00bb00;
STICKLINE(MACD>=0,0,MACD,0,0),COLOR00CCCC;
STICKLINE(MACD<0,0,MACD,0,0),COLORCYAN;
JGL:=(((xdif-XDEA)/ABS(XDEA)+(XDEA-DIF)/ABS(DIF)+(DIF-DEA)/ABS(DEA))/3)*10;
DRAWTEXT(CROSS(JGL,0)AND xdif>REF(xdif,1),DEA*0.9,'★'),COLORYELLOW;

通达信双重MACD指标公式

 

相关文章