在线检测未来函数

通达信高手DDX指标公式

来源:Internet,编辑:股旁网,2015-01-27

DRAWBAND(0,RGB(0,139,255),0.5,RGB(0,139,255)),COLORFF8B00;
DRAWBAND(0.5,RGB(0,120,0),1,RGB(0,120,0)),COLOR007800;
DRAWBAND(1,RGB(187,0,187),1.5,RGB(187,0,187)),COLORBB00BB;
DRAWBAND(1.5,RGB(255,58,133),2,RGB(255,58,133)),COLOR853AFF;
DRAWBAND(2,RGB(255,152,0),2.5,RGB(255,152,0)),COLOR0098FF;
DRAWTEXT(ISLASTBAR,0.25,'███'),COLORFF8B00;
DRAWTEXT(ISLASTBAR,0.25,'冰冻'),COLORFFFFCC;
DRAWTEXT(ISLASTBAR,0.75,'███'),COLOR007800;
DRAWTEXT(ISLASTBAR,0.75,'冷门'),COLORWHITE;
DRAWTEXT(ISLASTBAR,1.25,'███'),COLORBB00BB;
DRAWTEXT(ISLASTBAR,1.25,'活跃'),COLORFFFFCC;
DRAWTEXT(ISLASTBAR,1.75,'███'),COLOR853AFF;
DRAWTEXT(ISLASTBAR,1.75,'热门'),COLORWHITE;
DRAWTEXT(ISLASTBAR,2.25,'███'),COLOR0098FF;
DRAWTEXT(ISLASTBAR,2.25,'高温'),COLORWHITE;
{计算数据} R:=PERIOD;
S:=FROMOPEN;
VA1:=EMA(CAPITAL/IF(R=0,SUM(VOL,S),VOL)/CLOSE,10)/CLOSE;
地:IF(VA1>=2.5,2.5,VA1),COLORYELLOW,LINETHICK2;
天: POW(ATAN(EMA(CAPITAL/IF(R=0,SUM(VOL,S),VOL)/CLOSE,10)),2),COLORB5CA43,LINETHICK2;
趋势: EMA(WINNER(CLOSE)*100,10)/50,LINETHICK2,COLOR0015FF;
买卖: EMA((-3)*(HHV(HIGH,30)-CLOSE)/(HHV(HIGH,30)-LLV(LOW,30))+2.7,9),COLORWHITE,LINETHICK2;
{低位信号} 低①:买卖<0,COLORRED,NODRAW;
STICKLINE(低①,0,-0.1,3,0), COLORRED;
低②:买卖<0.1 AND 买卖>0 AND 买卖>=ref(买卖,1),COLORGREEN,NODRAW;
STICKLINE(低②,0,-0.1,2.5,0), COLORGREEN;
低③:买卖<0.25 AND 买卖>0.1 AND 买卖>=ref(买卖,1),COLORYELLOW,NODRAW;
STICKLINE(低③,0,-0.1,2,0), COLORYELLOW;
低A:买卖<0 AND 买卖>=ref(买卖,1),COLOR0099FF,NODRAW;
STICKLINE(低A,0.1,-0.1,3,0), COLOR0099FF;
低B:买卖<ref(HHV(买卖,5),4) AND 买卖>=ref(买卖,1) AND 买卖<0.8 AND 趋势>=ref(趋势,1) AND ref(EXIST(买卖<=ref(买卖,1),2),1) AND ref(EXIST(买卖<=0,10),8),COLOR0099FF,NODRAW;
STICKLINE(低B,0.3,0,3,0), COLOR0099FF;
{高位信号} 高①:买卖>2.5 AND 买卖>ref(买卖,1),COLORRED,NODRAW;
STICKLINE(高①,2.6,2.4,3,0),COLORRED;
高②:天>=1.9 AND 买卖>=2.2 AND CROSS(ref(HHV(买卖,3),3),天),COLOR007800,NODRAW;
STICKLINE(高②,2.6,2.4,2.5,0),COLOR007800;
高③:天<1.77 AND 买卖>=2.2 AND CROSS(ref(HHV(买卖,7),6),天),COLORFF8B00,NODRAW;
STICKLINE(高③,2.6,2.4,2,0),COLORFF8B00;
高A:买卖>2.45 AND 买卖<2.5 AND 买卖<=ref(买卖,1), COLORRED,NODRAW;
STICKLINE(高A,2.5,2.4,3,0), COLORRED;
高B:买卖>ref(LLV(买卖,5),4) AND 买卖<=ref(买卖,1) AND 买卖>1.5 AND 趋势<=ref(趋势,1) AND ref(EXIST(买卖>=ref(买卖,1),2),1) AND ref(EXIST(买卖>=2.48,10),8), COLOR0099FF,NODRAW;
STICKLINE(高B,2.7,2.4,3,0), COLOR0099FF;

通达信高手DDX指标公式

 

相关文章