在线检测未来函数

飞狐上中下通道主图指标公式

来源:Internet,编辑:股旁网,2015-01-28

中轨 :MA(CLOSE,20),COLORRED,LINETHICK2;
上轨:中轨+1*STD(CLOSE,20),COLORWHITE;
下轨:中轨-1*STD(CLOSE,20),COLOR00FF00;
上上轨:中轨+2*STD(CLOSE,20),COLORYELLOW;
下下轨:中轨-2*STD(CLOSE,20),COLORFF00FF;
VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
DRAWICON(CROSS(EMA(C,5),EMA(C,10)),L*0.98,1);
DRAWICON(CROSS(EMA(C,3),EMA(C,07)),L*0.98,9);
DRAWTEXT(CROSS(EMA(C,3),EMA(C,07)),L*0.95,'←买');
S:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1);
STICKLINE(CROSS(78.89,S),H+1.1,H,0.2,1),COLORGRAY;
DRAWTEXT(CROSS(78.89,S),H+1.1,'卖'),COLORFFFF00;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'老鼠仓'),COLOR4080FF;

飞狐上中下通道主图指标公式

 

相关文章