在线检测未来函数

通达信DMI的用法指标公式

来源:Internet,编辑:股旁网,2015-02-02

MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
ADXR:EXPMEMA(ADX,6);
DRAWTEXT_FIX(1,0.5,0.01,1,'当连续上涨到高位时,ADX下穿ADXR或下穿60时卖出;'),COLORGREEN;
DRAWTEXT_FIX(1,0.5,0.11,1,'当连续下跌到低位时,ADX下穿60时买入;'),COLORYELLOW;
DRAWTEXT_FIX(1,0.5,0.21,1,'当在低位盘整一段时间后,ADX上穿20时启动;'),COLORMAGENTA;

通达信DMI的用法指标公式

 

相关文章