在线检测未来函数

通达信五福星指标公式

来源:Internet,编辑:股旁网,2015-02-02

n:=120;m:=10;m1:=20;m2:=30;
J:=KDJ.J;T:=BARSLAST(J<0);
KDJJ:MA((C-REF(C,T))/REF(C,T),1)*100 COLOR0000FF;
VO:=VOL.MAVOL1;
VT:=BARSLAST(VO<=LLV(REF(VO,1),34));
VOL1:MA((C-REF(C,VT))/REF(C,VT),3)*100 LINETHICK2;
CI:=CCI.CCI;
CT:=BARSLAST(CI<=LLV(REF(CI,1),34));
CII:MA((C-REF(C,CT))/REF(C,CT),1)*100 COLOR8000FF;
DIF:=MACD.DIF;
FT:=BARSLAST(DIF<=LLV(REF(DIF,1),34));
MADIF:MA((C-REF(C,FT))/REF(C,FT)*100,3) COLOR408000;
BIA:=BIAS.BIAS1;
BT:=BARSLAST(BIA<=LLV(REF(BIA,1),34));
BIAS1:MA((C-REF(C,BT))/REF(C,BT),1)*100 COLOR8000FF ;
VARA:=LLV(LOW,36);
VARB:=HHV(HIGH,30);
VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*4,4)*25;
STICKLINE(VARC>91,HHV(BIAS1,60),HHV(BIAS1,60)+1,5,0),COLORWHITE;
STICKLINE(VARC<10,-8,-7,5,0),COLORRED;
短底:IF(KDJJ<0 AND VOL1<0 AND CII<0 AND MADIF<0 AND BIAS1<0,-8,DRAWNULL)STICK COLORGREEN LINETHICK3;
反弹:IF(KDJJ=0 AND CII=0 AND BIAS1=0,-7,DRAWNULL)STICK COLORYELLOW;
0 COLORBLUE;
JD:=IF(KDJJ<=LLV(REF(KDJJ,1),20),2,0);
VD:=IF(VOL1<=LLV(REF(VOL1,1),20),2,0);
CD:=IF(CII<=LLV(REF(CII,1),20),2,0);
MD:=IF(MADIF<=LLV(REF(MADIF,1),20),2,0);
BD:=IF(BIAS1<=LLV(REF(BIAS1,1),20),2,0);
抄底:IF((JD+VD+CD+MD+BD)>=6 AND VARC<10,-9,DRAWNULL)STICK COLORYELLOW LINETHICK2;
鞋底:=IF(EVERY(KDJJ<0 AND CII<0 AND BIAS1<0 AND MADIF=0,3),-13,DRAWNULL)STICK;
问D:=IF(KDJJ<=0 AND VOL1<=0 AND CII<=0 AND MADIF<=0 AND BIAS1<=0,-5,DRAWNULL)STICK COLOR008080;
G:=HHV(C,N);GD:=HHV(H,N);D:=LLV(C,N);DD:=LLV(L,N);
LD:=LLV(AMOUNT,N);LG:=HHV(AMOUNT,N);
G1:=HHV(C,M);GD1:=HHV(H,M);D1:=LLV(C,M);DD1:=LLV(L,M);
LD1:=LLV(AMOUNT,M);LG1:=HHV(AMOUNT,M);
G11:=HHV(C,M1);GD11:=HHV(H,M1);D11:=LLV(C,M1);DD11:=LLV(L,M1);
LD11:=LLV(AMOUNT,M1);LG11:=HHV(AMOUNT,M1);
G111:=HHV(C,M2);GD111:=HHV(H,M2);D111:=LLV(C,M2);DD111:=LLV(L,M2);
LD111:=LLV(AMOUNT,M2);LG111:=HHV(AMOUNT,M2);
趋势:=EMA(C,5)COLOR00FF00;
新G120:IF(C>=REF(G,1),C*1.1,DRAWNULL)STICK;
缩G120:IF(H>=REF(GD,1) AND AMOUNT<LG,C,DRAWNULL)STICK LINETHICK6;
新G:=IF(C>=REF(G1,1),C,DRAWNULL)STICK;{新高}
缩G10:IF(H>=REF(GD1,1) AND AMOUNT<LG1,C*0.8,DRAWNULL)STICK LINETHICK7;{缩量新高}
XG11:=IF(C>=REF(G11,1),C,DRAWNULL)STICK;
缩G20:IF(H>=REF(GD11,1) AND AMOUNT<LG11,C*0.5,DRAWNULL)STICK LINETHICK8;
缩G30:IF(H>=REF(GD111,1) AND AMOUNT<LG111,C*0.3,DRAWNULL)STICK LINETHICK9;
新D120:IF(C<=REF(D,1),-C,DRAWNULL)STICK COLOR004000;
放D120:IF(L<=REF(DD,1)AND AMOUNT>=REF(LG1,1),C*-1.2,DRAWNULL)STICK;{放量新低}
放D10:IF(L<=REF(DD1,1)AND AMOUNT>=LG1/2,-C,DRAWNULL)STICK;
放D20:IF(L<=REF(DD11,1)AND AMOUNT>=LG1,C*-0.7,DRAWNULL)STICK;
放D30:IF(L<=REF(DD111,1)AND AMOUNT>=LG1,C*-0.5,DRAWNULL)STICK;
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND CLOSE>0.5,0.5,0.1,0,ROUND(INDEXC));
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>0.51,0.80,0.2,0,'量收益');
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND CLOSE>0.5,0.9,0.2,0,ROUND(VOL1));
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>0.51,0.80,0.3,0,'CCI收益');
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND CLOSE>0.5,0.9,0.3,0,ROUND(CII));

通达信五福星指标公式

 

相关文章