在线检测未来函数

通达信逃顶组合指标公式

来源:Internet,编辑:股旁网,2015-02-13

PAA1:=MAX(C,O)-MIN(C,O)<H-MAX(C,O);
PAA2:=C<REF(C,1)*1.02 AND C>REF(C,1) AND (H-REF(H,1))/REF(C,1)<0.017 AND REF(L,1)>REF(L,2);
PAA:=PAA1 OR PAA2;
PAB:=REF(C,1)>REF(O,1) AND MAX(REF(C,1),REF(O,1))-MIN(REF(C,1),REF(O,1))>REF(C,2)*0.02;
PAC:=L>(REF(H,1)+REF(L,1))/2;
PAAA:=PAA AND PAB AND PAC;
{PAAA今天实体长度小于上影线
PAAB涨幅小于2%今天高点不超过昨天1.7%昨天最低价上升
PAB昨天阳线实体幅度大于2%
PAC今天最低价大于昨天的中间价}
PBA:=HIGH-MAX(C,OPEN)>REF(C,1)*0.027;
PBB:=(HIGH-MAX(C,OPEN))/REF(C,1)+(REF(H,1)-MAX(REF(C,1),REF(O,1)))/REF(C,2)>0.06;
PBAB:=PBA OR PBB;
PBC:=H>MAX(REF(O,1),REF(C,1));
PBABC:=PBAB AND PBC;
PBDA:=HIGH-MAX(C,OPEN)>REF(C,1)*0.02;
PBDB:=(C-REF(C,1))/REF(C,1)>0.035 AND (REF(C,1)-REF(C,2))/REF(C,2)>0.035;
PBD:=PBDA AND PBDB;
PBBB:=PBABC OR PBD;
{PBA长上影线2.7%
PBB两天上影幅度之和大于3%
PBC今天最高价大于昨天实体上线
PBDA今天上影大于2%
PBDB拉两根中阳线大于3.5%}
跑:=PAAA OR PBBB;
中阳小阴:PAAA,POINTDOT,COLORFFBB00;
STICKLINE(中阳小阴,0,60,2,0),COLORFFBB00;
长上影:PBBB,POINTDOT,COLORFFBB00;
STICKLINE(PBBB,0,40,1,0),COLORWHITE;
卖股不亏:IF(MA(H,13)<L*0.9,-20,0),STICK,COLORYELLOW;
{RSIG}
LC := REF(CLOSE,1);
VAR1:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
VAR2:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
VAR3:=EMA(VAR2,21);
VAR4:=EMA(EMA(EMA(VAR2,21),21),21);
RSI1:=VAR1-50,COLORYELLOW,LINETHICK2;
RSI2:=VAR2-50,COLORRED,LINETHICK2;
VAR5:=SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*100;
RSI3:=VAR5-50,COLORWHITE,LINETHICK2;
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,20);
V3:=COUNT(MA(C,1)>REF(C,1),3)=3;
风险1:IF(V1 AND V2 AND V3,60,0),STICK,COLOR00FF00;
V11:=MA(C,5)=HHV(MA(C,5),120);
V21:=MA(C,5)>MA(C,120);
V31:=COUNT(MA(C,1)>REF(C,1),3)=3;
风险2:IF(V11 AND V21 AND V31,50,0),STICK,COLORFF00FF;
短底:=STICKLINE(VAR1<-9 AND VAR1> REF(VAR1,1),VAR1-2,0,3,0),COLORGREEN;
大底:=STICKLINE(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),VAR1-5,0,7,0),COLORYELLOW;
买入准备:=VAR1<-9 AND VAR1> REF(VAR1,1),COLOR33CC00;
VAR9:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
短顶:STICKLINE(VAR9>9 AND FILTER(VAR9< REF(VAR9,1),5),20,0,7,0),COLORFF00FF;
大顶:STICKLINE(VAR9>20 AND FILTER(VAR9< REF(VAR9,1),5),10,0,7,0),COLORFEDCBA;
LCC:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LCC,0),5,1)/SMA(ABS(CLOSE-LCC),5,1)*100;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(B/2+40)*1.1;
DD:=SMA(CCC,3,1);
{【逃1】:IF(CROSS(DD,RSI5),40,0),STICK,LINETHICK1,COLOR00FF00; }
{【逃2】:IF(CROSS(80,RSI5),20,0),STICK,LINETHICK2,COLOR00FF00;}
逃顶1:IF((CROSS(DD,RSI5)),40,0),COLOR00FF00;
逃顶2:IF((CROSS(80,RSI5)),20,0),COLORYELLOW;
VAR1A:=INDEXV*INDEXC;
VAR2A:=EMA(VAR1A,5)/EMA(INDEXV,5);
VAR3A:=(INDEXC-VAR2A)/VAR2A*100;
VAR4A:=VAR3A<=-1.5 AND VAR3A>-100;
VAR5A:=SUM(VAR4A>0,18)/SUM(VAR4A=0,18);
VAR6A:=VAR5A<5 AND VAR5A>=0.25;
VAR7A:=(LOW+HIGH+CLOSE)/3;
VAR8A:=(VAR7A-MA(VAR7A,14))/(0.015*AVEDEV(VAR7A,14));
VAR9A:=EMA(VAR8A,3);
VARAA:=(HIGH+LOW+CLOSE)/3;
VARBA:=SUM(MAX(0,HIGH-REF(VARAA,1)),26)/SUM(MAX(0,REF(VARAA,1)-LOW),26)*100;
VARCA:=REF(MA(VARBA,3),2.2);
VARDA:=REF(MA(VARBA,13),6.2);
VAREA:=REF(MA(VARBA,89),36.6);
VARFA:=CROSS(VARCA,VARBA) AND VARBA>150;
{抄底:IF(VAR6A AND CROSS(VAR8A,VAR9A),60,0),COLORYELLOW; }
逃顶:IF(VARFA,60,0),COLORYELLOW;
V1A:=MA(C,3)=HHV(MA(C,3),7);
V2A:=MA(C,3)>MA(C,5);
V3A:=MA(V,5)>MA(V,10)*1.01;
V4A:=COUNT(MA(C,1)>REF(C,1),2)=2;
T:IF(V1A AND V2A AND V3A AND V4A,-20,0),COLORFFC7FF;
{VAR33:=PEAKBARS(3,15,1)<10;
VAR55:=IF(VAR33=1,2,0);
顶A:= IF(VAR55=2,2,0);
顶:IF(顶A>REF(顶A,1),50,0),COLORRED;含未来};

通达信逃顶组合指标公式

 

相关文章