在线检测未来函数

大智慧迷踪拳主图指标公式

来源:Internet,编辑:股旁网,2015-02-16

EMA13:=EMA(C,13);
EMA21:=EMA(C,21);
EMA34:=EMA(C,34);
{EMA60:MA(C,60),COLORFFCC66}
X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
STICKLINE(X2>X3 AND C>EMA13,LOW,HIGH,0.1,1),COLORRED;
STICKLINE(X2>X3 AND C>EMA13,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(X2<X3 AND C<EMA13,LOW,HIGH,0.1,1),COLORFFFF52;
STICKLINE(X2<X3 AND C<EMA13,CLOSE,OPEN,3,0),COLORFFFF52;
GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5));
GR2:=EMA13>EMA21 AND EMA21>EMA34 AND EMA13>REF(EMA13,1);
GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);
GR4:=H=HHV(H,GR1);
GR5:="MACD.MACD"(9,17,8)<REF("MACD.MACD"(9,17,8),1);
{GR6:=GR2 AND GR3 AND GR4;
GR7:=GR2 AND GR3 AND GR4 AND GR5;
GR8:=GR6 AND GR7;}
LC := REF(CLOSE,1);
RSI6:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
BIAS5:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
换手:=100*V/CAPITAL;
BB13:=ATAN(EMA13-REF(EMA13,1))*3.1416*10;
EMA8:=EMA(C,8);
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,6)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,L*0.99,'买点'),COLOR00FF00;
{STICKLINE(FF1,H,L,0.3,0),COLOR00FF00;
STICKLINE(FF1,O,C,3,1),LINETHICK2,COLOR00FF00;}
A2:=(C-REF(C,1))/REF(C,1)*100<1.02;
A3:=H>MA(C,5)*1.12;
AA:= A2 AND A3;
DRAWTEXT(AA,H*1.02,'卖点'),COLORFF0000;
{STICKLINE(AA,H,L,3,0),COLORFF0000;}
出货:1.36*MA(FORCAST(CLOSE,2),40),COLORGREEN,LINETHICK2;
高抛:1.175*MA(FORCAST(CLOSE,2),40),COLORRED,LINETHICK2;
低吸:0.812*MA(FORCAST(CLOSE,2),40),COLORF7E300,LINETHICK2;
A:=MA(CLOSE,32);
B:=MA(CLOSE,12);
DRAWTEXT(CROSS(B,A),B,'进场'),COLORGREEN,LINETHICK2;
DRAWTEXT(CROSS(A,B),A,'走人');
持钱:MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1)),COLORFF9900,LINETHICK2;
持币:MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1),COLORFF9900,LINETHICK2;
搏杀持股线:IF(MA(CLOSE,17)<持币,持币,MA(CLOSE,17)),COLORYELLOW,LINETHICK2;
N:=MA(CLOSE,89);
VAR11:=LLV(LOW,64)*1.15;
VAR12:=LLV(LOW,64)*1.29;
VAR13:=LLV(LOW,64)*1.49;
VAR14:=LLV(LOW,64)*1.61;
VAR15:=LLV(LOW,64)*1.8;
VAR16:=HHV(HIGH,64)*0.85;
VAR17:=HHV(HIGH,64)*0.71;
VAR18:=HHV(HIGH,64)*0.51;
VAR19:=HHV(HIGH,64)*0.39;
VAR20:=HHV(HIGH,64)*0.2;
目标①:=IF(CLOSE>N,VAR11,VAR16);
目标⑤:=IF(CLOSE>N,VAR15,VAR20);
VAR0:=(CLOSE*2+HIGH+LOW)/4*VOL;
VAR1:=SUM(VAR0,89)/SUM(VOL,89);
VAR2:=IF(COUNT(VAR0>0,2)>=2,MA(CLOSE,89)*(1+(MA(VAR0,89)/REF(MA(VAR0,89),1)-1)/21),MA(CLOSE,89));
VAR3:=IF(COUNT(ABS(CLOSE-VAR1)>21,8)>=1 AND COUNT(CLOSE/REF(CLOSE,1)<0.8,8)<1 AND COUNT(VAR0>0,2)>=2,10,0);
VAR4:=IF(CLOSE>=VAR1 AND COUNT(VAR0>0,2)>=2,VAR1*1.001,IF(VAR0<0.1 AND COUNT(VAR0>0,2)<1.5,MA(CLOSE,89),VAR1*0.999));
VAR5:=IF(VAR3>0,VAR2,VAR4);
VAR6:=MA(CLOSE,89);
搏杀生命线:IF(VAR5/REF(VAR5,1)>1.1 OR VAR5/REF(VAR5,1)<0.9,VAR6,VAR5),COLORF00FF0,LINETHICK2;
varl13:=("macd.diff#WEEK"(26,12,9));
varl14:=("macd.dea#WEEK"(26,12,9));
VL:=REF(LOW,1); VH:=REF(H,1);
Var1:=SMA(ABS(H-Vh),13,1)/SMA(MAX(H-Vh,0),13,1)*100;
Var2:=SMA(ABS(L-VL),13,1)/SMA(MAX(L-VL,0),13,1)*100;
Var3:=MA(Var1,13);
Var4:=MA(Var2,13);
Var5:=LLV(L,34);
Var6:=HHV(H,34);
Var7:=EMA(IF(H>=Var6,Var3,0),3);
Var8:=EMA(IF(L<=Var5,Var4,0),3);
var9:=(SMA(SMA((((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54))) * 100),7,1),5,1));
var10:=((SMA(((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54)) * 100),7,1)) * 16.18) - (var9* 10.9);
Var11:=FILTER(IF(var10<=var9 AND Var8>REF(Var8,1),Var8*8,0),55);
Var21:=LLV(LOW,60);
Var31:=HHV(HIGH,60);
Var41:=EMA((CLOSE-Var21)/(Var31-Var21)*100,13);
Var51:=EMA(0.667*REF(Var41,1)+0.333*Var41,21);
varl2:=FILTER(CROSS(Var51,Var41) AND Var41>84,13);
{K线
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),OPEN,CLOSE,7,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),OPEN,CLOSE,7,0),colorcyan;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF;}
DRAWTEXTABS(20,0,STKLABEL+' '+STKNAME+' '),ColorFFFF80;
持股线:=MA(C,26);
qjj:FILTER((CROSS(varl13,varl14) and varl14<0 and CROSS(c,持股线)),90),LINETHICK0;
DRAWTEXTREL(500,900,'买点:分批建仓. 进场:持股线上满仓. 逃跑:高抛或出货位清仓.'),Color989500;
var100:='所属板块:';
if inblock('电力')=1 then var100:=var100+' 电力';
if inblock('电脑')=1 then var100:=var100+' 电脑';
if inblock('电器')=1 then var100:=var100+' 电器';
if inblock('电子信息')=1 then var100:=var100+' 电子信息';
if inblock('房地产')=1 then var100:=var100+' 房地产';
if inblock('纺织服装')=1 then var100:=var100+' 纺织服装';
if inblock('钢铁')=1 then var100:=var100+' 钢铁';
if inblock('工程建筑')=1 then var100:=var100+' 工程建筑';
if inblock('供水供气')=1 then var100:=var100+' 供水供气';
if inblock('化工')=1 then var100:=var100+' 化工';
if inblock('化纤')=1 then var100:=var100+' 化纤';
if inblock('机械')=1 then var100:=var100+' 机械';
if inblock('建材')=1 then var100:=var100+' 建材';
if inblock('交通工具')=1 then var100:=var100+' 交通工具';
if inblock('交通设施')=1 then var100:=var100+' 交通设施';
if inblock('教育传媒')=1 then var100:=var100+' 教育传媒';
if inblock('金融')=1 then var100:=var100+' 金融';
if inblock('旅游酒店')=1 then var100:=var100+' 旅游酒店';
if inblock('煤炭石油')=1 then var100:=var100+' 煤炭石油';
if inblock('酿酒食品')=1 then var100:=var100+' 酿酒食品';
if inblock('农林牧渔')=1 then var100:=var100+' 农林牧渔';
if inblock('其他行业')=1 then var100:=var100+' 其他行业';
if inblock('汽车')=1 then var100:=var100+' 汽车';
if inblock('汽配')=1 then var100:=var100+' 汽配';
if inblock('商业连锁')=1 then var100:=var100+' 商业连锁';
if inblock('石化')=1 then var100:=var100+' 石化';
if inblock('通信')=1 then var100:=var100+' 通信';
if inblock('外贸')=1 then var100:=var100+' 外贸';
if inblock('医药')=1 then var100:=var100+' 医药';
if inblock('仪电仪表')=1 then var100:=var100+' 仪电仪表';
if inblock('有色金属')=1 then var100:=var100+' 有色金属';
if inblock('运输物流')=1 then var100:=var100+' 运输物流';
if inblock('造纸印刷')=1 then var100:=var100+' 造纸印刷';
if inblock('安徽')=1 then var100:=var100+' 安徽';
if inblock('北京')=1 then var100:=var100+' 北京';
if inblock('福建')=1 then var100:=var100+' 福建';
if inblock('甘肃')=1 then var100:=var100+' 甘肃';
if inblock('广东')=1 then var100:=var100+' 广东';
if inblock('广西')=1 then var100:=var100+' 广西';
if inblock('贵州')=1 then var100:=var100+' 贵州';
if inblock('海南')=1 then var100:=var100+' 海南';
if inblock('河北')=1 then var100:=var100+' 河北';
if inblock('河南')=1 then var100:=var100+' 河南';
if inblock('黑龙江')=1 then var100:=var100+' 黑龙江';
if inblock('湖北')=1 then var100:=var100+' 湖北';
if inblock('湖南')=1 then var100:=var100+' 湖南';
if inblock('吉林')=1 then var100:=var100+' 吉林';
if inblock('江苏')=1 then var100:=var100+' 江苏';
if inblock('江西')=1 then var100:=var100+' 江西';
if inblock('辽宁')=1 then var100:=var100+' 辽宁';
if inblock('内蒙古')=1 then var100:=var100+' 内蒙古';
if inblock('宁夏')=1 then var100:=var100+' 宁夏';
if inblock('青海')=1 then var100:=var100+' 青海';
if inblock('山东')=1 then var100:=var100+' 山东';
if inblock('山西')=1 then var100:=var100+' 山西';
if inblock('陕西')=1 then var100:=var100+' 陕西';
if inblock('上海')=1 then var100:=var100+' 上海';
if inblock('深圳')=1 then var100:=var100+' 深圳';
if inblock('四川')=1 then var100:=var100+' 四川';
if inblock('天津')=1 then var100:=var100+' 天津';
if inblock('***')=1 then var100:=var100+' ***';
if inblock('新疆')=1 then var100:=var100+' 新疆';
if inblock('云南')=1 then var100:=var100+' 云南';
if inblock('浙江')=1 then var100:=var100+' 浙江';
if inblock('重庆')=1 then var100:=var100+' 重庆';
if inblock('3G')=1 then var100:=var100+' 3G';
if inblock('H股')=1 then var100:=var100+' H股';
if inblock('QFII持股')=1 then var100:=var100+' QFII持股';
if inblock('ST')=1 then var100:=var100+' ST';
if inblock('奥运')=1 then var100:=var100+' 奥运';
if inblock('创投')=1 then var100:=var100+' 创投';
if inblock('次新股')=1 then var100:=var100+' 次新股';
if inblock('大盘')=1 then var100:=var100+' 大盘';
if inblock('股权改革')=1 then var100:=var100+' 股权改革';
if inblock('股权投资')=1 then var100:=var100+' 股权投资';
DD:=FINANCE2(35);
SS:=FINANCE2(37);
GG:=FINANCE2(3);
TH:=DYNAINFO(39);
DRAWTEXTABS(20,20,'总股本:'+NUMTOSTRn(DD,0)+'万股' +' 流通A股:'+NUMTOSTRn(SS,0)+'万股'+'市盈率:'+NUMTOSTRn(TH,2)+' 倍'+' 每股收益:'+NUMTOSTRn(GG,3)+' 元'),Color989500;
DRAWTEXTABS(20,40,var100+' '),Color989500;
DRAWTEXT(var11,C*0.98,'锁定'),ColorFFFF00;
DRAWICON(qjj,C*1.09,1);
DRAWTEXT(qjj,l*0.78,'霸占大牛股'),COLOR00FFFF;
DRAWTEXT(varl2,C*1.04,'逃跑'),Colorgreen;

大智慧迷踪拳主图指标公式

 

相关文章