在线检测未来函数

通达信潜龙升天指标公式

来源:Internet,编辑:股旁网,2015-02-16

A1:=EMA(CLOSE,7)-EMA(CLOSE,21);
B1:=EMA((0.668*REF(A1,1)+0.333*A1),1);
短多:IF(A1>=B1,A1,B1),LINETHICK3,COLORLIMAGENTA;
短空:B1,LINETHICK3,COLORGREEN;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),4,1)/SMA(ABS(CLOSE-LC),4,1)*100;
RSI4:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI5:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI6:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
RSI7:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
RSI8:=SMA(MAX(CLOSE-LC,0),9,1)/SMA(ABS(CLOSE-LC),9,1)*100;
RSI9:=SMA(MAX(CLOSE-LC,0),10,1)/SMA(ABS(CLOSE-LC),10,1)*100;
RSI10:=SMA(MAX(CLOSE-LC,0),11,1)/SMA(ABS(CLOSE-LC),11,1)*100;
RSI11:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI12:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
RSI13:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
RSI14:=SMA(MAX(CLOSE-LC,0),15,1)/SMA(ABS(CLOSE-LC),15,1)*100;
RSI15:=SMA(MAX(CLOSE-LC,0),16,1)/SMA(ABS(CLOSE-LC),16,1)*100;
RSI16:=SMA(MAX(CLOSE-LC,0),17,1)/SMA(ABS(CLOSE-LC),17,1)*100;
RSI17:=SMA(MAX(CLOSE-LC,0),18,1)/SMA(ABS(CLOSE-LC),18,1)*100;
RSI18:=SMA(MAX(CLOSE-LC,0),19,1)/SMA(ABS(CLOSE-LC),19,1)*100;
RSI19:=SMA(MAX(CLOSE-LC,0),20,1)/SMA(ABS(CLOSE-LC),20,1)*100;
RSI21:=SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*100;
RSI30:=SMA(MAX(CLOSE-LC,0),30,1)/SMA(ABS(CLOSE-LC),30,1)*100;
RSI40:=SMA(MAX(CLOSE-LC,0),40,1)/SMA(ABS(CLOSE-LC),40,1)*100;
RSI50:=SMA(MAX(CLOSE-LC,0),50,1)/SMA(ABS(CLOSE-LC),50,1)*100;
RSI60:=SMA(MAX(CLOSE-LC,0),60,1)/SMA(ABS(CLOSE-LC),60,1)*100;
RSI70:=SMA(MAX(CLOSE-LC,0),70,1)/SMA(ABS(CLOSE-LC),70,1)*100;
RSI80:=SMA(MAX(CLOSE-LC,0),80,1)/SMA(ABS(CLOSE-LC),80,1)*100;
RSI90:=SMA(MAX(CLOSE-LC,0),90,1)/SMA(ABS(CLOSE-LC),90,1)*100;
RSI100:=SMA(MAX(CLOSE-LC,0),100,1)/SMA(ABS(CLOSE-LC),100,1)*100;
RSI110:=SMA(MAX(CLOSE-LC,0),110,1)/SMA(ABS(CLOSE-LC),110,1)*100;
RSI120:=SMA(MAX(CLOSE-LC,0),120,1)/SMA(ABS(CLOSE-LC),120,1)*100;
短线RSI:=(RSI1+RSI2+RSI3+RSI4+RSI5)/5,COLORWHITE;
中线RSI:=(RSI6+ RSI7+ RSI8+ RSI9+ RSI10+ RSI11+ RSI12+ RSI13+ RSI14+ RSI15+ RSI16+ RSI17+ RSI18+ RSI19+ RSI21)/15,COLORYELLOW;
长线RSI:=(RSI21+RSI30+RSI40+RSI50+RSI60+RSI70+RSI80+RSI90+RSI100+RSI110+RSI120)/11;
A:=CROSS(短线RSI,中线RSI);
B:=CROSS(中线RSI,短线RSI);
A11:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
A21:=LLV(L,21);
A31:=LLV(L,30);
A41:=EMA(A11,5);
A51:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
基础:DIFF<-0.1 AND DIFF>DEA;
中线买入:CROSS(A11,A41) AND (A51-A41)>40 AND 基础;
STICKLINE(中线买入,0,2,4,0),,COLOR1010FF;

通达信潜龙升天指标公式

 

相关文章