在线检测未来函数

飞狐星星牧马主图指标公式

来源:Internet,编辑:股旁网,2015-02-17

平均价:=(HIGH+4*LOW+OPEN+CLOSE)/7;
A:=MA(EMA(平均价,3),1);
MMV:=MA(EMA(SLOPE(平均价,22)*20+平均价,55),1);
搏杀线:A,LINETHICK1,colorFFFF;
牧马生命线:MMV,LINETHICK2,colorFF00FF;
PARTLINE(A<=MMV,A),LINETHICK1,colorFF9900;
PARTLINE(A<=MMV,MMV),LINETHICK2,colorFF9900;
STICKLINE(A>MMV,A,MMV,0.1,0),colorFF00FF;
STICKLINE(A<=MMV,A,MMV,0.1,0),colorFF9900;
能量线:=DMA(平均价,VOL/(SMA(VOL,5,1)*5));
VAR3C:=EMA(能量线,2);
VAR4C:=REF(VAR3C,1);
STICKLINE(VAR3C>VAR4C,VAR3C,VAR4C,9,0),colorFFFF;
STICKLINE(VAR3C<VAR4C,VAR3C,VAR4C,9,0),colorFF00;
KS:=(CLOSE-EMA(CLOSE,13))/EMA(CLOSE,13)*(-100);
趋势线:=EMA(KS/10+EMA(CLOSE,10),3);
AA:=-100*(趋势线-CLOSE)/趋势线;
AC:=EMA(AA,5);
STICKLINE(CLOSE>=OPEN AND AA>=0 AND AA>=AC,OPEN,CLOSE,8,0),colorFF;
STICKLINE(OPEN>CLOSE AND AA>=0 AND AA>=AC,CLOSE,OPEN,8,0),colorFF;
STICKLINE(CLOSE>=OPEN AND AA>=0 AND AA>=AC,CLOSE,HIGH,0.5,0),colorFF;
STICKLINE(CLOSE>=OPEN AND AA>=0 AND AA>=AC,OPEN,LOW,0.5,0),colorFF;
STICKLINE(OPEN>CLOSE AND AA>=0 AND AA>=AC,CLOSE,LOW,0.5,0),colorFF;
STICKLINE(OPEN>CLOSE AND AA>=0 AND AA>=AC,OPEN,HIGH,0.5,0),colorFF;
STICKLINE(CLOSE>=OPEN AND AA>=0 AND AA<AC,OPEN,CLOSE,8,0),colorFF00FF;
STICKLINE(OPEN>CLOSE AND AA>=0 AND AA<AC,CLOSE,OPEN,8,0),colorFF00FF;
STICKLINE(CLOSE>=OPEN AND AA>=0 AND AA<AC,CLOSE,HIGH,0.5,0),colorFF00FF;
STICKLINE(CLOSE>=OPEN AND AA>=0 AND AA<AC,OPEN,LOW,0.5,0),colorFF00FF;
STICKLINE(OPEN>CLOSE AND AA>=0 AND AA<AC,CLOSE,LOW,0.5,0),colorFF00FF;
STICKLINE(OPEN>CLOSE AND AA>=0 AND AA<AC,OPEN,HIGH,0.5,0),colorFF00FF;
STICKLINE(CLOSE>=OPEN AND AA<0,OPEN,CLOSE,8,0),colorFF9900;
STICKLINE(OPEN>CLOSE AND AA<0,CLOSE,OPEN,8,0),colorFF9900;
STICKLINE(CLOSE>=OPEN AND AA<0,CLOSE,HIGH,0.5,0),colorFF9900;
STICKLINE(CLOSE>=OPEN AND AA<0,OPEN,LOW,0.5,0),colorFF9900;
STICKLINE(OPEN>CLOSE AND AA<0,CLOSE,LOW,0.5,0),colorFF9900;
STICKLINE(OPEN>CLOSE AND AA<0,OPEN,HIGH,0.5,0),colorFF9900;
X5:=REF(CLOSE,1);
X6:=(SMA(MAX(CLOSE-X5,0),7,1))/(SMA(ABS(CLOSE-X5),7,1))*100;
X7:=CROSS(79,X6);
X8:=FILTER(X7,4);
DRAWICON(X8,HIGH*1.03,5);
VAR1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
DRAWTEXT(CROSS(VAR3,VAR4) AND VAR3<40,LOW-0.03,'★买入'),colorFF;
DRAWTEXT(CROSS(VAR4,VAR3) AND VAR4>75,HIGH*1.03,'★减磅'),colorF0F000;
RSV1:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
RSV2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
支撑:IF(CROSS(J1,J2),LOW,REF(LOW,BARSLAST(CROSS(J1,J2)))),POINTDOT,LINETHICK2,colorFFFF;
压力:IF(CROSS(J2,J1),HIGH,REF(HIGH,BARSLAST(CROSS(J2,J1)))),POINTDOT,LINETHICK2,colorFF00;
DRAWTEXT(支撑=压力 AND REF(支撑,1)<>REF(压力,1),LOW*0.97,'优'),ALIGN1,color3300FF;
VCF1:=LLV(LOW,5);
VCF2:=HHV(HIGH,5);
VCF3:=EMA((CLOSE-VCF1)/(VCF2-VCF1)*100,4);
VCF4:=EMA(0.667*REF(VCF3,1)+0.333*VCF3,2);
VCF5:=(HIGH+LOW)/2;
VCF6:=DMA(VCF5,VOL/SUM(VOL,5));
VCF7:=DMA(VCF5,VOL/SUM(VOL,13));
VCF8:=DMA(VCF5,VOL/SUM(VOL,34));
VCF9:=DMA(VCF5,VOL/SUM(VOL,75));
VCFA:=EMA(WINNER(0.9*CLOSE),5);
VCFB:=1-EMA(WINNER(1.2*CLOSE),5);
VCFC:=EMA(WINNER(CLOSE),5);
VCFD:=100*(CLOSE-VCF6)/VCF6;
VCFE:=100*(CLOSE-VCF7)/VCF7;
VCFF:=100*(MIN(CLOSE,OPEN)-VCF8)/VCF8;
VCF10:=BARSLAST(VCF8>VCF9 AND REF(VCF8,1)<=REF(VCF9,1));
VCF11:=((COUNT(WINNER(CLOSE)<0.11 AND EMA(WINNER(CLOSE),5)<0.15,2))>0 OR 1-WINNER(1.2*CLOSE)>=0.8 AND WINNER(CLOSE)<0.05) AND (COUNT(VCFE<-16,2))>0 AND (COUNT(VCFF<-20,2))>0;
VCF12:=(COUNT(VCFD<-10,2))>0 AND (COUNT(VCFE<-15,2))>0 AND (COUNT(VCFF<-15,2))>0 AND (COUNT(VCFA>0.8,VCF10))=0;
VCF13:=(COUNT(VCF11 OR VCF12,2))>0 AND VCF3>REF(VCF3,1) AND (1-WINNER(1.15*CLOSE))*100>80;
黑马出击:=IF(VCF13 AND COUNT(VCF13,3)<=1,0.5,0);
DRAWTEXT(黑马出击>0,LOW-0.09,'★黑马'),colorFF;

飞狐星星牧马主图指标公式

 

相关文章