在线检测未来函数

通达信看透主力主图指标公式

来源:Internet,编辑:股旁网,2015-02-17

{使用说明:如果突破E1,并且回踩不破,将有一波主升行情。 如果突破C1,并且回踩不破,一波主升行情已经展开。}

N:=21;
N1:=10;
{量能平台}
TTJ:=BARSLAST((VOL=HHV(VOL,N)));
K0:=TTJ=0;
K1:=SUMBARS(K0,1);
K2:=SUMBARS(K0,2);
K3:=SUMBARS(K0,3);
K4:=SUMBARS(K0,4);
K5:=SUMBARS(K0,5);
K6:=SUMBARS(K0,6);
K7:=SUMBARS(K0,7);
K8:=SUMBARS(K0,8);
K9:=SUMBARS(K0,9);
K10:=SUMBARS(K0,10);
A1:(K1<=30,REF(C,K1-1)*1.002),COLOREA91B5,NODRAW,LINETHICK1;
AA:STICKLINE(K1<=30,REF(C,K1-1)*1.002,REF(C,K1-1),10,0),COLOREA91B5;
B1:(K2<=30,REF(C,K2-1)*1.002),COLORWHITE,NODRAW,LINETHICK1;
BA:STICKLINE(K2<=30,REF(C,K2-1)*1.002,REF(C,K2-1),10,0),COLORWHITE;
{日K线}
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
{粉}
STICKLINE(CLOSE< REF(CLOSE,1),HIGH,LOW,0,0 ),COLOR00DD00;
STICKLINE(CLOSE< REF(CLOSE,1),OPEN,CLOSE,3.2,0 ),COLORFF33FF;
STICKLINE(CLOSE< REF(CLOSE,1),OPEN,CLOSE,2.7,0 ),COLORFF55FF;
STICKLINE(CLOSE< REF(CLOSE,1),OPEN,CLOSE,2.1,0 ),COLORFF77FF;
STICKLINE(CLOSE< REF(CLOSE,1),OPEN,CLOSE,1.5,0 ),COLORFF99FF;
STICKLINE(CLOSE< REF(CLOSE,1),OPEN,CLOSE,0.9,0 ),COLORFFBBFF;
STICKLINE(CLOSE< REF(CLOSE,1),OPEN,CLOSE,0.3,0 ),COLORFFDDFF;
{金}
STICKLINE(CLOSE> REF(CLOSE,1),HIGH,LOW,0,0 ),COLOR000DDD;
STICKLINE(CLOSE> REF(CLOSE,1),OPEN,CLOSE,3.2,0 ),COLOR003333;
STICKLINE(CLOSE> REF(CLOSE,1),OPEN,CLOSE,2.7,0 ),COLOR005555;
STICKLINE(CLOSE> REF(CLOSE,1),OPEN,CLOSE,2.1,0 ),COLOR007777;
STICKLINE(CLOSE> REF(CLOSE,1),OPEN,CLOSE,1.5,0 ),COLOR009999;
STICKLINE(CLOSE> REF(CLOSE,1),OPEN,CLOSE,0.9,0 ),COLOR00BBBB;
STICKLINE(CLOSE> REF(CLOSE,1),OPEN,CLOSE,0.3,0 ),COLOR00DDDD;
{红}
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3.2,0),COLOR000555;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),2.7,0),COLOR000777;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),2.1,0),COLOR000999;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),1.5,0),COLOR000BBB;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),0.9,0),COLOR000DDD;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),0.3,0),COLOR000FFF;
{绿}
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3.2,0),COLOR005500;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),2.7,0),COLOR007700;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),2.1,0),COLOR009900;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),1.5,0),COLOR00BB00;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),0.9,0),COLOR00DD00;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),0.3,0),COLOR00FF00;
{紫}
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLOR550055;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2.7,0),COLOR770077;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2.1,0),COLOR990099;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORBB00BB;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),0.9,0),COLORDD00DD;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),0.3,0),COLORFF00FF;
{蓝}
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORFF3300;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.7,0),COLORFF5500;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.1,0),COLORFF7700;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORFF9900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.9,0),COLORFFBB00;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.3,0),COLORFFDD00;
DRAWICON(FILTER(VAR19=1,5),L*0.9998,1);
DRAWICON(FILTER(VAR1A=1,5),H*1.0003,2);
{前高 价格和虚线}
AA1:=REF(H,N1)=HHV(H,2*N1+1);
QY:=BACKSET(AA1,N1+1);
CC:=FILTER(QY,N1) AND H=HHV(H,N1+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
GDCS13:=CONST(REF(HIGH,GDCS1-1));
XG1:=BACKSET(ISLASTBAR,GDCS1);
C1:(XG1,GDCS13,GDCS13),COLORRED,NODRAW,LINETHICK1;
STICKLINE(XG1,GDCS13,GDCS13,1,0),COLORRED;
{黄色虚线}
AAA:=(3*C+H+L+O)/6;
VAR21:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR21;
立桩量:=FILTER(TJ1,5);
STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),COLORYELLOW;
D1:REF(LOW,BARSLAST(立桩量)),COLORYELLOW,NODRAW,LINETHICK1;
{STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),COLORCYAN;}
{K线 绿色虚线}
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
三日价涨A:=C>=REF(C,1);
三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
TIM:=IF(DATE<1140214,1,0);
四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;
四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;
前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;
倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
黄金柱:=倍量黄金柱 OR 高量黄金柱;
BACKSET101:=BACKSET(黄金柱,4);
FILTER101:=FILTER(BACKSET101,3);
牛熊线:=SUMBARS(FILTER101,1);
STICKLINE(牛熊线,REF(L,牛熊线-2),REF(L,牛熊线-2),0.0001,0),COLORGREEN;
{DRAWTEXT(ISLASTBAR,REF(L,牛熊线-2)*0.99,CON2STR(REF(L,牛熊线-2),2)),COLORGREEN,LINETHICK1;}
E1:REF(L,牛熊线-2),COLORGREEN,NODRAW,LINETHICK1;
{趋势}
F1:=(3*CLOSE+OPEN+LOW+HIGH)/6;
趋:(20*F1+19*REF(F1,1)+18*REF(F1,2)+17*REF(F1,3 )+16*REF(F1,4)+15*REF(F1,5)+14*REF(F1,6)
+13*REF(F1,7)+12*REF(F1,8)+11*REF(F1,9)+10*REF(F1,10 )+9*REF(F1,11)+8*REF(F1,12)
+7*REF(F1,13)+6*REF(F1,14)+5*REF(F1,15)+4*REF(F1,16) +3*REF(F1,17)+2*REF(F1,18)+
REF(F1,20))/210,COLORYELLOW;
势:MA(趋,5),COLORRED;

通达信看透主力主图指标公式

 

相关文章