在线检测未来函数

通达信多空抄底指标公式

来源:Internet,编辑:股旁网,2015-02-24

VAR22:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR32:=SMA(SMA(VAR22,3,1),3,1)/28.57;
VAR42:=EMA(VAR32,5);
VAR52:=3*VAR32-2*VAR42;
AA:=CROSS(VAR52,VAR32) AND VAR32<2.1 AND C>O;
VAR62:=(2*CLOSE+HIGH+LOW)/4;
VAR72:=LLV(LOW,13);
VAR82:=HHV(HIGH,13);
VAR92:=EMA((VAR62-VAR72)/(VAR82-VAR72)*100,13);
VARA2:=EMA(0.667*REF(VAR92,1)+0.333*VAR92,2);
多:VAR92,COLORRED,POINTDOT;
空:EMA(0.382*REF(VAR92,2)+0.618*VAR92,12),COLORGREEN;
STICKLINE(VAR92>VARA2,VAR92,VARA2,6,0),COLORRED;
STICKLINE(VAR92<=VARA2,VAR92,VARA2,6,0),COLORFFCC66;
STICKLINE(AA,0,30,40,1),COLORYELLOW;
STICKLINE(AA,16,29,38,0),COLORRED;
STICKLINE(AA,1,14,38,0),COLORRED;
STICKLINE(AA,15,15,40,1),COLORYELLOW;
STICKLINE(AA,30,50,10,0),COLORYELLOW;
STICKLINE(AA,53,55,10,1),COLORRED;
STICKLINE(AA,57,59,10,1),COLORRED;
STICKLINE(AA,61,63,10,1),COLORRED;
STICKLINE(AA,65,67,10,1),COLORRED;
STICKLINE(AA,69,75,12,0),COLORFFCCCC;
DRAWTEXT(AA,100,'底'),COLORYELLOW;
VAR1:="DMI.PDI"(12,6);
VAR2:="DMI.MDI"(12,6);
VAR3:=VAR1>65 AND VAR1>REF(VAR1,1);
VAR4:=LLV(VAR1,0);
VAR5:=BARSLAST(VAR4=VAR1);
VAR6:=(0-REF(VAR2,4))/(VAR4-REF(VAR2,VAR5))>2;
VAR7:=VAR1>REF(VAR1,1);
VAR8:=VOL>2*MA(VOL,30);
VAR9:="DMI.ADX"(12,6);
VARA:="DMI.ADXR"(12,6);
VARB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;
VARC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);
VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));
VARF:=TROUGHBARS(3,15,1)<4;
VAR10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);
VAR11:=IF(VARF=1,50,0);
VAR12:=CROSS(VAR2,VAR1) AND CROSS(VARA,VAR9);
VAR13:=CROSS(VAR2,VAR1) AND CROSS(VAR9,VARA);
VAR14:=VARB AND VARC AND VARD AND VAR10 AND VAR6 AND VAR7 AND VAR8*50;
VAR15:=BARSLAST(CROSS(VAR2,VAR1)=1);
VAR16:=BARSLAST(CROSS(VAR1,VAR2)=1);
VAR17:=HHV(VAR1,VAR16);
VAR18:=BARSLAST(VAR1=VAR17);
多空:EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;
0,COLORRED;
STICKLINE(FILTER(VARF=1,5) AND 多空<-10,50,0,15,0);
STICKLINE(FILTER(VARF=1,5),50,0,8,0),COLORWHITE;
VAR19:=VAR3 OR VAR12 OR VAR13*100;
VAR1A:=VAR13*100;
DRAWICON(FILTER(VARF=1,3),50,1);
DRAWTEXT(FILTER(VARF=1,3),35,'抄'),COLORRED;
DRAWTEXT(FILTER(VARF=1,3),22,'底'),COLORRED;
STICKLINE(多空<-10,0,多空,1,0),COLORYELLOW;
STICKLINE(多空>10,0,多空,1,0),COLORYELLOW;

通达信多空抄底指标公式

 

相关文章