在线检测未来函数

通达信明月弯刀主图指标公式

来源:Internet,编辑:股旁网,2015-02-25

AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)
+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,COLORRED,LINETHICK2;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
DRAWBAND(VAR1,RGB(255,250,250),VAR6,RGB(250,250,0));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
DRAWTEXT(CROSS(C,VAR6) AND C/REF(C,1)>1.03,L*0.96,'弯刀'),COLORYELLOW;
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
大宗进:(超B)+(大B),COLOR0000FF,NODRAW;
大宗出:(超S)+(大S),COLOR0080FF,NODRAW;
非大宗进:(中B)+(小B),COLOR8000FF,NODRAW;
非大宗出:(中S)+(小S),COLOR00FF00,NODRAW;
大宗进限制:=IF((超B+大B)=0,0,大宗进);
大宗出限制:=IF((超S+大S)=0,0,大宗出);
非大宗进限制:=IF(中B+小B=0,0,非大宗进);
非大宗出限制:=IF(中S+小S=0,0,非大宗出);
主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;
散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;
净流入:(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORFFFFFF,NODRAW;
CM1:=INTPART(PPART(1)*100);
CM2:=INTPART(PPART(2)*100);
CM3:=INTPART(PPART(3)*100);
CM4:=INTPART(PPART(4)*100);
CM5:=INTPART(PPART(5)*100);
CM6:=INTPART(PPART(6)*100);
CM7:=INTPART(PPART(7)*100);
CM8:=INTPART(PPART(8)*100);
CM9:=INTPART(PPART(9)*100);
CM10:=INTPART(PPART(10)*100);
CM11:=INTPART(PPART(11)*100);
CM12:=INTPART(PPART(12)*100);
CM13:=INTPART(PPART(13)*100);
CM14:=INTPART(PPART(14)*100);
CM15:=INTPART(PPART(15)*100);
CM16:=INTPART(PPART(16)*100);
CM17:=INTPART(PPART(17)*100);
CM18:=INTPART(PPART(18)*100);
CM19:=INTPART(PPART(19)*100);
CM20:=INTPART(PPART(20)*100);
CM21:=INTPART(PPART(21)*100);
CM22:=INTPART(PPART(22)*100);
CM23:=INTPART(PPART(23)*100);
CM24:=INTPART(PPART(24)*100);
CM25:=INTPART(PPART(25)*100);
CM26:=INTPART(PPART(26)*100);
CM27:=INTPART(PPART(27)*100);
CM28:=INTPART(PPART(28)*100);
CM29:=INTPART(PPART(29)*100);
CM30:=INTPART(PPART(30)*100);
CM31:=INTPART(PPART(31)*100);
CM32:=INTPART(PPART(32)*100);
CM33:=INTPART(PPART(33)*100);
CM34:=INTPART(PPART(34)*100);
CM35:=INTPART(PPART(35)*100);
CM36:=INTPART(PPART(36)*100);
CM37:=INTPART(PPART(37)*100);
CM38:=INTPART(PPART(38)*100);
CM39:=INTPART(PPART(39)*100);
CM40:=INTPART(PPART(30)*100);
CM41:=INTPART(PPART(41)*100);
CM42:=INTPART(PPART(42)*100);
CM43:=INTPART(PPART(43)*100);
CM44:=INTPART(PPART(44)*100);
CM45:=INTPART(PPART(45)*100);
CM46:=INTPART(PPART(46)*100);
CM47:=INTPART(PPART(47)*100);
CM48:=INTPART(PPART(48)*100);
CM49:=INTPART(PPART(49)*100);
CM50:=INTPART(PPART(50)*100);
CM51:=INTPART(PPART(51)*100);
CM52:=INTPART(PPART(52)*100);
CM53:=INTPART(PPART(53)*100);
CM54:=INTPART(PPART(54)*100);
CM55:=INTPART(PPART(55)*100);
CM56:=INTPART(PPART(56)*100);
CM57:=INTPART(PPART(57)*100);
CM58:=INTPART(PPART(58)*100);
CM59:=INTPART(PPART(59)*100);
CM60:=INTPART(PPART(60)*100);
IF(CURRBARSCOUNT<INTPART(CM2/2),CONST(COSTEX(REF(C,1),REF(C,2))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM3/2),CONST(COSTEX(REF(C,2),REF(C,3))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM4/2),CONST(COSTEX(REF(C,3),REF(C,4))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM5/2),CONST(COSTEX(REF(C,4),REF(C,5))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM6/2),CONST(COSTEX(REF(C,5),REF(C,6))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM7/2),CONST(COSTEX(REF(C,6),REF(C,7))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM8/2),CONST(COSTEX(REF(C,8),REF(C,9))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM9/2),CONST(COSTEX(REF(C,9),REF(C,10))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM10/2),CONST(COSTEX(REF(C,10),REF(C,11))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM11/2),CONST(COSTEX(REF(C,11),REF(C,12))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM12/2),CONST(COSTEX(REF(C,12),REF(C,13))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM13/2),CONST(COSTEX(REF(C,13),REF(C,14))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM14/2),CONST(COSTEX(REF(C,14),REF(C,15))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM15/2),CONST(COSTEX(REF(C,15),REF(C,16))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM16/2),CONST(COSTEX(REF(C,16),REF(C,17))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM17/2),CONST(COSTEX(REF(C,17),REF(C,18))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM18/2),CONST(COSTEX(REF(C,18),REF(C,19))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM19/2),CONST(COSTEX(REF(C,19),REF(C,20))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM20/2),CONST(COSTEX(REF(C,20),REF(C,21))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM21/2),CONST(COSTEX(REF(C,21),REF(C,22))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM22/2),CONST(COSTEX(REF(C,22),REF(C,23))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM23/2),CONST(COSTEX(REF(C,23),REF(C,24))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM24/2),CONST(COSTEX(REF(C,24),REF(C,25))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM25/2),CONST(COSTEX(REF(C,25),REF(C,26))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM26/2),CONST(COSTEX(REF(C,26),REF(C,27))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM27/2),CONST(COSTEX(REF(C,27),REF(C,28))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM28/2),CONST(COSTEX(REF(C,28),REF(C,29))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM29/2),CONST(COSTEX(REF(C,29),REF(C,30))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM30/2),CONST(COSTEX(REF(C,30),REF(C,31))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM31/2),CONST(COSTEX(REF(C,31),REF(C,32))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM32/2),CONST(COSTEX(REF(C,32),REF(C,33))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM33/2),CONST(COSTEX(REF(C,33),REF(C,34))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM34/2),CONST(COSTEX(REF(C,34),REF(C,35))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM35/2),CONST(COSTEX(REF(C,35),REF(C,36))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM36/2),CONST(COSTEX(REF(C,36),REF(C,37))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM37/2),CONST(COSTEX(REF(C,37),REF(C,38))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM38/2),CONST(COSTEX(REF(C,38),REF(C,39))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM39/2),CONST(COSTEX(REF(C,39),REF(C,40))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM40/2),CONST(COSTEX(REF(C,40),REF(C,41))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM41/2),CONST(COSTEX(REF(C,41),REF(C,42))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM42/2),CONST(COSTEX(REF(C,42),REF(C,43))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM43/2),CONST(COSTEX(REF(C,43),REF(C,44))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM44/2),CONST(COSTEX(REF(C,44),REF(C,45))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM45/2),CONST(COSTEX(REF(C,45),REF(C,46))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM46/2),CONST(COSTEX(REF(C,46),REF(C,47))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM47/2),CONST(COSTEX(REF(C,47),REF(C,48))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM48/2),CONST(COSTEX(REF(C,48),REF(C,49))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM49/2),CONST(COSTEX(REF(C,49),REF(C,50))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM50/2),CONST(COSTEX(REF(C,50),REF(C,51))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM51/2),CONST(COSTEX(REF(C,51),REF(C,52))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM52/2),CONST(COSTEX(REF(C,52),REF(C,53))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM53/2),CONST(COSTEX(REF(C,53),REF(C,54))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM54/2),CONST(COSTEX(REF(C,54),REF(C,55))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM55/2),CONST(COSTEX(REF(C,55),REF(C,56))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM56/2),CONST(COSTEX(REF(C,56),REF(C,57))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM57/2),CONST(COSTEX(REF(C,57),REF(C,58))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM58/2),CONST(COSTEX(REF(C,58),REF(C,59))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM59/2),CONST(COSTEX(REF(C,59),REF(C,60))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM60/2),CONST(COSTEX(REF(C,60),REF(C,61))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM1/2),CONST(C),DRAWNULL),COLORRED;
DRAWKLINE(H,O,L,C);
AA:=MONTH-REF(MONTH,1);
DRAWTEXT(AA>1 OR (AA<0 AND AA>-11),L*0.9,'重大事项停牌');
K8:=BARSLAST(EMA(C,5)>=EMA(C,20));
K9:=BARSLAST(EMA(C,5)<=EMA(C,20));
K110:=IF(EMA(C,5)>=EMA(C,20),(EMA(C,5)+EMA(C,20))/2,DRAWNULL);
K115:=IF(EMA(C,5)>=EMA(C,20),EMA(C,5),DRAWNULL);
K120:=IF(EMA(C,5)>=EMA(C,20),EMA(C,20),DRAWNULL);
线5:IF(CURRBARSCOUNT<CONST(K9+2),K115,DRAWNULL)COLORYELLOW;
线10:IF(CURRBARSCOUNT<CONST(K9+2),K110,DRAWNULL),COLORYELLOW;
线20:IF(CURRBARSCOUNT<CONST(K9+2),K120,DRAWNULL),COLORYELLOW;

通达信明月弯刀主图指标公式

 

相关文章