在线检测未来函数

通达信霸王主图指标公式

来源:Internet,编辑:股旁网,2015-02-27

上升线:ema(c,3),colorred,linethick2;
下降线:ema(c,5),color00ff00,linethick2;
中间线:ema(下降线,5),colorwhite,linethick2;
Var1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
Var2:=REF(Var1,1);
Var3:=SMA((close-Var2),6,1)/SMA(ABS(close-Var2),6,1)*100;
Var4:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
Var5:=EMA(0.667*REF(Var4,1)+0.333*Var4,5);
Var6:=IF(VOL>=1.3*MA(VOL,5) AND COUNT(Var4>=Var5 and Var4<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0);
Var7:=SMA(MAX(CLOSE-ref(c,1),0),6,1)/SMA(ABS(CLOSE-ref(c,1)),6,1)*100;
Var8:=SMA(MAX(Var1-Var2,0),10,1)/SMA(ABS(Var1-Var2),10,1)*100;
Var9:=IF(COUNT(Var8<20,5)>=1 AND COUNT(Var1=LLV(Var1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWICON(FILTER(ref(Var3,1)>81 and Var3<80 OR CROSS(82,Var7),5),high,2);
DRAWTEXT(FILTER(ref(Var3,1)>81 and Var3<80 OR CROSS(82,Var7),5),high,'快卖'),coloryellow;
DRAWTEXT(FILTER(Var9 OR Var6,5),low,'波霸说:注意买入'),colorred;
DRAWICON(FILTER(CROSS(上升线,下降线)and 中间线>=ref(中间线,1)and Var3<50,5),上升线,1);

通达信霸王主图指标公式

 

相关文章