在线检测未来函数

通达信红带飘香指标公式

来源:Internet,编辑:股旁网,2015-03-02

L21:=STD(C,60)/C*10;
L22:=100*L21*((CLOSE-LLV(C,60))/(HHV(C,60)-LLV(C,60))-0.5);
L23:=SMA(L22,9,1);
L24:=SMA(L23,3,1);
长线:=3*L23-2*SMA(L24,3,1),NODRAW;
长线系数:(MA(长线,3)-MA(长线,5))*(100-长线)/100*1,NODRAW;
DRAWBAND(L23,RGB(100,0,0),L24,RGB(0,100,0));
C21:=CROSS(L23,L24);
C22:=CROSS(L24,L23);
L11:=STD(C,20)/C*10;
L12:=100*L11*((CLOSE-LLV(C,20))/(HHV(C,20)-LLV(C,20))-0.5);
L13:=SMA(L12,9,1);
L14:=SMA(L13,3,1);
中线:=3*L13-2*SMA(L14,3,1),NODRAW;
中线系数:(MA(中线,3)-MA(中线,5))*(100-中线)/100*3,NODRAW;
DRAWBAND(L13,RGB(255,0,0),L14,RGB(0,255,0));
C11:=CROSS(L13,L14);
C12:=CROSS(L14,L13);
DRAWICON(COUNT(C11,5)=1 AND COUNT(C21,5)=1,0,1);
DRAWICON(COUNT(C12,5)=1 AND COUNT(C22,5)=1,0,2);
DRAWICON(LONGCROSS(L23,L24,30) AND L23<-5,L23,25);
DRAWICON(C22 AND L23>20,L23,27);
DRAWICON(C21 AND L23>20,L23,25);
L31:=STD(C,5)/C*10;
L32:=100*L31*((CLOSE-LLV(C,5))/(HHV(C,5)-LLV(C,5))-0.5);
L33:=SMA(L32,9,1);
L34:=SMA(L33,3,1);
短线:=3*L33-2*SMA(L34,3,1),NODRAW;
短线系数:(MA(短线,3)-MA(短线,5))*(100-短线)/100*5,NODRAW;
DRAWBAND(L33,RGB(255,200,0),L34,RGB(0,2,250));
波段系数:(长线系数+中线系数+短线系数)/2,COLORWHITE,NODRAW;
A0:=(CONST(HHV(L23,200))-CONST(LLV(L23,200)))/100;
A1:=CONST(LLV(L23,200));
STICKLINE(BETWEEN(CURRBARSCOUNT,150,50),A1+0*A0,A1+10*A0,2,1),COLORLIMAGENTA;
STICKLINE(CONST(ROUND(波段系数))>0 AND BETWEEN(CURRBARSCOUNT,100,
100-CONST(ROUND(波段系数))),A1+0*A0,A1+10*A0,5,0),COLORRED;
STICKLINE(CONST(ROUND(波段系数))<0 AND BETWEEN(CURRBARSCOUNT,100,
100-CONST(ROUND(波段系数))),A1+0*A0,A1+10*A0,5,0),COLORGREEN;
STICKLINE(BETWEEN(CURRBARSCOUNT,99.9,100.1),A1+0*A0,A1+10*A0,5,0),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=160,A1+5*A0,CONST(波段系数)/50*100),COLORMAGENTA;

通达信红带飘香指标公式

 

相关文章