在线检测未来函数

通达信轻松买卖指标公式

来源:Internet,编辑:股旁网,2015-03-04

TYP:=(HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINESTICK,COLORRED,LINETHICK2;
STICKLINE(CCI,30,1,2.3,1),COLORBROWN ;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
K1:=(SMA(RSV,3,1)-50)*4;
VAR1:=REF(J,1)<0 AND J>0;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,13);
VAR6:=HHV(VAR4,13);
VAR7:=IF(MA(CLOSE,34),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,100,VAR8);
VAR10:=VAR9>0.1;
VAR11:=K1<=-100;
B:=CROSS(CCI,-200) AND CCI>REF(CCI,1);
S:=CROSS(200,CCI) AND CCI<REF(CCI,1) AND C<=REF(C,1) AND H<=REF(H,1);
XG:=FILTER(VAR1 AND VAR10 AND VAR11,40) OR B;
STICKLINE(XG,0,10,3,0),COLORFF00FF;
STICKLINE(XG,10,20,3,0),COLOR00FFFF;
STICKLINE(XG,20,30,3,0),COLORRED;
DRAWICON(XG,32,34);
DRAWICON(XG,14,30);
STICKLINE(S,0,10,3,0),COLORBLUE;
STICKLINE(S,10,20,3,0),COLOR00FFFF;
STICKLINE(S,20,30,3,0),COLORGREEN;
DRAWICON(S,32,35);
DRAWICON(S,14,29);

通达信轻松买卖指标公式

 

相关文章