在线检测未来函数

通达信一线通吃指标公式

来源:Internet,编辑:股旁网,2015-03-05

N:=6;
P:=1;
N1:=99;
M:=9;
N3:=30;
SHORT:=14;
LONG:=14;
MID:=60;
VAR0:DRAWGBK(C>=0,RGB(38,18,0),RGB(0,38,18),0,2,0);
VAR1:=19000000+DATE;
VAR3:=100*VAR2;
VAR4:=PERIOD=5;
VAR5:=(O+H+L+(C*2))/5;
VAR6:=EMA(VAR5,21);
VAR7:=IF(VAR1<=VAR3 AND VAR4,STD(VAR5,21),DRAWNULL);
VAR8:=((((VAR5-VAR6)/VAR7)*100)+200)/4;
VAR9:=(EMA(VAR8,5)-25)*1.56;
VARA:=EMA(VAR9,2)*1.22;
VARB:=EMA(VARA,2);
VARC:=IF(VAR1<=VAR3 AND VAR4,1.618*((3*VARA)-(2*VARB)),DRAWNULL);
VARD:=HHV(VARC,8);
VARE:=LLV(VARC,8);
VARF:=EXPMA(IF(VAR1<=VAR3 AND VAR4,SMA(VARD,3,1),DRAWNULL),2);
VAR10:=EXPMA(IF(VAR1<=VAR3 AND VAR4,SMA(VARE,3,1),DRAWNULL),2);
VAR11:=IF(VAR1<=VAR3 AND VAR4,(SMA(VARD,3,1)+SMA(VARE,3,1))/2,DRAWNULL);
VAR12:=IF(BACKSET(VAR11>=REF(VAR11,1),2),VARF,DRAWNULL);
VAR13:=IF(BACKSET(VAR11<=REF(VAR11,1),2),VARF,DRAWNULL);
VAR14:DRAWBAND(VARF,RGB(68,68,68),VAR10,RGB(0,0,0));
VAR15:DRAWBAND(VAR12,RGB(68,38,18),VAR10,RGB(0,0,0));
VAR16:DRAWBAND(VAR13,RGB(18,68,38),VAR10,RGB(0,0,0));
0,COLOR636363,POINTDOT;
VARC,COLOR666666;
IF(BACKSET(VARC<=REF(VARC,1) AND VAR1<=VAR3,2) AND NOT(C=O AND H=L) AND VAR4,VARC,DRAWNULL),COLORAA9933,LINETHICK2;
IF(VAR1<=VAR3 AND VAR4 AND BACKSET(VARC>=REF(VARC,1),2) AND NOT(C=O AND H=L),VARC,DRAWNULL),COLOR0099AA,LINETHICK2;
VAR1B:STICKLINE(VAR1<=VAR3 AND VAR4 AND IF(H=L AND C=O,CROSS(VARC,VAR10),VARC<VAR10 AND VARC<=REF(VARC,1) AND VARC<REFX(VARC,1)),LLV(VARC,3),VAR10,0,0),COLOR330099;
VAR1C:STICKLINE(VAR1<=VAR3 AND VAR4 AND IF(H=L AND C=O,CROSS(VARF,VARC),VARC>VARF AND VARC>=REF(VARC,1) AND VARC>REFX(VARC,1)),HHV(VARC,3),VARF,0,0),COLOR008800;
VAR1D:=260;
VAR1E:=680;
VAR1F:=7763;
QX1:DRAWNUMBER_FIX(VAR1>=VAR3,0.89,0.6,1,VAR1D),COLOR00FFFF;
QX2:DRAWNUMBER_FIX(VAR1>=VAR3,0.93,0.6,1,VAR1E),COLOR00FFFF;
QX3:DRAWNUMBER_FIX(VAR1>=VAR3,0.98,0.6,1,VAR1F),COLOR00FFFF;
IF(VAR1>VAR3,VAR2,DRAWNULL),COLORFFFFFF;

通达信一线通吃指标公式

 

相关文章