在线检测未来函数

通达信战略家主图指标公式

来源:Internet,编辑:股旁网,2015-03-08

N:=IF(BARSCOUNT(C)>=10,10,BARSCOUNT(C));
STICKLINE(C>=MA(C,N),MA(C,N),REF(MA(C,N),1),5,0),COLORYELLOW;
STICKLINE(C<MA(C,N),MA(C,N),REF(MA(C,N),1),5,0),COLORBLUE;
DRAWTEXT(C>=MA(C,N) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,N),' 黄色持股 (短线)'),COLORYELLOW;
DRAWTEXT(C<MA(C,N) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,N),' 蓝色持币 (短线)'),COLORFF9933;
M:=IF(BARSCOUNT(C)>=45,45,BARSCOUNT(C));
STICKLINE(C>=MA(C,M),MA(C,M),REF(MA(C,M),1),5,0),COLORYELLOW;
STICKLINE(C<MA(C,M),MA(C,M),REF(MA(C,M),1),5,0),COLORBLUE;
DRAWTEXT(C>=MA(C,M) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,M),' 黄色持股 (中线)'),COLORYELLOW;
DRAWTEXT(C<MA(C,M) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,M),' 蓝色持币 (中线)'),COLORFF9933;
DRAWKLINE(H,O,L,C);
MA5:MA(C,5),COLORMAGENTA;
MA10:MA(C,N),COLORLIRED;
MA25:MA(C,25),LINETHICK2,COLORRED;
MA45:MA(C,M),COLORGREEN;
MA120:MA(C,120),COLORBROWN;

通达信战略家主图指标公式

 

相关文章