在线检测未来函数

通达信清晰MACD指标公式

来源:Internet,编辑:股旁网,2015-03-10

DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1),STICK;
MACD2:=EMA(MACD1,3);
DIF:DIF1,COLOR33FF33;
DEA:DEA1,COLORYELLOW;
MACD:MACD1,NODRAW,COLORMAGENTA;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,3,1),COLORRED;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,3,1),COLORYELLOW;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,3,1),COLORWHITE;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,3,1),COLORGREEN;
IF(DIF1>=DEA1,DIF1,DRAWNULL),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(DIF,DEA),DIF-0.1,'金叉'),COLORRED;
DRAWTEXT(CROSS(DEA,DIF),DIF+0.1,'死叉'),COLORGREEN;
DRAWICON(CROSS(DIF,DEA),-0.05,1);
DRAWICON(CROSS(DEA,DIF),+0.05,2);

通达信清晰MACD指标公式

 

相关文章