在线检测未来函数

通达信成交量波浪指标公式

来源:Internet,编辑:股旁网,2015-03-10

M1:=5;
M2:=10;
{VOLUME:VOL,VOLSTICK;原始指标}
{修改成交量画素色}
STICKLINE(C>O,0,VOL,1,1),COLORLIRED;
STICKLINE(C<O,0,VOL,1,1),COLORLIGREEN;
{倍量突出显示}
近期高量:=REF(HHV(V,480),1);
STICKLINE(VOL>MA(VOL,60)*2 AND C>O,0,VOL,1,1),COLORRED;
STICKLINE(VOL>MA(VOL,60)*2 AND C<O,0,VOL,1,1),COLORLIGREEN;
{主图波浪线}
DIFC:=(EMA(VOL,12)-EMA(VOL,26))*7+MA(VOL,160)*1.2,COLORYELLOW;
DEAC:EMA(DIFC,5)LINETHICK1,COLORGREEN;
MACDC:=(DIFC-DEAC)*2+(MA(VOL,160)*1.35),COLORSTICK;
IF(DIFC>MA(DIFC,5),DEAC,DRAWNULL),COLORRED,LINETHICK3;
IF(DEAC>REF(DEAC,1),DEAC,DRAWNULL),COLORRED,LINETHICK3;
{换手率满足4个月内>500%}
HSL:=100*VOL/(FINANCE(7)/100);
LH:=SUM(HSL,80);
换手率4月:LH,NODRAW,COLORWHITE;
LH1:=SUM(HSL,10);
换手率10日:LH1,NODRAW,COLORRED;
{MACD金叉3次、4次特别提示}
DIFF:=EMA(CLOSE*100,12)-EMA(CLOSE*100,26);
DEA:=EMA(DIFF,9);DEA6:=EMA(DIFF,5);MACD2:=(DIFF - DEA)*2;
DIF:=DIFF;DEF:=DEA;MACD:=MACD2,NODRAW;
{获利比:WINNER(C),NODRAW;}
STICKLINE((MACD2>=0),0,MACD2,0,1),COLORRED;
STICKLINE(((MACD2>=0) AND (MACD2 < REF(MACD2,1))),0,MACD2,0,0),COLORMAGENTA;
STICKLINE((MACD2<0),0,MACD2,0,0),COLORGREEN;
STICKLINE(((MACD2<0) AND (MACD2 > REF(MACD2,1))),0,MACD2,0,1),COLORWHITE;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
一次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=1,1)=1;
{DRAWTEXT(一次金叉,-3,'一金');}
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWTEXT(二次金叉,近期高量*0.3,'MACD二次金叉');
STICKLINE(二次金叉,0,VOL,1,0),COLORYELLOW;{用户可自行添加其它MACD金叉黄色量柱提示}
三次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=3,60)=1;
DRAWTEXT(三次金叉,近期高量*0.3,'三次金叉');
四次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=4,64)=1;
STICKLINE(三次金叉,-8,-10,9,0),COLORRED;
STICKLINE(四次金叉,-8,-10,9,0),COLORRED;{自己加的}
DRAWTEXT(四次金叉,近期高量*0.3,'四次金叉');
{大宗流入}
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
大宗净流入:((超B+大B+中B+小B)-(超S+大S+中S+小S))/10000,NODRAW;
近5:SUM(大宗净流入,5),NODRAW;
近10:SUM(大宗净流入,10),NODRAW;
近15:SUM(大宗净流入,15),NODRAW;

通达信成交量波浪指标公式

 

相关文章