在线检测未来函数

飞狐两上一下指标公式

来源:Internet,编辑:股旁网,2015-03-12

X1:=EMA(((2*C+H+L)/4-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,13)-21;
X2:=EMA(0.618*REF(X1,1)+0.382*X1,3);
if(x2>x1,x1,x1),colorff00ff;
if(x1>x2,x2,x1),color00ff00;
lmx1:=WINNER(CLOSE)*100;
lmx2:=100-lmx1;
lmx3:=ABS(lmx1-lmx2);
TD:=Backset(ISLASTBAR,1);
P:=SYSPARAM(1);
STICKLINE(TD,lmx3[P],0,3,0),COLORMAGENTA,shift2,align0,PXUP20;
STICKLINE(TD,lmx2[P],0,3,0 ),COLORCYAN,shift1,align0,PXUP20;
STICKLINE(TD,lmx1[P],0,3,0),COLORRED,shift3,align0,PXUP20;
DRAWTEXT(TD AND lmx1,lmx1[P],'牛'),COLORRED,shift3,align0,PXUP30;
DRAWTEXT(TD AND lmx2,lmx2[P],'熊'),COLORCYAN,shift1,align0,PXUP30;
DRAWTEXT(TD AND lmx3,lmx3[P],'马'),COLORMAGENTA,shift2,align0,PXUP30;

飞狐两上一下指标公式

 

相关文章