在线检测未来函数

大智慧东滨西凑主图指标公式

来源:Internet,编辑:股旁网,2015-03-12

DRAWGBKLAST(1,STRIP(RGB(0,0,80),RGB(0,20,20),0));
{K线JHJ}
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR0000AA;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000EE;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;
A74:=MA(CLOSE,20);
A75:=(CLOSE > MA(CLOSE,5));
A76:=(MA(CLOSE,5) > MA(CLOSE,10));
A77:=(CLOSE > MA(CLOSE,10));
A78:=(MA(CLOSE,5) > MA(CLOSE,20));
A79:=(CLOSE > MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74 > A710);
AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10))) + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);T := BARSLAST(DISPSTATUS=1)+1;
T := BARSLAST(DISPSTATUS=1)+1;
HHg := HHV(H, T);
ddg := LLV(L, T);
{Hk := LL-HH; G12 := LL-HK*1.55; }
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'该股放量下跌,走势明显偏弱,离场观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'该股缩量下跌,走势偏弱,离场观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'该股形态良好,强势明显,量能充足,可以继续持有。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'该股走势趋弱,量能不足,减持大部分筹码。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'该股形态不佳,注意成交量的变化,但目前不适合参与。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'该股走势太弱,没有参与价值。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,50,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,50,'如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(12,50,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(12,50,'可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,50,'大盘形态走坏,重仓者可以减去大部分仓位。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 < V2)) THEN
DRAWTEXTABS(12,50,'大盘缩量调整,注意风险,短线清仓观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,50,'大盘走势良好,量能理想,可以继续持有强势股。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(12,50,'大盘形态良好,但量能稍显不足,随时准备减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,50,'大盘趋势不明,注意成交量变化,目前不适宜进场。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(12,50,'大盘趋势向下,量能萎缩,不适合进场。 '),COLOR00FF00,LINETHICK3;
DRAWTEXTABS(8,25,'所属板块:'+BKNAME),ColorFFDE00,linethick3;
流通盘大小:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(66,2,'【流通盘大小:'+NUMTOSTRN(流通盘大小,2)+'亿'+'】'),LINETHICK3,COLORRED;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股净资产:=FINANCE2(4);
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);
净利润同比增长:=FINANCE2(10);
DRAWTEXTABS(160,70,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),COLOR00FF00;
DRAWTEXTABS(160,85,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),COLORRED;
DRAWTEXTABS(160,100,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),COLORRED;
DRAWTEXTABS(2,70,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(2,85,'主营收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),LINETHICK1,ColorYELLOW;
DRAWTEXTABS(2,100,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(3,120,'历史最高价:'+HHV(HIGH,0)),Colorred,LINETHICK3;
DRAWTEXTABS(3,140,'历史最低价:'+LLV(LOW,0)),ColorAFFF00,LINETHICK3;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
DRAWTEXTREL(350,8,'【量能饱和度:'+NUMTOSTRN(SAT,0)+'】'),LINETHICK5,Color8000FF;
AA8:MA(CLOSE,8),color0000FF,LAYER2;
AA13:MA(CLOSE,13),color00ff00,LAYER2;
FILLRGN(MA(C,8),MA(C,13),MA(C,8)>MA(C,13),rgb(150,10,10),MA(C,8)<MA(C,13),rgb(0,100,100)),LAYER4;
x1:=(2*C+L+H)/4;
bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;
ema8:=ema(c,8);
DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10),ema8,'∠45上升'),colorwhite;
压力:WMA(REF(HHV(C,34),1),2),Color0099FF,DOTLINE;
支撑:WMA(REF(LLV(C,34),1),2),ColorABFF46,DOTLINE;
ZX:(压力+支撑)/2,Color00ffFF,DOTLINE;
PARTLINE(ZX,ZX<=ref(ZX,1),rgb(0,255,0),1,rgb(255,0,0) ),LINETHICK2,LAYER0;
FILLRGN(压力,ZX,压力>ZX,RGB(0,0,180)),LAYER7;
FILLRGN(支撑,ZX,支撑<ZX,RGB(50,50,50)),LAYER7;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(ff1,(LOW* 0.99),'老鼠仓'),Color4080FF;
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,(HIGH* 0.97),'▲大黑马'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.992),'【买】'),ALIGN1,Colorff00ff,LINETHICK3;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.008),'【卖】'),ALIGN1,Colorgreen,LINETHICK3;
持仓:IF(CLOSE>=SAR(4,2,20),SAR(4,2,20),C),CIRCLEDOT,COLORRED,LINETHICK1;;
空仓:IF(CLOSE<=SAR(4,2,20),SAR(4,2,20),C),CIRCLEDOT,COLORGREEN,LINETHICK1;;
{买卖指标}
AA05:=WMA(C,9);
MMA5:=(C-AA05)/AA05*100;
AAA10:WMA(C,13),linethick0;
AA30:WMA(C,34),linethick0;
MM30:=(C-AA30)/AA30*100;
JC:=cross(0,MMA5) and MM30<ref(MM30,1) and AAA10>ref(AAA10,1) ;
减仓:=filter(JC,10);
drawtext(减仓,high*1.065,'◆'),ALIGN2,linethick3,color00ff00;
drawtext(减仓,high*1.055,'★'),ALIGN1,linethick3,color66ff66;
drawtext(减仓,high*1.055,'☆'),ALIGN1,linethick3,color0099ff;
drawtext(减仓,high*1.064,'◆'),ALIGN0,linethick3,color00ff00;
{高抛低吸}
SJ:=WMA(((2*C+H+L)/4-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
DRAWTEXT(CROSS(SJ,ZJ) AND SJ<30,L,'←吸'),COLOR00FFFF,LINETHICK3,LAYER0;
DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,H,'←抛'),COLOR00FFFf,LINETHICK3,LAYER0;
{---------创历史新高---------}
X:=BARSLAST(DISPSTATUS=1)+1;
高:=HHvall(HHv(H,X));
跑:=高=H AND ((C-L)<(O-C) OR (O-L)<(C-O));
STICKLINE(跑,C,O,8,0),COLORaaaaaa,LAYER0;;
STICKLINE(跑,C,O,6,0),COLORbbbbbb,LAYER0;;
STICKLINE(跑,C,O,4,0),COLORdddddd,LAYER0;;
STICKLINE(跑,C,O,2,0),COLORFFFFFF,LAYER0;;
DRAWTEXT(跑,H*1.01,'←【高】'),COLORFFFFFF;
E:=LLvaLL(LLv(L,X))*0.98;
DIFF:=WMA(CLOSE,12)-WMA(CLOSE,26);
DEA:=WMA(DIFF,9);
MACD:=3*(DIFF-DEA);
SZ:= MACD>REF(MACD,1);
STICKLINE(SZ,E,E+MACD*1.5,1.5,0),COLOR0000CC;
STICKLINE(SZ,E,E+MACD*0.9,2,0),COLOR0000EE;
STICKLINE(SZ,E,E+MACD*0.7,3,0),COLOR0033FF;
STICKLINE(SZ,E,E+MACD*0.5,3,0),COLOR0077FF;
STICKLINE(SZ,E,E+MACD*0.3,3,0),COLOR00BBFF;
STICKLINE(SZ,E,E+MACD*0.1,5,0),COLOR00FFFF;
XD:= MACD<REF(MACD,1);
STICKLINE(XD,E,E+MACD*1.5,1.5,0),COLORCC0033;
STICKLINE(XD,E,E+MACD*0.9,2,0),COLOREE0033;
STICKLINE(XD,E,E+MACD*0.7,3,0),COLORFF3333;
STICKLINE(XD,E,E+MACD*0.5,3,0),COLORFF7733;
STICKLINE(XD,E,E+MACD*0.3,4,0),COLORFFBB33;
STICKLINE(XD,E,E+MACD*0.1,5,0),COLORFFFF33;

大智慧东滨西凑主图指标公式

 

相关文章