在线检测未来函数

通达信四色柱指标公式

来源:Internet,编辑:股旁网,2015-03-12

{用法:黄色出现买入,紫色出现卖出,蓝色出现空仓,红色出现满仓。操作策略:随色彩变化而改变。}

DRAWGBK(O>C,RGB(50,25,0),RGB(0,25,50),0,'',0);
DIF:=10*(EMA(CLOSE,20)-EMA(CLOSE,120));
DEA:=EMA(DIF,10);
MACD:=(DIF-DEA)*2,COLORSTICK;
A3:=DIF;
STICKLINE(A3>REF(A3,1)AND A3<0,0,A3,-1,0),COLOR003399;
STICKLINE(A3>REF(A3,1)AND A3<0,0,A3,2,0),COLOR0099BB;
STICKLINE(A3>REF(A3,1)AND A3<0,0,A3,1,0),COLOR00AADD;
STICKLINE(A3>REF(A3,1)AND A3<0,0,A3,0.1,0),COLOR00FFFF;
STICKLINE(A3>REF(A3,1)AND A3>0,0,A3,-1,0),COLOR000099;
STICKLINE(A3>REF(A3,1)AND A3>0,0,A3,2,0),COLOR0000BB;
STICKLINE(A3>REF(A3,1)AND A3>0,0,A3,1,0),COLOR0000DD;
STICKLINE(A3>REF(A3,1)AND A3>0,0,A3,0.1,0),COLOR0000FF;
STICKLINE(A3<REF(A3,1)AND A3<0,0,A3,-1,0),COLOR339900;
STICKLINE(A3<REF(A3,1)AND A3<0,0,A3,2,0),COLOR77BB00;
STICKLINE(A3<REF(A3,1)AND A3<0,0,A3,1,0),COLOR9ADD00;
STICKLINE(A3<REF(A3,1)AND A3<0,0,A3,0.1,0),COLORDDFF00;
STICKLINE(A3<REF(A3,1)AND A3>0,0,A3,-1,0),COLOR330099;
STICKLINE(A3<REF(A3,1)AND A3>0,0,A3,2,0),COLOR9900BB;
STICKLINE(A3<REF(A3,1)AND A3>0,0,A3,1,0),COLORBB00DD;
STICKLINE(A3<REF(A3,1)AND A3>0,0,A3,0.1,0),COLORFF00FF;
{DRAWICON(MACD>REF(MACD,1)AND DIF<-20 AND REF(MACD,1)<REF(MACD,2),DIF,1);
DRAWICON(MACD<REF(MACD,1)AND DIF>20 AND REF(MACD,1)>REF(MACD,2),DIF,2)};

通达信四色柱指标公式

 

相关文章