在线检测未来函数

通达信出手是金指标公式

来源:Internet,编辑:股旁网,2015-03-12

N:=5;M:=3;
CFA:=(HIGH+CLOSE)/2;
CFB:=EMA(C,N);
CFC:=EMA(CFA,M);
N1:=3;N2:=8;M1:=50;M2:=100;SM:=20;KS:=6;
AT:=C/FINANCE(33)<M1 AND C/FINANCE(33)>0 AND FINANCE(7)<10000000*M2;
{11111111111111111111111111. K??}
XC:=C*(1-64/1000);
XL:=L;
XH:=H;
VV:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,VOL);
III_C:=IF(CURRBARSCOUNT=1 AND PERIOD=5,XC,XC);
III_L:=IF(CURRBARSCOUNT=1 AND PERIOD=5,XL,XL);
III_H:=IF(CURRBARSCOUNT=1 AND PERIOD=5,XH,XH);
AC:=III_C;
AL:=III_L;
AH:=III_H;
AQ_1:=AC-REF(AC,1);
AQ_2:=100*EMA(EMA(AQ_1,6),6)/EMA(EMA(ABS(AQ_1),6),6);
AQ_3:=CROSS(EMA(AC,N2),EMA(AC,N1));
AQ_4:=CROSS(EMA(AC,N1),EMA(AC,N2));
AZ1:=AL=LLV(AL,BARSLAST(AQ_3)+1);
AZ2:=LLV(AL,BARSLAST(AQ_3)+1);
AZ3:=AH=HHV(AH,BARSLAST(AQ_4)+1);
AZ4:=HHV(AH,BARSLAST(AQ_4)+1);
AQ_A:=DRAWLINE(AZ1,AZ2,AZ3,AZ4,0);
AY1:=AH=HHV(AH,BARSLAST(AQ_4)+1);
AY2:=HHV(AH,BARSLAST(AQ_4)+1);
AY3:=AL=LLV(AL,BARSLAST(AQ_3)+1);
AY4:=LLV(AL,BARSLAST(AQ_3)+1);
AQ_B:=DRAWLINE(AY1,AY2,AY3,AY4,0);
TJA:=IF(AQ_B<REF(AQ_B,1) AND AQ_B=AQ_A,1,0),COLORLIGREEN;
{22222222222222222222222222222. ??}
TH:=SUM(IF(CLOSE>REF(CLOSE,1),VV,0),26);
TL:=SUM(IF(CLOSE<REF(CLOSE,1),VV,0),26);
TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VV,0),26);
VVR:=100*(TH*2+TQ)/(TL*2+TQ);
MAVR:=EMA(VVR,6);
CC:=MAVR;
LL:=CC;
HH:=CC;
K_1:=CC-REF(CC,1);
K_2:=100*EMA(EMA(K_1,6),6)/EMA(EMA(ABS(K_1),6),6);
K_3:=CROSS(EMA(CC,N2),EMA(CC,N1));
K_4:=CROSS(EMA(CC,N1),EMA(CC,N2));
KZ1:=LL=LLV(LL,BARSLAST(K_3)+1);
KZ2:=LLV(LL,BARSLAST(K_3)+1);
KZ3:=HH=HHV(HH,BARSLAST(K_4)+1);
KZ4:=HHV(HH,BARSLAST(K_4)+1);
K_A:=DRAWLINE(KZ1,KZ2,KZ3,KZ4,0);
KY1:=HH=HHV(HH,BARSLAST(K_4)+1);
KY2:=HHV(HH,BARSLAST(K_4)+1);
KY3:=LL=LLV(LL,BARSLAST(K_3)+1);
KY4:=LLV(LL,BARSLAST(K_3)+1);
K_B:=DRAWLINE(KY1,KY2,KY3,KY4,0);
TJB:=IF(K_B<REF(K_B,1) AND K_B=K_A,1,0),COLORWHITE;
{333333333333333333333333333. ??"??·}
DPXX_GL:=INDEXC;
DPXX_DIF:=100*(EMA(DPXX_GL,5)-EMA(DPXX_GL,9))/DPXX_GL;
DPXX_DEA:=EMA(DPXX_DIF,3);
DPXX_AC:=DPXX_DEA;
DPXX_AL:=DPXX_AC;
DPXX_AH:=DPXX_AC;
DPXX_AQ_1:=DPXX_AC-REF(DPXX_AC,1);
DPXX_AQ_2:=100*EMA(EMA(DPXX_AQ_1,6),6)/EMA(EMA(ABS(DPXX_AQ_1),6),6);
DPXX_AQ_3:=CROSS(EMA(DPXX_AC,N2),EMA(DPXX_AC,N1));
DPXX_AQ_4:=CROSS(EMA(DPXX_AC,N1),EMA(DPXX_AC,N2));
DPXX_AZ1:=DPXX_AL=LLV(DPXX_AL,BARSLAST(DPXX_AQ_3)+1);
DPXX_AZ2:=LLV(DPXX_AL,BARSLAST(DPXX_AQ_3)+1);
DPXX_AZ3:=DPXX_AH=HHV(DPXX_AH,BARSLAST(DPXX_AQ_4)+1);
DPXX_AZ4:=HHV(DPXX_AH,BARSLAST(DPXX_AQ_4)+1);
DPXX_AQ_A:=DRAWLINE(DPXX_AZ1,DPXX_AZ2,DPXX_AZ3,DPXX_AZ4,0);
DPXX_AY1:=DPXX_AH=HHV(DPXX_AH,BARSLAST(DPXX_AQ_4)+1);
DPXX_AY2:=HHV(DPXX_AH,BARSLAST(DPXX_AQ_4)+1);
DPXX_AY3:=DPXX_AL=LLV(DPXX_AL,BARSLAST(DPXX_AQ_3)+1);
DPXX_AY4:=LLV(DPXX_AL,BARSLAST(DPXX_AQ_3)+1);
DPXX_AQ_B:=DRAWLINE(DPXX_AY1,DPXX_AY2,DPXX_AY3,DPXX_AY4,0);
DPXX_TJA:= IF(DPXX_AQ_B<REF(DPXX_AQ_B,1) AND DPXX_AQ_B=DPXX_AQ_A,1,0);
TJC:=DPXX_TJA=1 AND DPXX_DIF>DPXX_DEA;
YR1:=LLV(III_L,21);
YR2:=HHV(III_H,21);
YTK:=EMA((III_C-YR1)/(YR2-YR1)*100,6);
YTD:=EMA(0.667*REF(YTK,1)+0.333*YTK,2);
YR3:=LLV(III_L,55);
YR4:=HHV(III_H,34);
YR5:=EMA((III_C-YR3)/(YR4-YR3)*100,3);
YR6:=(YTK+YR5)/2;
YR7:=EMA(0.667*REF(YR5,1)+0.333*YTK,2);
YR8:=EMA(YR6,5);
YR9:=EMA(0.667*REF(YR8,1)+0.333*YR8,2);
YV7:=SMA(C,6.18,1)*YTK;
VOV:=(YTK+YTD+YR6+YR8+YR9)*0.2;
YC:=VOV;
YL:=YC;
YH:=YC;
YQ_1:=YC-REF(YC,1);
YQ_2:=100*EMA(EMA(YQ_1,6),6)/EMA(EMA(ABS(YQ_1),6),6);
YQ_3:=CROSS(EMA(YC,N2),EMA(YC,N1));
YQ_4:=CROSS(EMA(YC,N1),EMA(YC,N2));
YZ1:=YL=LLV(YL,BARSLAST(YQ_3)+1);
YZ2:=LLV(YL,BARSLAST(YQ_3)+1);
YZ3:=YH=HHV(YH,BARSLAST(YQ_4)+1);
YZ4:=HHV(YH,BARSLAST(YQ_4)+1);
YQ_A:=DRAWLINE(YZ1,YZ2,YZ3,YZ4,0);
YY1:=YH=HHV(YH,BARSLAST(YQ_4)+1);
YY2:=HHV(YH,BARSLAST(YQ_4)+1);
YY3:=YL=LLV(YL,BARSLAST(YQ_3)+1);
YY4:=LLV(YL,BARSLAST(YQ_3)+1);
YQ_B:=DRAWLINE(YY1,YY2,YY3,YY4,0);
TJD:=IF(YQ_B<REF(YQ_B,1) AND YQ_B=YQ_A,1,0);
{44444444444444444444444444444. ????}
RC:=WINNER(III_C)*0.9*100-5;
RL:=RC;
RH:=RC;
RQ_1:=RC-REF(RC,1);
RQ_2:=100*EMA(EMA(RQ_1,6),6)/EMA(EMA(ABS(RQ_1),6),6);
RQ_3:=CROSS(EMA(RC,N2),EMA(RC,N1));
RQ_4:=CROSS(EMA(RC,N1),EMA(RC,N2));
RZ1:=RL=LLV(RL,BARSLAST(RQ_3)+1);
RZ2:=LLV(RL,BARSLAST(RQ_3)+1);
RZ3:=RH=HHV(RH,BARSLAST(RQ_4)+1);
RZ4:=HHV(RH,BARSLAST(RQ_4)+1);
RQ_A:=DRAWLINE(RZ1,RZ2,RZ3,RZ4,0);
RY1:=RH=HHV(RH,BARSLAST(RQ_4)+1);
RY2:=HHV(RH,BARSLAST(RQ_4)+1);
RY3:=RL=LLV(RL,BARSLAST(RQ_3)+1);
RY4:=LLV(RL,BARSLAST(RQ_3)+1);
RQ_B:=DRAWLINE(RY1,RY2,RY3,RY4,0);
TJE:=IF(RQ_B<REF(RQ_B,1) AND RQ_B=RQ_A,1,0);
{55555555555555555555555555555555555.SM20}
MS:=EMA(III_C,SM);
SL:=MS;
SH:=MS;
SQ_1:=MS-REF(MS,1);
SQ_2:=100*EMA(EMA(SQ_1,6),6)/EMA(EMA(ABS(SQ_1),6),6);
SQ_3:=CROSS(EMA(MS,N2),EMA(MS,N1));
SQ_4:=CROSS(EMA(MS,N1),EMA(MS,N2));
SZ1:=SL=LLV(SL,BARSLAST(SQ_3)+1);
SZ2:=LLV(SL,BARSLAST(SQ_3)+1);
SZ3:=SH=HHV(SH,BARSLAST(SQ_4)+1);
SZ4:=HHV(SH,BARSLAST(SQ_4)+1);
SQ_A:=DRAWLINE(SZ1,SZ2,SZ3,SZ4,0);
SY1:=SH=HHV(SH,BARSLAST(SQ_4)+1);
SY2:=HHV(SH,BARSLAST(SQ_4)+1);
SY3:=SL=LLV(SL,BARSLAST(SQ_3)+1);
SY4:=LLV(SL,BARSLAST(SQ_3)+1);
SQ_B:=DRAWLINE(SY1,SY2,SY3,SY4,0);
TJF:=IF(SQ_B<REF(SQ_B,1) AND SQ_B=SQ_A,1,0);
{6666666666666666666666666666666. "???·?????}
HR1:=LLV(III_L,21);
HR2:=HHV(III_H,21);
HTK:=EMA((III_C-HR1)/(HR2-HR1)*100,6);
HV7:=SMA(III_C,6.18,1)*HTK;
DC:=HV7;
DL:=HV7;
DH:=HV7;
DQ_1:=DC-REF(DC,1);
DQ_2:=100*EMA(EMA(DQ_1,6),6)/EMA(EMA(ABS(DQ_1),6),6);
DQ_3:=CROSS(EMA(DC,N2),EMA(DC,N1));
DQ_4:=CROSS(EMA(DC,N1),EMA(DC,N2));
DZ1:=DL=LLV(DL,BARSLAST(DQ_3)+1);
DZ2:=LLV(DL,BARSLAST(DQ_3)+1);
DZ3:=DH=HHV(DH,BARSLAST(DQ_4)+1);
DZ4:=HHV(DH,BARSLAST(DQ_4)+1);
DQ_A:=DRAWLINE(DZ1,DZ2,DZ3,DZ4,0);
DY1:=DH=HHV(DH,BARSLAST(DQ_4)+1);
DY2:=HHV(DH,BARSLAST(DQ_4)+1);
DY3:=DL=LLV(DL,BARSLAST(DQ_3)+1);
DY4:=LLV(DL,BARSLAST(DQ_3)+1);
DQ_B:=DRAWLINE(DY1,DY2,DY3,DY4,0);
TJG:=IF(DQ_B<REF(DQ_B,1) AND DQ_B=DQ_A,1,0);
DPC:=INDEXC;
DPL:=INDEXL;
DPH:=INDEXH;
DPQ_1:=DPC-REF(DPC,1);
DPQ_2:=100*EMA(EMA(DPQ_1,6),6)/EMA(EMA(ABS(DPQ_1),6),6);
DPQ_3:=CROSS(EMA(DPC,N2),EMA(DPC,N1));
DPQ_4:=CROSS(EMA(DPC,N1),EMA(DPC,N2));
DPZ1:=DPL=LLV(DPL,BARSLAST(DPQ_3)+1);
DPZ2:=LLV(DPL,BARSLAST(DPQ_3)+1);
DPZ3:=DPH=HHV(DPH,BARSLAST(DPQ_4)+1);
DPZ4:=HHV(DPH,BARSLAST(DPQ_4)+1);
DPQ_A:=DRAWLINE(DPZ1,DPZ2,DPZ3,DPZ4,0);
DPY1:=DPH=HHV(DPH,BARSLAST(DPQ_4)+1);
DPY2:=HHV(DH,BARSLAST(DQ_4)+1);
DPY3:=DPL=LLV(DPL,BARSLAST(DPQ_3)+1);
DPY4:=LLV(DPL,BARSLAST(DPQ_3)+1);
DPQ_B:=DRAWLINE(DPY1,DPY2,DPY3,DPY4,0);
TJH:=IF(DPQ_B<REF(DPQ_B,1) AND DPQ_B=DPQ_A,1,0);
SCA:TJA+TJB+TJC+TJD+TJE+TJF+TJG +TJH,COLORMAGENTA,LINETHICK2;

通达信出手是金指标公式

 

相关文章