在线检测未来函数

大智慧KDJ与MACD二合一指标公式

来源:Internet,编辑:股旁网,2015-03-16

DRAWGBKLAST(1,STRIP(RGB(0,0,80),RGB(0,20,20),0)); ;0,DOTLINE;80,DOTLINE;
{---kdj(9.3.3)----}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),ColorFF9900;
D:SMA(K,3,1),Color00FF00,LINETHICK1;
J:3*K-2*D,Color00FFFF,LINETHICK1,LAYER0;
PARTLINE(D,D<REF(D,1),rgb(0,255,0),D>REF(D,1),rgb(255,0,0)),PRECIS1,linethick2;
FILLRGN(D,J,D>REF(D,1),RGB(60,0,60)),LAYER5;
FILLRGN(D,J,D<REF(D,1),RGB(60,80,60)),LAYER5;
{高抛低吸}
SJ:=WMA(((2*C+H+L)/4-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
MR:=CROSS(SJ,ZJ) AND SJ<30;
MC:=CROSS(ZJ,SJ) AND SJ>70;
AA8:=100*EMA(EMA(C-REF(C,1),8),5)/EMA(EMA(ABS(C-REF(C,1)),8),5);
买:=LLV(AA8,2)=LLV(AA8,8) AND COUNT(AA8<0,2) AND CROSS(AA8,WMA(AA8,2));
DRAWTEXT(MR ,J,'↖加仓1,'),COLOR00FFFF,LAYER0;;
DRAWTEXT(FILTER(买,5),J,'↖加仓 2.'),COLOR00FFff,LAYER2;;
卖:=HHV(AA8,2)=HHV(AA8,8) AND COUNT(AA8>0,2) AND CROSS(WMA(AA8,2),AA8);
DRAWTEXT(MC,J,'↙减仓1,'),COLOR00FF00,LAYER0;;;
DRAWTEXT(FILTER(卖,5),J,'↙减仓 2'),COLOR00ff00,LAYER2;;;
{----MACD(26.12.9)----EMA---}
{DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
MACD:2*(DIFF-DEA),PRECIS2,LINETHICK0;}
{----MACD(26.12.9)----WMA----}
DIFF:=WMA(CLOSE,12)-WMA(CLOSE,26);
DEA:=WMA(DIFF,9);
MACD:2*(DIFF-DEA),PRECIS2,LINETHICK0;;
Q:=120;
SZ:=MACD>REF(MACD,1);
STICKLINE(SZ,0,MACD*1*Q,1.2,0),COLOR0000CC;
STICKLINE(SZ,0,MACD*0.9*Q,2,0),COLOR0000EE;
STICKLINE(SZ,0,MACD*0.8*Q,2.5,0),COLOR0011FF;
STICKLINE(SZ,0,MACD*0.7*Q,3,0),COLOR0033FF;
STICKLINE(SZ,0,MACD*0.6*Q,3.3,0),COLOR0055FF;
STICKLINE(SZ,0,MACD*0.5*Q,3.6,0),COLOR0077FF;
STICKLINE(SZ,0,MACD*0.4*Q,4,0),COLOR0099FF;
STICKLINE(SZ,0,MACD*0.3*Q,4.3,0),COLOR00BBFF;
STICKLINE(SZ,0,MACD*0.2*Q,4.7,0),COLOR00DDFF;
STICKLINE(SZ,0,MACD*0.1*Q,5.1,0),COLOR00FFFF;
XD:=MACD<REF(MACD,1);
STICKLINE(XD,0,MACD*1*Q,1.2,0),COLORFF0000;
STICKLINE(XD,0,MACD*0.9*Q,2,0),COLORFF2211;
STICKLINE(XD,0,MACD*0.8*Q,2.5,0),COLORFF3311;
STICKLINE(XD,0,MACD*0.7*Q,3,0),COLORFF5511;
STICKLINE(XD,0,MACD*0.6*Q,3.3,0),COLORFF7733;
STICKLINE(XD,0,MACD*0.5*Q,3.6,0),COLORFF8833;
STICKLINE(XD,0,MACD*0.4*Q,4,0),COLOR999933;
STICKLINE(XD,0,MACD*0.3*Q,4.3,0),COLOR77BB00;
STICKLINE(XD,0,MACD*0.2*Q,4.7,0),COLOR88DD00;
STICKLINE(XD,0,MACD*0.1*Q,5.1,0),COLOR00FF00;
DRAWGBK(SZ,STRIP(RGB(0,0,255),RGB(60,0,60),0));

大智慧KDJ与MACD二合一指标公式

 

相关文章