在线检测未来函数

通达信波动级别指标公式

来源:Internet,编辑:股旁网,2015-03-16

T1:=10;
T2:=20;
T3:=40;
M1:=(HHV(C,T1)-LLV(C,T1))/(HHV(C,T1)+LLV(C,T1))*200;
M2:=(HHV(C,T2)-LLV(C,T2))/(HHV(C,T2)+LLV(C,T2))*200;
M3:=(HHV(C,T3)-LLV(C,T3))/(HHV(C,T3)+LLV(C,T3))*200;
短期波动:M1,COLORRED;
中期波动:M2,COLORYELLOW;
长期波动:M3,COLORMAGENTA;
Z11:=VARCAT('短:',VAR2STR(MA(M1,50)/1,1));
Z12:=VARCAT('中:',VAR2STR(MA(M2,100)/2,1));
Z13:=VARCAT('长:',VAR2STR(MA(M3,200)/4,1));
Z10:=VARCAT(STRCAT('可排序波动比较',Z11),VARCAT(Z12,Z13));
DRAWTEXT_FIX(1,0,0,0,Z10),COLORYELLOW;
DRAWTEXT_FIX(1,0,1,0,'通过挖掘短中长波动定势,可以做出很多选股公式,本指标仅供本群参考研究使用'),COLORLIGRAY;
M11:=MA(M1,3);M12:=MA(M1,5);
C11:=IF(M11>=M12,'短期波动增大;','短期波动减小;');
C12:=IF(M1<=5,'处于盘整阶段;',IF(M1<=15,'处于趋势状态;','处于异动状态;'));
DRAWTEXT_FIX(1,0,0.1,0,STRCAT(C11,C12));
M21:=MA(M2,5);M22:=MA(M2,13);
C21:=IF(M21>=M22,'中期波动增大;','中期波动减小;');
C22:=IF(M2<=10,'处于盘整阶段;',IF(M2<=20,'处于趋势状态;','处于异动状态;'));
DRAWTEXT_FIX(1,0,0.2,0,STRCAT(C21,C22));
M31:=MA(M3,13);M32:=MA(M3,26);
C31:=IF(M31>=M32,'长期波动增大;','长期波动减小;');
C32:=IF(M3<=15,'处于盘整阶段;',IF(M3<=30,'处于趋势状态;','处于异动状态;'));
DRAWTEXT_FIX(1,0,0.3,0,STRCAT(C31,C32));
MMAX:=MAX(MAX(M12,M22),M32);
MMIN:=MIN(MIN(M12,M22),M32);
集中度:100-(MMAX-MMIN)/(MMAX+MMIN)*100,NODRAW;
DRAWICON(CROSS(M32,10),10,25);
DRAWICON(集中度>90 AND M3<=REF(M3,1) AND M1>REF(M1,1) AND MA(C,5)>MA(C,13),M3,5);
NOTEXT25:25,CROSSDOT,COLORGREEN;
NOTEXT10:10,CIRCLEDOT,COLORLIGRAY;
DRAWTEXT(CURRBARSCOUNT=7,10,'爆发线');
DRAWTEXT(CURRBARSCOUNT=7,25,'异动线');
{稳赚不亏主升选股其一}
J11:=CROSS(M32,10);
T11:=BARSLAST(J11);
TJ1:=CROSS(M1,5) AND T11<10;
DRAWICON(TJ1,M3,1);

通达信波动级别指标公式

 

相关文章