在线检测未来函数

通达信MACD共振30指标公式

来源:Internet,编辑:股旁网,2015-03-23

{使用说明:最上面线:30分钟做多(当前周期);第二条线:60分做多周期(短线);第三条线:日线级别做多(中线);第四条线:周线级别做多(长线)。}

DIF30:=EMA(CLOSE*100,12)-EMA(CLOSE*100,26);
DEA30:=EMA(DIF30,9);
MACD0030:=(DIF30-DEA30)*2,COLORSTICK;
做多30:=DIF30>REF(DIF30,1);
做多31:=DEA30>REF(DEA30,1);
DIF60:=EMA(CLOSE*100,24)-EMA(CLOSE*100,52);
DEA60:=EMA(DIF60,9);
MACD0060:=(DIF60-DEA60)*2,COLORSTICK;
做多60:=DIF60>REF(DIF60,1);
做多61:=DEA60>REF(DEA60,1);
DIF日:=EMA(CLOSE*100,77)-EMA(CLOSE*100,208);
DEA日:=EMA(DIF日,32);
MACD00日:=(DIF日-DEA日)*2,COLORSTICK;
做多日:=DIF日>REF(DIF日,1);
做多日1:=DEA日>REF(DEA日,1);
DIF周:=EMA(CLOSE*100,480)-EMA(CLOSE*100,1040);
DEA周:=EMA(DIF周,66);
MACD00周:=(DIF周-DEA周)*2,COLORSTICK;
做多周:=DIF周>REF(DIF周,1);
-72,COLOR222222;
MACD30:-90,COLORGRAY,LINETHICK2;
MACD60:-108,COLORGRAY,LINETHICK2;
MACD日:-126,COLORGRAY,LINETHICK2;
MACD周:-144,COLORGRAY,LINETHICK2;
-158,COLOR222222;
IF(做多30,MACD30,DRAWNULL),COLORRED,LINETHICK8;
IF(做多60,MACD60,DRAWNULL),COLOR0066CC,LINETHICK8;
IF(做多日,MACD日,DRAWNULL),COLOR0066CC,LINETHICK9;
IF(做多周,MACD周,DRAWNULL),COLOR0066CC,LINETHICK9;

通达信MACD共振30指标公式

 

相关文章