在线检测未来函数

飞狐黄金金叉指标公式

来源:Internet,编辑:股旁网,2015-03-24

T1:=5;
T2:=4;
P:=((2)*(CLOSE) + HIGH + LOW + OPEN)/(5);
BB:=MA(P,3);
CC:=(SUM(IF((P > REF(P,1)),(P)*(VOL),0),4))/(SUM(IF((P < REF(P,1)),(P)*(VOL),0),4));
DD:=REF(100 - (100)/(1 + CC),1);
A1:=HHV(P,15);
A2:=LLV(P,15);
A3:=A1 - A2;
A4:=(EMA((P - A2)/(A3),2))*(100);
B1:=HHV(P,60);
B2:=LLV(P,60);
B3:=B1 - B2;
B4:=(EMA((P - B2)/(B3),2))*(100);
C1:=HHV(P,240);
C2:=LLV(P,240);
C3:=C1 - C2;
C4:=(EMA((P - C2)/(C3),2))*(100);
长风险:C4,Linethick2,Color443434;
中风险:B4,ColorAA7755;
短风险:A4,Color44AABB;
IF(FILTER((中风险 < REF(中风险,1)) and (中风险 > 90) and (BB < REF(BB,1)),5),92,100),Linethick2,Color44BB00;
IF(FILTER((中风险 > REF(中风险,1)) and (中风险 < 5) and (CLOSE > REF(CLOSE,1)),5),14,0),Linethick2,Color2222FF;
VAR4:=LLV(LOW,T1);
VAR5:=HHV(HIGH,T2);
散户:EMA(((P - VAR4)/(VAR5 - VAR4))*(100),T2),Linethick2,Color3333DD;
庄家:EMA((0.667)*(REF(散户,1)) + (0.333)*(散户),2),Linethick2,ColorDDCC00;
VAR6:=((HHV(HIGH,4) - P)/(HHV(HIGH,4) - LLV(LOW,4)))*(100) - 72;
VAR7:=((P - LLV(LOW,4))/(HHV(HIGH,4) - LLV(LOW,4)))*(100);
VAR8:=SMA(VAR7,2,1);
DRAWTEXT(CROSS(散户,庄家) and (散户 < 50) and (29 < 散户),20,'▲'),colorred;
DRAWTEXT(CROSS(庄家,散户) and (散户 > 40) and (71 > 散户),70,'▼'),ColorFF0000;
DRAWTEXT(CROSS(散户,庄家) and (散户 < 30),30,'吸'),colorred;
DRAWICON(CROSS(散户,庄家) and (散户 < 30),20,1),coloryellow;
DRAWICON(CROSS(庄家,散户) and (散户 > 70),80,2),ColorFF00FF;
VAR9:=CLOSE - REF(CLOSE,5);
VARA:=((EMA(EMA(VAR9,5),5))/(EMA(EMA(ABS(VAR9),5),5)))*(100);
VARB:=((EMA(EMA(VAR9,10),10))/(EMA(EMA(ABS(VAR9),10),10)))*(100);
VARC:=((EMA(EMA(VAR9,20),20))/(EMA(EMA(ABS(VAR9),20),20)))*(100);
卖出:=IF((VARA > 0) and CROSS(VARC,VARA),10,0);
DRAWICON((卖出 > 0),60,2),Color00FF00;
CCI:=((P - MA(P,14))*(100))/((1.5)*(AVEDEV(P,14)));
RSI1:=((SMA(MAX(CLOSE - REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE - REF(CLOSE,1)),6,1)))*(100);
STICKLINE((CCI > 100),106,100,6,0),Color00AC00;
STICKLINE((RSI1 > 80),105,102,6,0),Color00FE00;
STICKLINE((CCI < (-100)),(-6),0,6,0),coloryellow;
STICKLINE((RSI1 < 25),(-6),(-2),6,0),ColorFF44FF;
D1:=(中风险 > REF(中风险,1)) and (短风险 > REF(短风险,1)) and (长风险 > REF(长风险,1)) and (长风险 < 8) and (中风险 < 10) and (短风险 < 15);
D2:=CROSS(短风险,中风险) and (中风险 < 8);
D3:=CROSS(短风险,长风险) and (长风险 < 8) and (中风险 < 20);
DRAWICON(FILTER(D1 or D2 or D3 and (DD < 15) and (CLOSE > REF(CLOSE,1)),5),8,1),ColorFF0000;
DRAWICON(FILTER((中风险 < REF(中风险,1)) and (短风险 < REF(短风险,1)) and (长风险 < REF(长风险,1)) and (中风险 > 95) and (短风险 > 85) or (长风险 > 100) and (中风险 > 100) and (短风险 > 100),5),95,2),Color000080;
警戒线:80,ColorDCDCDC;
启动线:20,coloryellow;
50,POINTDOT,Color00DCDC;

飞狐黄金金叉指标公式

 

相关文章