在线检测未来函数

飞狐顶底背离指标公式

来源:Internet,编辑:股旁网,2015-03-25

A1:=BARSLAST(ref(cross("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));
B1:=ref(c,A1+1)>c and ref("macd.diff"(12,26,9),A1+1)<"macd.diff"(12,26,9) and cross("macd.diff"(12,26,9),"macd.dea"(12,26,9));
MACD背离:=FILTER(B1>0,5);
STICKLINE(MACD底背离,0,0.75,3,0),COLORGREEN;
DRAWTEXT(MACD底背离,0.57,'MACD底背离'),COLORGREEN;
A2:=BARSLAST(ref(cross("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=ref(c,A2+1)>c and ref("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) and cross("kdj.k"(9,3,3),"kdj.d"(9,3,3));
KDJ底背离:=FILTER(B2>0,5);
STICKLINE(KDJ底背离,0,1,3,0),COLORYELLOW;
DRAWTEXT(KDJ底背离,0.80,'KDJ底背离'),COLORYELLOW;
A3:=BARSLAST(ref(cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) and cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
RSI底背离:=FILTER(B3>0,5);
STICKLINE(RSI底背离,0,0.5,3,0),COLORFFCC66;
DRAWTEXT(RSI底背离,0.25,'RSI底背离'),COLORFFCC66;
2,COLORRED;
C1:=BARSLAST(ref(cross("macd.dea"(12,26,9),"macd.diff"(12,26,9)),1));
D1:=ref(c,C1+1)<c and ref("macd.diff"(12,26,9),C1+1)>"macd.diff"(12,26,9) and cross("macd.dea"(12,26,9),"macd.diff"(12,26,9));
MACD顶背离:=FILTER(D1>0,5);
STICKLINE(MACD顶背离,2,1.25,3,0),COLOR0066FF;
DRAWTEXT(MACD顶背离,1.47,'MACD顶背离'),COLOR0066FF;
C2:=BARSLAST(ref(cross("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1));
D2:=ref(c,C2+1)<c and ref("kdj.k"(9,3,3),C2+1)>"kdj.k"(9,3,3) and cross("kdj.d"(9,3,3),"kdj.k"(9,3,3));
KDJ顶背离:=FILTER(D2>0,5);
STICKLINE(KDJ顶背离,2,1,3,0),COLORRED;
DRAWTEXT(KDJ顶背离,1.2,'KDJ顶背离'),COLORRED;
C3:=BARSLAST(ref(cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=ref(c,C3+1)<c and ref("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) and cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
RSI顶背离:=FILTER(D3>0,5);
STICKLINE(RSI顶背离,2,1.5,3,0),COLORFF00FF;
DRAWTEXT(RSI顶背离,1.75,'RSI顶背离'),COLORFF00FF;
底背离:MACD底背离 or KDJ底背离 or RSI底背离;
顶背离:MACD顶背离 or KDJ顶背离 or RSI顶背离;

飞狐顶底背离指标公式

 

相关文章