在线检测未来函数

通达信新换手率指标公式

来源:Internet,编辑:股旁网,2015-03-25

HSL:100*VOL/CAPITAL,VOLSTICK;
M3:=SMA(HSL,3,1);
MH1:MA(HSL,5),COLORRED;
MH2:MA(HSL,10);
MH3:MA(HSL,20);
MH4:MA(HSL,100);
警戒值:MH3/MH4,COLORRED,NODRAW;
S1:=警戒值-LLV(警戒值,30);
IF(UPNDAY(MH4,3)&&警戒值>0.7,MH4,DRAWNULL),COLORBLUE;
R1:=(OPEN+2*CLOSE)/3;
A1:=(R1*6+REF(R1,1)*5+REF(R1,2)*4+REF(R1,3)*3+REF(R1,4)*2+REF(R1,5)*1)/21,LINETHICK3,COLORGREEN;
BA1:=(A1-REF(A1,1))/REF(A1,1)*100;
AB:=HSL/REF(HSL,2)*100;
AB2:=HSL/REF(HSL,1)*100;
DRAWTEXT(AB<55&&REF(AB2,1)>50&&REF(BA1,2)>1&&REF(HSL,2)>2.5&&HSL<6,2*HSL,'A'),COLORWHITE;
ZF1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
DRAWTEXT(AB2<60&&AB2>50&&REF(BA1,1)>0.5&&HSL>1.2&&HSL<6,2*HSL,'B'),COLORWHITE;
DRAWTEXT(AB<55&&REF(AB2,1)>50&&REF(HSL,2)>2.5&&HSL<6&&AB<40&&ZF1<3&&BA1<-0.3,3*HSL,'选择突破方向'),COLORWHITE;
AX1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
AX2:=HSL/MH4;
AX2A:=HSL/REF(HSL,1);
DRAWTEXT(AX1>3&&AX1<5&&AX2A>2&&AX2>2,1.2*HSL,'庄家痕迹'),COLORMAGENTA;
AX3:=IF(AX1>3&&AX1<5&&AX2A>2&&AX2>2,2,DRAWNULL);
AX4:=COUNT(AX3>1,20);
DRAWTEXT(AX4=2&&AX1>3&&AX1<5&&AX2A>2&&AX2>2,1.5*HSL,'加自选'),COLORRED;

通达信新换手率指标公式

 

相关文章