在线检测未来函数

飞狐量快慢线指标公式

来源:Internet,编辑:股旁网,2015-03-27

DRAWGBK(1,COLORRGB(0,0,20),COLORRGB(0,60,50),1);
DRAWTEXTEX(CLOSE,1,0,22,STKLABEL+' '+STKNAME+''),colorDDFF;
BB:=BARPOS=SYSPARAM(1);
VARIABLE:WDAY[7]='星期六';
WDAY[1]:='星期日';
WDAY[2]:='星期一';
WDAY[3]:='星期二';
WDAY[4]:='星期三';
WDAY[5]:='星期四';
WDAY[6]:='星期五';
FY:=YEAR;
FM:=MONTH;
FD:=DAY;
WD:=WEEKDAY;
P:=SYSPARAM(1);
STR1:=''+'今日: '+NUMTOSTR(FY[P],0)+'年'+NUMTOSTR(FM[P],0)+'月'+NUMTOSTR(FD[P],0)+'日 '+WDAY[WD[P]+1];
DRAWTEXTEX(CLOSE,1,460,22,STR1),colorDDFF;
月向线:=98;
月量线:=100;
50,LINEDOT;
CS:=IF(CAPITAL<1,516,469);
A:=EMA(CLOSE,198)-EMA(CLOSE,CS);
B:=EMA(A,112);
月线下水:=A<0;
月转红:=A>=REF(A,1);
A1:=EMA(CLOSE,55)-EMA(CLOSE,119);
B1:=EMA(A1,36);
周线下水:=A1<0;
周红:=A1>=REF(A1,1);
周转红:=A1>=REF(A1,1) AND REF(A1>=REF(A1,1),1)=0;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD1:=2*(DIFF-DEA);
日转红:=MACD1>=0 AND REF(MACD1,1)<0;
PARTLINE(月转红,月向线),LINETHICK3,colorFFFFFF;
PARTLINE(周红,月量线),LINETHICK3,colorFF;
PARTLINE(月转红=0,月向线),LINEDOT,LINETHICK1,colorFF00;
PARTLINE(月线下水 AND 月转红=0,月向线),LINETHICK2,colorFF00;
PARTLINE(周红=0,月量线),LINEDOT,LINETHICK1,colorFF00;
PARTLINE(周线下水 AND 周红=0,月量线),LINETHICK2,colorFF00;
CS1:=100;
CS2:=HHV(ABS(MACD1),CS1);
CS3:=ABS(100/CS2);
MACD:(MACD1*CS3+100)/2,LINETHICK1,color74FFFF;
CS:=MACD;
日红:=CS>=REF(CS,1);
日转红:=日红 AND REF(日红,1)=0;
PARTLINE(日红,CS),LINETHICK3,colorFFFF;
A:=MA(VOL,5);
V1:=IF(CAPITAL<1,MA(A,74),A);
V2:=IF(CAPITAL<1,WMA(V1,360),WMA(V1,14));
V3:=(A-LLV(A,14))/(HHV(A,14)-LLV(A,14))*100;
V4:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
V7:=SMA(V4,3,1);
V8:=SMA(V7,3,1);
V5:=CROSS(V3,1) AND V1<V2 AND V8<20;
V6:=CROSS(98,V3) AND V1>V2 AND V7>80;
W1:=CROSS(V7,V8) AND V8<20;
MACDMR:=W1 AND 周红;
DRAWICON(MACDMR,月量线,4),colorFF;
月WW1:=SMA((CLOSE-LLV(CLOSE,350))/(HHV(HIGH,350)-LLV(LOW,350)),54,1);
月线:=SMA((月WW1-LLV(月WW1,20))/(HHV(月WW1,20)-LLV(月WW1,20)),54,1)*100;
月价:月线,LINETHICK0,colorFFFFFF;
月ZZ:=SMA((VOL-LLV(VOL,350))/(HHV(VOL,350)-LLV(VOL,350)),54,1);
月量:SMA((月ZZ-LLV(月ZZ,20))/(HHV(月ZZ,20)-LLV(月ZZ,20)),54,1)*100,LINETHICK0,colorFF;
NN:=IF(MA(CLOSE,60)>MA(CLOSE,120),6,3);
NN:=3;
WW1:=SMA((CLOSE-LLV(CLOSE,21))/(HHV(HIGH,21)-LLV(LOW,21)),NN,1);
WW2:=SMA((WW1-LLV(WW1,5))/(HHV(WW1,5)-LLV(WW1,5)),NN,1)*100;
ZZ:=SMA((VOL-LLV(VOL,21))/(HHV(VOL,21)-LLV(VOL,21)),NN,1);
ZZ1:=SMA((ZZ-LLV(ZZ,5))/(HHV(ZZ,5)-LLV(ZZ,5)),NN,1)*100;
快线:=EMA(WW2,1);
价快:=快线;
慢线:=EMA(快线,2);
价慢:慢线,LINETHICK0,colorFF00;
STICKLINE(EMA(慢线,2)>=REF(EMA(慢线,2),1),EMA(慢线,1),REF(EMA(慢线,1),1),5,0),LINETHICK1,colorFF;
STICKLINE(EMA(慢线,2)<REF(EMA(慢线,2),1),EMA(慢线,2),REF(EMA(慢线,2),1),5,0),colorFF00;
量快:EMA(ZZ1,1),LINEDOT,LINETHICK1,colorFFFFFF;
量慢:=EMA(量快,2);
PARTLINE(快线>=REF(快线,1),快线),LINETHICK1,colorFF;
PARTLINE(快线<REF(快线,1),快线),LINETHICK1,colorFF00;
PARTLINE(月线>=REF(月线,1),月线),LINEDOT,LINETHICK3,colorFFFFFF;
PARTLINE(月线<REF(月线,1),月线),LINETHICK2,color808080;
PARTLINE(月量>=REF(月量,1),月量),LINEDOT,LINETHICK1,color7400FF;
PARTLINE(月量<REF(月量,1),月量),LINEDOT,LINETHICK1,color808080;
周WW1:=SMA((CLOSE-LLV(CLOSE,110))/(HHV(HIGH,110)-LLV(LOW,110)),16,1);
周线:=SMA((周WW1-LLV(周WW1,10))/(HHV(周WW1,10)-LLV(周WW1,10)),16,1)*100;
周价:周线,LINETHICK0,colorFF00FF;
周ZZ:=SMA((VOL-LLV(VOL,110))/(HHV(VOL,110)-LLV(VOL,110)),16,1);
周量:SMA((周ZZ-LLV(周ZZ,10))/(HHV(周ZZ,10)-LLV(周ZZ,10)),16,1)*100,LINETHICK0,colorFFFF;
快线2:=EMA(周线,1);
慢线2:=EMA(快线2,2);
量快2:=EMA(周量,1);
量慢2:=EMA(量快2,2);
DRAWICON(CROSS(快线2,慢线2),慢线2,10);
DRAWICON(CROSS(慢线2,快线2),快线2,11);
DRAWICON(CROSS(量快2,量慢2),量慢2,10);
DRAWICON(CROSS(量慢2,量快2),量快2,11);
PARTLINE(周线>=REF(周线,1),周线),LINETHICK2,colorFF00FF;
PARTLINE(周线>=REF(周线,1) AND 月线>=REF(月线,1),周线),LINETHICK3,colorFF;
PARTLINE(周线<REF(周线,1),周线),LINETHICK2,colorFF00;
PARTLINE(周量>=REF(周量,1),周量),LINEDOT,LINETHICK1,colorFFFF;
PARTLINE(周量<REF(周量,1),周量),LINEDOT,LINETHICK1,colorFF00;
DRAWTEXT(FILTER(快线>=95 AND 慢线>=95 AND 周线>=90 OR 周量>=90,5),90,'周减'),PXUP4,colorFFFFFF;
DRAWTEXT(FILTER(快线>=95,5),95,'日减'),PXUP4,colorFFFFFF;
DRAWTEXT(周线>=REF(周线,1) AND CROSS(快线,慢线) AND 周线<50 AND 快线<50,快线+快线*0.1,'←价买'),colorFFFF;
DRAWTEXT(周量>=REF(周量,1) AND CROSS(快线,慢线) AND 周线<50 AND 快线<60,快线,'←量买'),colorFFFF;
DRAWICON(CROSS(价快,量快) AND 量快>60 AND 量快<REF(量快,1) OR CROSS(量快,价快) AND 量快>60 AND 价快<REF(价快,1),量快,11);
显示位置:=-6;
RSI6:(SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),6,1))*100,LINEDOT,LINETHICK1,color6FFF;
DRAWICON(CROSS(RSI6,价快),RSI6,4),colorFF;
DRAWICON(CROSS(价快,RSI6),RSI6,5),colorFF00;
LC:=REF(CLOSE,1);
月RS:=(SMA(MAX(CLOSE-LC,0),100,1))/(SMA(ABS(CLOSE-LC),100,1))*100;
月SI:=(SMA(MAX(CLOSE-LC,0),320,1))/(SMA(ABS(CLOSE-LC),320,1))*100;
PARTLINE(月RS>月SI,显示位置+2),LINETHICK4,colorFFFFFF;
PARTLINE(月RS<月SI,显示位置+2),LINEDOT,LINETHICK1,colorFF00;
周RS:=EMA((SMA(MAX(CLOSE-LC,0),25,1))/(SMA(ABS(CLOSE-LC),25,1))*100,2);
周SI:=EMA((SMA(MAX(CLOSE-LC,0),80,1))/(SMA(ABS(CLOSE-LC),80,1))*100,21);
PARTLINE(周RS>周SI,显示位置+4),LINETHICK4,colorFF;
PARTLINE(周RS<周SI,显示位置+4),LINEDOT,LINETHICK1,colorFF00;
有量:=130-15*(SMA(SMA(VOL,4,3)/SMA(VOL,24,4)+SMA(VOL,5,4)/SMA(VOL,36,4)*1.052,18,9));
STICKLINE(有量<=100,100-有量,0,2,0),color78FF;
攻击量:IF(有量<=100,100-有量,0),LINETHICK0;
量买:周量>=REF(周量,1) AND CROSS(快线,慢线) AND 周线<50 AND 快线<60,LINETHICK0;
价买:周线>=REF(周线,1) AND CROSS(快线,慢线) AND 周线<50 AND 快线<50,LINETHICK0;
ST:=STRFIND(STKNAME,'ST',1)>0;
S:=STRFIND(STKNAME,'S',1)>0;
停牌:=DYNAINFO(4)=0;
非ST:=NOT(ST) AND NOT(停牌) AND NOT(S) AND REF(CLOSE,100)>0;
红点选股:CROSS(快线2,慢线2) AND CROSS(量快2,量慢2) AND 非ST,LINETHICK0;
持仓区选股:月RS>月SI OR 周RS>周SI AND 非ST,LINETHICK0;
超级选股:红点选股 AND 持仓区选股 AND 非ST,LINETHICK0;
参考选股1:非ST AND 快线2>慢线2 AND 量快2>量慢2 AND 持仓区选股 AND (REF(快线2,1)<REF(慢线2,1) OR REF(量快2,1)<REF(量慢2,1)),LINETHICK0;
A:=ABS(快线-量快);
参考选股2:非ST AND 持仓区选股 AND CROSS(快线,慢线) AND 快线<50 AND 周线>REF(周线,1) AND 周量>REF(周量,1) AND (CLOSE-LLV(CLOSE,10))/LLV(CLOSE,10)*100<20 AND (HHV(CLOSE,20)-CLOSE)/CLOSE>0.1 AND A<20,LINETHICK0;
VERTLINE(参考选股2),LINEDOT,LINETHICK1,colorFF;
VERTLINE(参考选股1),LINEDOT,LINETHICK1,colorFFFF;
VERTLINE(超级选股),LINETHICK2,colorFF00AB;
周持仓区选股:周RS>周SI,LINETHICK0;
周持仓新:周RS>周SI AND REF(周RS>周SI,1)<1,LINETHICK0;
月持仓区选股:月RS>月SI AND 非ST,LINETHICK0;
A1:=CROSS(快线,慢线);
A3:=BARSLAST(REF(CROSS(快线,慢线),1));
C3:=REF(CLOSE,A3);
LX:=REF(快线,A3);
价背选股:A1 AND 快线>LX AND CLOSE<C3 AND 量慢>REF(量慢,C3),LINETHICK0;
DRAWTEXT(价背选股,快线+快线*0.1,'←价背'),colorFF;
A21:=CROSS(量快,量慢);
A23:=BARSLAST(REF(CROSS(量快,量慢),1));
C23:=REF(CLOSE,A23);
LX:=REF(量快,A23);
量背选股:COUNT(A21 AND 量快>LX AND CLOSE<C23,10)>0 AND CROSS(快线,慢线) AND 量慢>REF(量慢,1),LINETHICK0;
DRAWTEXT(量背选股,量快,'←量背'),colorFF;
背离:=FILTER(COUNT(REF(慢线,1)>REF(慢线,2),3)>=2 AND 慢线>REF(慢线,1) AND COUNT(REF(量慢,1)>REF(量慢,2),3)>=2 AND 量慢<REF(量慢,1),2);
DRAWTEXT(顶背离,量慢,'←顶背离'),colorFFFF00;
CPE1:=CLOSE*CLOSE/FINANCE(33);
CPE:=EMA(CPE1,5);
SP:=EMA(CLOSE,5);
TJ:=CPE<REF(CPE,1) AND SP>REF(SP,1);
CPE选股:=TJ AND REF(TJ,1)=0;
V1:=EMA(CLOSE,5)-EMA(CLOSE,340);
V2:=EMA(V1,144);
V3:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
卖出:=CROSS(95,V3) AND V1>V2 AND COUNT(V3>95,3)=2 AND TJ=0;
量价判断:=价慢<35 AND 周价<35 AND 攻击量>0;
抄底买入:CROSS(V3,5) AND V1<V2 AND COUNT(V3<5,3)>=2 AND 量价判断,LINETHICK0;
VERTLINE(卖出),LINEDOT,colorFF00;
DRAWTEXT(卖出,10,'顶'),colorFF00;
VERTLINE(抄底买入),LINEDOT,color5BFF;
DRAWTEXT(抄底买入,90,'抄底'),colorFF;
抄底加码:CPE选股 AND COUNT(抄底买入,4)>0,LINETHICK0;
VERTLINE(抄底加码),colorFF;
DRAWTEXT(抄底加码,90,'加码'),colorFF;
二师量买:量背选股 AND 量买,LINETHICK0;
二师价买:价背选股 AND 价买,LINETHICK0;
二师量价买:量背选股 AND 价背选股 OR 量买 AND 价买,LINETHICK0;
二师送礼:抄底买入 AND (二师量买 OR 二师价买),LINETHICK0;
二师送钱:二师量买 AND 二师价买,LINETHICK0;
VERTLINE(二师量买 OR 二师价买 OR 二师送礼 OR 二师送钱 OR 二师量价买),color89FF;
V1:=MA(CLOSE,3)=HHV(MA(CLOSE,3),7);
V2:=MA(CLOSE,3)>MA(CLOSE,5);
V3:=MA(VOL,5)>MA(VOL,10)*1.01;
V4:=COUNT(MA(CLOSE,1)>REF(CLOSE,1),2)=2;
逃顶:=V1 AND V2 AND V3 AND V4 AND TJ=0 AND 价慢>RSI6;
AA:=-2;
V1:=LLV(LOW,10);
V2:=HHV(HIGH,25);
价位线:=EMA((CLOSE-V1)/(V2-V1)*4,4);
DRAWTEXT(CROSS(价位线,0.3),AA,'■'),colorFF;
DRAWTEXT(CROSS(3.5,价位线),AA,'■'),colorFF00;
价位线选股:CROSS(价位线,0.3),LINETHICK0;
周月低选股:周价<10 AND 月价<10 AND 慢线>REF(慢线,1) AND REF(慢线,1)<REF(慢线,2) AND 非ST,LINETHICK0;
RSI选股:CROSS(RSI6,价快),LINETHICK0;
MACD选股:MACDMR,LINETHICK0;
MACD选股1:周红 AND 日转红,LINETHICK0;
DRAWICON(MACD选股1,98,10);
DRAWTEXT(BARPOS=SYSPARAM(1) AND 超级选股,80,'←超级选股'),colorFF;
DRAWTEXT(BARPOS=SYSPARAM(1) AND 参考选股1,80,'←参考选股1'),colorFF;
DRAWTEXT(BARPOS=SYSPARAM(1) AND 参考选股2,80,'←参考选股2'),colorFF;
DRAWTEXT(BARPOS=SYSPARAM(1) AND (卖出 OR 逃顶),80,'←逃顶'),colorFF00;
DRAWTEXT(BARPOS=SYSPARAM(1) AND 二师量买,80,'←二师量买'),colorFF;
DRAWTEXT(BARPOS=SYSPARAM(1) AND 二师价买,80,'←二师价买'),colorFF;
DRAWTEXT(BARPOS=SYSPARAM(1) AND 二师送礼,80,'←二师送礼'),colorFF;
DRAWTEXT(BARPOS=SYSPARAM(1) AND 二师送钱,80,'←二师送钱'),colorFF;
DRAWTEXT(BARPOS=SYSPARAM(1) AND 二师量价买,80,'←二师量价买'),colorFF;

飞狐量快慢线指标公式

 

相关文章