在线检测未来函数

大智慧换手和板块主图指标公式

来源:Internet,编辑:股旁网,2015-03-30

{参数设置 年:最小1990,最大3000,缺省年2014 月:1,12,1 (缺省月7)日:1,31,1(缺省日17)}
年:=2015;
月:=2;
日:=26;
时间:=(年-1900)*10000+月*100+日;
DRAWTEXT(BARSLAST(DATE>=时间),L*0.94,'换手起点'),COLORRED;
DRAWICON(BARSLAST(DATE>=时间),L*0.98,1);
HSL:100*VOL/(capital),linethick0;
上市日期:(FINANCE2(2)-19000000),linethick0;
{天数:BARSLAST(DATE<=1140101);
累积换手:=SUM(HSL,5);}
HS100:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=100,0),linethick0;
HS200:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=200,0),linethick0;
HS300:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=300,0),linethick0;
HS400:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=400,0),linethick0;
HS500:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=500,0),linethick0;
HS600:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=600,0),linethick0;
HS700:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=700,0),linethick0;
HS800:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=800,0),linethick0;
HS900:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=900,0),linethick0;
HS1000:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=1000,0),linethick0;
DRAWTEXT(CROSS(HS100,0.99),L*0.94,'换100'),COLORYELLOW;
DRAWICON(CROSS(HS100,0.99),L*0.98,1);
DRAWTEXT(CROSS(HS200,0.99),L*0.94,'换200'),COLORGREEN;
DRAWICON(CROSS(HS200,0.99),L*0.98,1);
DRAWTEXT(CROSS(HS300,0.99),L*0.94,'换300'),COLORWHITE;
DRAWICON(CROSS(HS300,0.99),L*0.98,1);
DRAWTEXT(CROSS(HS400,0.99),L*0.97,'换400'),COLORWHITE;
DRAWTEXT(CROSS(HS500,0.99),L*0.97,'换500'),COLORWHITE;
DRAWTEXT(CROSS(HS600,0.99),L*0.97,'换600'),COLORWHITE;
DRAWTEXT(CROSS(HS700,0.99),L*0.97,'换700'),COLORWHITE;
DRAWTEXT(CROSS(HS800,0.99),L*0.97,'换800'),COLORWHITE;
DRAWTEXT(CROSS(HS900,0.99),L*0.97,'换900'),COLORWHITE;
DRAWTEXT(CROSS(HS1000,0.99),L*0.97,'换1000'),COLORWHITE;
X1:=STRFIND(BKNAME,'自选股,',1); x2:=STRFIND(BKNAME,'自选股1底部,',1);
x3:=STRFIND(BKNAME,'自选股2平台,',1); x4:=STRFIND(BKNAME,'自选股A绩优,',1);
x5:=STRFIND(BKNAME,'自选股B绩优增仓,',1);
x:=max(1,x1,x2,x3,x4,x5);
x1:= if(x=x1,7,if(x=x2 or x=x3 or x=x4,12,if(x=x5,16,0)));
{BK1:=STRMID(BKNAME,x+x1,8); X6:=if(STRFIND(BK1,',',1)<>0,STRFIND(BK1,',',1),9);
BK:=STRMID(BKNAME,x+x1,x6-1);}
BK:=STRMID(BKNAME,x+x1,200);
DRAWTEXTABS(0,10,'板块名称:'+BK),Color9DFFFF;

大智慧换手和板块主图指标公式

 

相关文章