在线检测未来函数

大智慧风险评估指标公式

来源:Internet,编辑:股旁网,2015-04-02

n:=55;
活期存款利率:=0.81*1.0;
一年期存款利率:=3.87*1.0;
三年期存款利率:=5.22*1.0;
名义无风险利率:=一年期存款利率;
风险补偿率:=0.03986;
投资期望收益率:=名义无风险利率+风险补偿率;
风险补偿率二:=0.03986;
名义无风险利二:=三年期存款利率;
i2:=名义无风险利二+风险补偿率二;
v0:=1/(1+投资期望收益率);
x0:=1/(1+i2);
m2:=1;
k1:=0.68;
k11:=0.75;
v1:=(POW(1+投资期望收益率,K1)-1)/投资期望收益率;
x1:=(POW(1+i2,K11)-1)/i2;
g:=0.03;
m:=2;
g2:=0.05;
v2:=1-POW((1+g)/(1+投资期望收益率),m-1);
x2:=1-POW((1+g2)/(1+i2),m2-1);
v3:=(1+g)*v2/(投资期望收益率-g);
x3:=(1+g2)*x2/(i2-g2);
v4:=POW(v0,k1+(m-1))/投资期望收益率;
x4:=POW(x0,k11+(m2-1))/i2;
v5:=(v1+v3);
x5:=(x1+x3);
每股收益:=FINANCE2(3);
预期每股收益:=0.278;
预期每股收益二:=0.29;
股息分配比例:=0.35;
股息分配比例二:=0.42;
红股折算股息:=0.12;
红股折算股息二:=0.09;
现金股息:=预期每股收益*股息分配比例;
现金股息二:=预期每股收益二*股息分配比例二;
基准股息:=现金股息+红股折算股息;
基准股息二:=现金股息二+红股折算股息二;
d:=基准股息;
d2:=基准股息二;
上证指数平均价:="SH000001$AMOUNT"/"SH000001$VOL"/100;
深圳成指平均价:="SZ399001$AMOUNT"/"SZ399001$VOL"/100;
沪深个股平均价:=("SH000001$AMOUNT"+"SZ399001$AMOUNT")/("SH000001$VOL"+"SZ399001$VOL")/100;
股票平均成交价:=AMOUNT/(VOL*100);
股票理论价格:=d*POW(V0,K1)*v5+d*POW(1+g,m-1)*v4;
股票理论价格二:=d2*POW(x0,K11)*x5+d2*POW(1+g2,m2-1)*x4;
股价泡沫率估算:=100*(股票平均成交价-股票理论价格)/股票理论价格/1000;
泡沫估算二:=100*(股票平均成交价-股票理论价格二)/股票理论价格二;
今成交均价:=股票平均成交价;
理论价估算:=股票理论价格;
理论价二:=股票理论价格二;
每股市盈率:=DYNAINFO(39);
股票合理市赢率:=股票理论价格/预期每股收益*100;
股票合理市赢二:=股票理论价格二/预期每股收益二;
合理市赢二:=股票合理市赢二;
十日均价泡沫估:=100*(ma(股票平均成交价,10)-股票理论价格)/股票理论价格/1000;
{趋势+逃顶 参数n:40 100 55 }
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
个股升降坐标:IF(VAR6>n,VAR6-n,0),PRECIS2,colorf00ff0;
STICKLINE(REF(个股升降坐标,1)<个股升降坐标,个股升降坐标,REF(个股升降坐标,1),5,0),colorf00ff0;
STICKLINE(REF(个股升降坐标,1)>个股升降坐标,个股升降坐标,REF(个股升降坐标,1),5,0),color00ff00;
历史最高成交价:=HHV(HIGH,0);
历史最低成交价:=LLV(LOW,0);
H1:=INDEXA;
大盘短线压力:=(((INDEXC + INDEXL) + INDEXH) / 3);
XHH:=((INDEXA / INDEXV) / 100);
短线支撑:=(IF((INDEXC > 200),大盘短线压力,XHH) - INDEXL);
大盘短线支撑:=(INDEXC - 短线支撑);
VAR193:=(INDEXC + 短线支撑);
DRAWTEXTABS(20,5,'■活期存款利率:'+NUMTOSTRN(活期存款利率,2)+'%'),Color00FFFF;
DRAWTEXTABS(170,5,'■一年期存款利率:'+NUMTOSTRN(一年期存款利率,2)+'%'),Color00FFFF;
DRAWTEXTABS(325,5,'■三年期存款利率:'+NUMTOSTRN(三年期存款利率,2)+'%'),Color00FFFF;
DRAWTEXTABS(490,5,'■存款名义无风险利率:'+NUMTOSTRN(名义无风险利率,2)+'%'),Color00FFFF;
DRAWTEXTABS(20,20,'■存款风险补偿率:'+NUMTOSTRN(风险补偿率,2)+'%'),Color00FFFF;
DRAWTEXTABS(170,20,'■个股股息分配比例:'+NUMTOSTRN(股息分配比例,2)+'%'),Color00FFFF;
DRAWTEXTABS(325,20,'■个股分红折算股息:'+NUMTOSTRN(红股折算股息,2)+'元'),Color00FFFF;
DRAWTEXTABS(490,20,'■持有个股基准股息:'+NUMTOSTRN(基准股息,2)+'元/股'),Color00FFFF;
DRAWTEXTABS(20,75,'■当前每股收益:'+NUMTOSTRN(每股收益,2)+'元'),Color00FF00;
DRAWTEXTABS(175,75,'■理想预期每股收益:'+NUMTOSTRN(预期每股收益,2)+'元'),Color00FF00;
DRAWTEXTABS(345,75,'■当前每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),Color00FF00;
DRAWTEXTABS(520,75,'■个股合理市赢率:'+NUMTOSTRN(股票合理市赢率,2)+'倍'),Color00FF00;
DRAWTEXTABS(680,75,'■投资期望收益率:'+NUMTOSTRN(投资期望收益率,2)+'%'),Color00FF00;
DRAWTEXTABS(20,90,'■上证指数均价:'+NUMTOSTRN(上证指数平均价,2)+'元'),ColorFFFFFF;
DRAWTEXTABS(175,90,'■深圳成指均价:'+NUMTOSTRN(深圳成指平均价,2)+'元'),ColorFFFFFF;
DRAWTEXTABS(345,90,'■沪深个股平均价:'+NUMTOSTRN(沪深个股平均价,2)+'元'),ColorFFFFFF;
DRAWTEXTABS(520,90,'■个股对应大盘平均成交价:'+NUMTOSTRN(股票平均成交价,2)+'元'),ColorFFFFFF;
DRAWTEXTABS(20,105,'■对应经济周期【股价泡沫率】估算:'+NUMTOSTRN(股价泡沫率估算,0)+'% →'),ColorFFFF00;
DRAWTEXTABS(265,105,'当前个股成交均价:'+NUMTOSTRN(今成交均价,2)+'元 →'),ColorFFFF00;
DRAWTEXTABS(440,105,'对应经济周期十日【均价泡沫率】估算:'+NUMTOSTRN(十日均价泡沫估,0)+'%'),ColorFFFF00;
DRAWTEXTABS(20,120,'■历史最高成交价:'+NUMTOSTRN(历史最高成交价,2)+'元'),Color0000FF;
DRAWTEXTABS(200,120,'■历史最低成交价:'+NUMTOSTRN(历史最低成交价,2)+'元'),Color0000FF;
DRAWTEXTABS(370,120,'■大盘短线压力: '+NUMTOSTRN(大盘短线压力,2)+'点'),Color0000FF;
DRAWTEXTABS(540,120,'■大盘短线支撑: '+NUMTOSTRN(大盘短线支撑,2)+'点'),Color0000FF;

大智慧风险评估指标公式

 

相关文章