在线检测未来函数

通达信动态成交量指标公式

来源:Internet,编辑:股旁网,2015-04-06

DRAWGBK(CURRBARSCOUNT=1, RGB(110,108,108),RGB(88,30,0),0,'',0);
STICKLINE(C>0,-100,100,15,0)COLOR0080FF;
A1:=COST(85);A2:=COST(15);A3:=A1-A2;A4:=(A1+A2)/2;
单峰密集:A3/A4*100<15,LINETHICK0;B1:=HHV(HIGH,250);
B2:=LLV(LOW,250);B3:=B1-B2;低位:A4<(B3*0.4+B2),LINETHICK0;
低位单峰密集:单峰密集 AND 低位,COLORRED;高位:A4>(B3*0.7+B2),LINETHICK0;
高位单峰密集:单峰密集 AND 高位,COLORGREEN;
{三位一体选股公式}STICKLINE(OPEN>=CLOSE,VOL,0,3,0),COLORAAAAAA;
STICKLINE(OPEN>=CLOSE,VOL,0,2.5,0),COLORBBBBBB;
STICKLINE(OPEN>=CLOSE,VOL,0,0.4,0),COLORCCCCCC;
STICKLINE(OPEN>=CLOSE,VOL,0,0.1,0),COLORDDDDDD;
STICKLINE(CLOSE>OPEN,VOL,0,3,0),COLOR6666CC;
STICKLINE(CLOSE>OPEN,VOL,0,2.4,0),COLOR7777DD;
STICKLINE(CLOSE>OPEN,VOL,0,0.4,0),COLOR8888EE;
STICKLINE(CLOSE>OPEN,VOL,0,1.1,0),COLOR9999FF;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0,0),COLOR1199FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0,0),COLOR1199FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0,0),COLORCCCCCC;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0,0),COLORCCCCCC;VAR1:=DYNAINFO(17)*REF(MA(VOL,5),1);
VAR2:STICKLINE(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,0,2.6,1);
VARC:=(SMA(ABS(LOW-REF(LOW,1)),3,1))/(SMA(MAX(LOW-REF(LOW,1),0),3,1));
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
RSV:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
K:=SMA(RSV,6,1);D:=SMA(K,3,1);J:=3*K-2*D;LC:=REF(CLOSE,1);
XA:=(IF(CROSS(J1,J) AND J<20,-1,0))+(IF(CROSS(J,J1) AND J>80,1,0));
TYP:=(HIGH+LOW+CLOSE)/3;CCJ:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))/2;
RSI1:=(SMA(MAX(CLOSE-LC,0),6,1))/(SMA(ABS(CLOSE-LC),6,1))*100;
VAR222:=LLV(LOW,36);VAR333:=HHV(HIGH,36);
K2:=EMA((CLOSE-VAR222)/(VAR333-VAR222)*100,9);
XB:=(IF(CCJ>100 AND K2>50 AND CLOSE>OPEN,0.5,0))+(IF(RSI1>80 AND K2>50 AND CLOSE>OPEN,0.5,0));
RSV3:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;
K13:=SMA(RSV3,21,1);D13:=SMA(K1,3,1);J13:=3*K13-2*D13;XC:=IF(J13>80 AND RSI1>85,0.5,0);
金指:EMA(IF(LOW<=LLV(LOW,30),VARC,0),3)*150,LINETHICK2,COLORFF0000;
IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2),COLORFF0000;
警戒线:(IF(XA+XB+XC>0,61.8,0))*150,COLORYELLOW,LINETHICK2;
DRAWTEXT(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VOL,'动态行情VOL'),COLORYELLOW,LINETHICK2;

通达信动态成交量指标公式

 

相关文章